cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3512
Views
0
Helpful
8
Replies

How do I disable MAC flapping message?

Difan Zhao
Contributor
Contributor

Hi experts, is there a way to disable this alert?

Jun 26 13:08:19 MDT: %SW_MATM-4-MACFLAP_NOTIF: Host 0050.56ac.5e9f in vlan 265 is flapping between port Gi1/0/19 and port Gi1/0/17

It turned out to be some server behavior... It picks different link when sending packets..

Thanks,

8 Replies 8

pille1234
Participant
Participant

The warning message is there for a reason. I suggest you disable the root cause and not the warning. Depending on the switch type you use the switch will eventually disable dynamic mac address learning completely for a given time period to protect its CPU, thus resulting in packet loss.

Agree... I am trying to find the people who could fix the root cause. However just being curious, is it possible to disable the message? Thanks,

Alexander Pai
Beginner
Beginner

Generally, I wouldn't recommend trying to disable this check since it's typically a clear indication of spanning tree loop.

What does the physical and virtual topology look like?  The MAC address assigned is a VMWare address, so it's possible your virtual networking is not setup properly.  For example, you may have multiple VM's sharing the same virtual MAC address.

I traced the cables. Both ports (reporting the flapping) are connected with one physical server box. That box has label something like ESXhost in the name so I assumed that it is VM which is causing the grief. I am trying to find right team to report this issue... Right now just want to know my option I have on the switch. Thanks

It's also possible the host was setup to use Etherchannel, without setting it up on the switch side as well.  In either case, you'll have to work with your server folks to determine the correct configuration.

Thanks. once I found the right person I certain will discuss all the options. However is it not possble to disable the message on the switch temporarily? It is spamming the log pretty bad. It is WS-C3750G-24TS-1U with IOS 12.2(44)SE5

Thanks

Not really an easy way to do it, since you'd have to write an EEM script to suppress the message.  It still wouldn't avoid the CPU overhead anyway since the event is still being detected/observed, but just suppressing the error message.

The recommended action is usually disabling one of the ports.  The persistant flapping will cause constant updates to the mac address tables and impact to the CPU with the errors.  Return traffic will also flip flop between the two links.

I see. Right now I don't think there is a loop if that's what you worried. The CPU is only average 10%. Both interfaces has <5mbps usage. If there is no way to turn the message off then I will have to get server guy to fix their problem...

Thanks

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers