cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
5566
Views
0
Helpful
5
Replies
dannyngo99
Beginner

How to add new subnet to existing network

We’ve merged two locations into one. We’d like to add new subnet 192.168.201.0

To existing network 192.168.7.0

Our current devices: 1751 router will be replaced with 2621xm with 2 WICs (2 full T1 lines).We want to dedicate a full T1 line for 2 servers located on new subnet.

C2950G switch and 3524XL switch. We also add two 2950 (24ports) SI. How do I configure to let users on subnet 192.168.7.0 to communicate to two servers on new subnet 192.168.201.0

Thanks in advance.

Danny.

5 REPLIES 5
Georg Pauwen
VIP Expert

Hello Danny,

are the servers and the clients located at the same site ?

Basically, you either add a secondary IP address to an existing (Fast)Ethernet interface of the 2621XM router, or you configure a trunk between the switch and the router, in order for the VLANs to be able to talk to each other.

What do you mean by dedicating a full T1 for the two servers ? Who is accessing the servers, and from where ?

Regards,

GP

Hi Gp,

Thanks for your input.We decided to have all devices on one subnet 192.168.7.0.All servers and clients are located in the same site (LAN).Our database and image servers ip addresses are 192.168.7.5 and 192.168.7.6 respectively.We've just added new T1 line to SECOND Serical inferface (WIC#2).We'd like to dedicate this T1 bandwidth to these two servers.

they are accessed by local users and remote branch users. here is the 2621xm router config:

Can I use IP CEF Load-sharing per-destination command to allocate the new T1 bandwidth for ONLY Database and image SERVERS. The orther T1 is utilized by the rest of LAN users? Do i need to add any other command to make it work?

Thanks,

OPS#sh run

Building configuration...

Current configuration : 1578 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

service udp-small-servers

service tcp-small-servers

!

hostname OPS

!

boot-start-marker

boot-end-marker

enable secret xxx

enable password xxx

!

no network-clock-participate slot 1

no network-clock-participate wic 0

no aaa new-model

ip subnet-zero

ip cef

!

no ftp-server write-enable

!

class-map match-any VOIP

match ip dscp ef

!

!

policy-map VOIP-QOS

class VOIP

priority 1158

class class-default

fair-queue

random-detect dscp-based

interface FastEthernet0/0

ip address 192.168.157.1 255.255.255.0 secondary

ip address 192.168.7.1 255.255.255.0

speed auto

full-duplex

no mop enabled

!

interface Serial0/0

ip unnumbered FastEthernet0/0

service-policy output VOIP-QOS

no ip mroute-cache

!

interface Serial0/1

ip unnumbered FastEthernet0/0

service-policy output VOIP-QOS

no ip mroute-cache

!

router eigrp 15

network 192.168.1.0

network 192.168.2.0

network 192.168.3.0

network 192.168.4.0

network 192.168.5.0

network 192.168.6.0

network 192.168.7.0

network 192.168.8.0

network 192.168.151.0

network 192.168.152.0

network 192.168.153.0

network 192.168.154.0

network 192.168.155.0

network 192.168.156.0

network 192.168.157.0

network 192.168.158.0

no auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.1.5

ip http server

!

dialer-list 1 protocol ip permit

!

line con 0

line aux 0

line vty 0 4

password xxx

login

end

OPS#sh ver

Cisco Internetwork Operating System Software

IOS (tm) C2600 Software (C2600-IPBASE-M), Version 12.3(6e), RELEASE SOFTWARE (fc3)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2005 by cisco Systems, Inc.

Compiled Fri 01-Apr-05 03:01 by hqluong

Image text-base: 0x80008098, data-base: 0x80ED1544

ROM: System Bootstrap, Version 12.2(8r) [cmong 8r], RELEASE SOFTWARE (fc1)

ROM: C2600 Software (C2600-IPBASE-M), Version 12.3(6e), RELEASE SOFTWARE (fc3)

OPS uptime is 1 hour, 54 minutes

System returned to ROM by power-on

System image file is "flash:c2600-ipbase-mz.123-6e.bin"

cisco 2620XM (MPC860P) processor (revision 0x401) with 126976K/4096K bytes of memory.

Processor board ID FTX0926A1DJ (3720557725)

M860 processor: part number 5, mask 2

Bridging software.

X.25 software, Version 3.0.0.

1 FastEthernet/IEEE 802.3 interface(s)

2 Serial network interface(s)

32K bytes of non-volatile configuration memory.

32768K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

Hello,

quick question: is this a legacy configuration that has been used before in another setup ? If you can also post the configuration of the remote site router, I can try and give you a working config without the stuff that I think is not necessary...

Regards,

GP

Hi GP,

Yes, it s a legancy configuration.Here is the config of remote site router.

Thanks,

Danny.

Larch1#sh run

Building configuration...

Current configuration : 1310 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

service password-encryption

service udp-small-servers

service tcp-small-servers

!

hostname Larch1

!

enable secret xxx

enable password -----

!

ip subnet-zero

!

!

!

no ip bootp server

!

class-map match-any VOIP

match ip dscp 46

!

!

policy-map VOIP-QOS

class VOIP

priority 1158

class class-default

fair-queue

random-detect dscp-based

!

!

!

!

interface FastEthernet0/0

ip address 192.168.151.1 255.255.255.0 secondary

ip address 192.168.1.1 255.255.255.0

speed auto

full-duplex

!

interface Serial0/0

ip unnumbered FastEthernet0/0

service-policy output VOIP-QOS

!

interface Serial0/1

ip unnumbered FastEthernet0/0

service-policy output VOIP-QOS

!

router eigrp 15

network 192.168.1.0

network 192.168.2.0

network 192.168.3.0

network 192.168.4.0

network 192.168.5.0

network 192.168.6.0

network 192.168.7.0

network 192.168.8.0

network 192.168.9.0

network 192.168.151.0

network 192.168.152.0

network 192.168.153.0

network 192.168.154.0

network 192.168.155.0

network 192.168.156.0

network 192.168.157.0

network 192.168.158.0

network 192.168.201.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.1.5

ip route 170.209.0.2 255.255.255.255 192.168.1.44

ip route 170.209.0.3 255.255.255.255 192.168.1.44

ip http server

ip pim bidir-enable

!

!

!

line con 0

line aux 0

line vty 0 4

password ----

login

!

!

end

Larch1#

Larch1#sh ver

Cisco Internetwork Operating System Software

IOS (tm) C2600 Software (C2600-I-M), Version 12.2(8)T5, RELEASE SOFTWARE (fc1)

TAC Support: http://www.cisco.com/tac

Copyright (c) 1986-2002 by cisco Systems, Inc.

Compiled Fri 21-Jun-02 08:50 by ccai

Image text-base: 0x80008074, data-base: 0x80A2BD40

ROM: System Bootstrap, Version 12.2(7r) [cmong 7r], RELEASE SOFTWARE (fc1)

Larch1 uptime is 47 weeks, 4 days, 3 hours, 10 minutes

System returned to ROM by power-on

System image file is "flash:c2600-i-mz.122-8.T5.bin"

cisco 2610XM (MPC860P) processor (revision 0x100) with 28672K/4096K bytes of mem

ory.

Processor board ID JAD07040MRM (2162841338)

M860 processor: part number 5, mask 2

Bridging software.

X.25 software, Version 3.0.0.

1 FastEthernet/IEEE 802.3 interface(s)

2 Serial network interface(s)

32K bytes of non-volatile configuration memory.

16384K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

Hello,

check out this config, I made some additions and took some things out. I would not use IP unnumbered on the serial interfaces, because when the FastEthernet interface would go down, you would not be able to access the router through the serial interface either, in order to troubleshoot:

OPS#sh run

Building configuration...

Current configuration : 1578 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

service udp-small-servers

service tcp-small-servers

!

hostname OPS

!

boot-start-marker

boot-end-marker

enable secret xx

enable password xxx

!

no network-clock-participate slot 1

no network-clock-participate wic 0

no aaa new-model

ip subnet-zero

ip cef

!

no ftp-server write-enable

!

class-map match-any VOIP

match ip dscp ef

!

!

policy-map VOIP-QOS

class VOIP

priority 1158

class class-default

fair-queue

random-detect dscp-based

interface Loopback0

ip address 1.x.x.x.255.255.255

!

interface FastEthernet0/0

ip address 192.168.157.1 255.255.255.0 secondary

ip address 192.168.7.1 255.255.255.0

speed auto

full-duplex

no mop enabled

!

interface Serial0/0

ip address 192.168.2.1 255.255.255.252

service-policy output VOIP-QOS

no ip mroute-cache

!

interface Serial0/1

ip address 192.168.3.1 255.255.255.252

service-policy output VOIP-QOS

no ip mroute-cache

!

router eigrp 15

eigrp router-id 1.1.1.1

network 1.x.x.1

network 192.168.2.0

network 192.168.3.0

network 192.168.7.0

network 192.168.157.0

no auto-summary

!

ip classless

ip route 0.0.0.0 0.0.x.x.x.1.5

ip http server

!

line con 0

line aux 0

line vty 0 4

password xxx

login

end

Larch1#sh run

Building configuration...

Current configuration : 1310 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

service password-encryption

service udp-small-servers

service tcp-small-servers

!

hostname Larch1

!

enable secret xxxx

enable password -----

!

ip subnet-zero

!

!

!

no ip bootp server

!

class-map match-any VOIP

match ip dscp 46

!

!

policy-map VOIP-QOS

class VOIP

priority 1158

class class-default

fair-queue

random-detect dscp-based

!

interface Loopback0

ip address 2.x.x.x.255.255

!

interface FastEthernet0/0

ip address 192.168.151.1 255.255.255.0 secondary

ip address 192.168.1.1 255.255.255.0

speed auto

full-duplex

!

interface Serial0/0

ip address 192.168.2.2 255.255.255.252

service-policy output VOIP-QOS

!

interface Serial0/1

ip address 192.168.3.2 255.255.255.252

service-policy output VOIP-QOS

!

router eigrp 15

eigrp router-id 2.x.2

network 192.168.1.0

network 192.168.2.0

network 192.168.3.0

network 192.168.7.0

network 192.168.151.0

no auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.x.x.1.5

ip route 170.209.x.x.x.255.255 192.168.1.44

ip route 170.209.x.x.x.255.255 192.168.1.44

ip http server

ip pim bidir-enable

!

!

!

line con 0

line aux 0

line vty 0 4

password ----

login

!

!

end

Regards,

GP