cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
6013
Views
15
Helpful
4
Replies
Highlighted
Beginner

How to verify Auto QoS is working?

We implemented auto qos on our 2960's access ports and uplink ports to support Cisco Jabber. How can we verify that QoS is working?

 

interface GigabitEthernet1/0/19
switchport access vlan 301
switchport mode access
switchport voice vlan 64
power inline auto max 15400
srr-queue bandwidth share 1 30 35 5
priority-queue out
auto qos voip cisco-softphone
spanning-tree portfast
service-policy input AUTOQOS-SRND4-SOFTPHONE-POLICY
end

 

interface GigabitEthernet5/0/48
switchport mode trunk
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust dscp
auto qos trust
end

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Try "show mls qos interface gigX/X/X statistics". Apparently there's a bug stating the initial command I supplied is invalid due to hardware limitations.

 

https://bst.cloudapps.cisco.com/bugsearch/bug/CSCso80701

View solution in original post

4 REPLIES 4
Highlighted
Participant

show policy-map interface X/X

Highlighted

Okay, so that's what I thought, but not what I was hoping for. It seems to me that it's not working then? Where do I go from here?

 

switch#sh policy-map interface gi1/0/19
 GigabitEthernet1/0/19

  Service-policy input: AUTOQOS-SRND4-SOFTPHONE-POLICY

    Class-map: AUTOQOS_VOIP_DATA_CLASS (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0000 bps, drop rate 0000 bps
      Match: ip dscp ef (46)

    Class-map: AUTOQOS_MULTIENHANCED_CONF_CLASS (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0000 bps, drop rate 0000 bps
      Match: access-group name AUTOQOS-ACL-MULTIENHANCED-CONF

    Class-map: AUTOQOS_BULK_DATA_CLASS (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0000 bps, drop rate 0000 bps
      Match: access-group name AUTOQOS-ACL-BULK-DATA

    Class-map: AUTOQOS_TRANSACTION_CLASS (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0000 bps, drop rate 0000 bps
      Match: access-group name AUTOQOS-ACL-TRANSACTIONAL-DATA

    Class-map: AUTOQOS_SCAVANGER_CLASS (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0000 bps, drop rate 0000 bps
      Match: access-group name AUTOQOS-ACL-SCAVANGER

    Class-map: AUTOQOS_SIGNALING_CLASS (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0000 bps, drop rate 0000 bps
      Match: access-group name AUTOQOS-ACL-SIGNALING

    Class-map: AUTOQOS_DEFAULT_CLASS (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0000 bps, drop rate 0000 bps
      Match: access-group name AUTOQOS-ACL-DEFAULT

    Class-map: class-default (match-any)
      0 packets, 0 bytes
      5 minute offered rate 0000 bps, drop rate 0000 bps
      Match: any
switch#
Highlighted

Try "show mls qos interface gigX/X/X statistics". Apparently there's a bug stating the initial command I supplied is invalid due to hardware limitations.

 

https://bst.cloudapps.cisco.com/bugsearch/bug/CSCso80701

View solution in original post

Highlighted

switch#show mls qos interface gi2/0/21 statistics
GigabitEthernet2/0/21 (All statistics are in packets)

  dscp: incoming
-------------------------------

  0 -  4 :   115878134            0            0            0            0
  5 -  9 :           0            0            0            0            0
 10 - 14 :           0            0            0            0            0
 15 - 19 :           0            0            0         1840            0
 20 - 24 :           0            0            0            0            0
 25 - 29 :           0            0            0            0            0
 30 - 34 :           0            0            0            0            0
 35 - 39 :           0            0            0            0            0
 40 - 44 :           0            0            0            0            0
 45 - 49 :           0       294867            0            0            0
 50 - 54 :           0            0            0            0            0
 55 - 59 :           0            0            0            0            0
 60 - 64 :           0            0            0            0
  dscp: outgoing
-------------------------------

  0 -  4 :   184920242            0          898            0           63
  5 -  9 :           0            0            0       165026            0
 10 - 14 :           6            0            0            0            0
 15 - 19 :           0            0            0         8940            0
 20 - 24 :           4            0            0            0       434421
 25 - 29 :           0            0            0            0            0
 30 - 34 :           0            0            0            0         9358
 35 - 39 :           0            0            0            0            0
 40 - 44 :           0            0            0            0            1
 45 - 49 :           0      7234479            0      2737842            0
 50 - 54 :         180            0            0            0            0
 55 - 59 :           0            0            0            0            0
 60 - 64 :           0            0            0            0
  cos: incoming
-------------------------------

  0 -  4 :   116206577            0            0            0            0
  5 -  7 :           0            0            0
  cos: outgoing
-------------------------------

  0 -  4 :   196092323       167633        10778        19370        15946
  5 -  7 :      128287        43870      2496850
  output queues enqueued:
 queue:    threshold1   threshold2   threshold3
-----------------------------------------------
 queue 0:           0           0      127657
 queue 1:     6164217      308425     2546099
 queue 2:           0           0    40247895
 queue 3:      165026           6   149598665

  output queues dropped:
 queue:    threshold1   threshold2   threshold3
-----------------------------------------------
 queue 0:           0           0           0
 queue 1:           0           0           0
 queue 2:           0           0        1077
 queue 3:        4209           0        3095

Policer: Inprofile:      1020040 OutofProfile:       115404

Content for Community-Ad