cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
488
Views
0
Helpful
7
Replies

HSRP configuraiton

duahimanshu816
Level 1
Level 1

Hi,

I am new in HSRP configuration, please help me to come out from this issue.

I have one cisco 2800 Router and two Layer 2 Switch 2960 Cisco.
I have been told to make one switch redundant. if switch one goes down and traffic should flow to router from switch2.

i have two server which will connect with these two switches if one fails still able to access router through active switch.

please let me know what should i do.

thanks advance.

regards,
Himanshu Dua

1 Accepted Solution

Accepted Solutions

Hi Himanshu,

HSRP will not be a solution in your implementation.

You will need to look atintegrated routing & bridging.

This will create an Bridged Vitual Interface (BVI) on your router that the 2 ethernet
interfaces will bridge in to. Only one of these interfaces will carry traffic. When it fails the
other ethernet interface will take over.

Of course you wil need to use your own interface,Ip addresss & vlan numbers

Router config
=============

!
bridge irb
!
bridge 1 protocol ieee
bridge 1 route ip
!
int f0/0
descrition *** LINK TO SWITCH 0 ***
no ip address
bridge-group 1
no shut
!
int f0/1
descrition *** LINK TO SWITCH 1 ***
no ip address
bridge-group 1
no shut
!
!
int bvi 1
descrition *** L3 Bridged Virtual Router Interface ***
ip address 10.0.0.1 255.255.255.0
no shut
!
ip route 0.0.0.0 0.0.0.0 "NEXT-HOP- IP ADDRESS"
!More routes as required or routing protocol etc.
!

Switch 0 Config
===============

!
inteface fast 0/1
descrition *** LINK TO ROUTER FA0/0 ***
switchport mode access
switchport vlan 100
no shut
!

Switch 1 Config
===============

!
inteface fast 0/1
descrition *** LINK TO ROUTER FA0/1 ***
switchport mode access
switchport vlan 100
no shut
!

Your switches will need spanning tree. This will STP block
one of the links to the router. If the other link fails the blocking link wil
take over.

Hope this helps
Regards
Alex

Regards, Alex. Please rate useful posts.

View solution in original post

7 Replies 7

Mark Malone
VIP Alumni
VIP Alumni

The design you have there does not require HSRP to make the server redundent all you have to do is connect the server to the other layer 2 switch so it has dual connections , if one switch dies it will switch across the other

STP would take care of this at layer 2 by default , if you had 2 routers thats where you would setup HSRP for failover

Thanks for the reply mark,

sorry, may be i could not explain you well or i could not understand well.

My goel is to make one switch redundant to other switch.

I have only one router and two layer2 switches. 

Now my goel is to keep both two server into same network and should connect with both switches if one switch goes down and the traffic start flowing from second switch.

and you mean to say that :- connectivity between server and switch should be like server1/lan1/switch1/port1 and server1/lan2/switch2/port1 (nic teaming)

to configure HSRP do we need two router? 

 

 

Hi Himanshu,

HSRP will not be a solution in your implementation.

You will need to look atintegrated routing & bridging.

This will create an Bridged Vitual Interface (BVI) on your router that the 2 ethernet
interfaces will bridge in to. Only one of these interfaces will carry traffic. When it fails the
other ethernet interface will take over.

Of course you wil need to use your own interface,Ip addresss & vlan numbers

Router config
=============

!
bridge irb
!
bridge 1 protocol ieee
bridge 1 route ip
!
int f0/0
descrition *** LINK TO SWITCH 0 ***
no ip address
bridge-group 1
no shut
!
int f0/1
descrition *** LINK TO SWITCH 1 ***
no ip address
bridge-group 1
no shut
!
!
int bvi 1
descrition *** L3 Bridged Virtual Router Interface ***
ip address 10.0.0.1 255.255.255.0
no shut
!
ip route 0.0.0.0 0.0.0.0 "NEXT-HOP- IP ADDRESS"
!More routes as required or routing protocol etc.
!

Switch 0 Config
===============

!
inteface fast 0/1
descrition *** LINK TO ROUTER FA0/0 ***
switchport mode access
switchport vlan 100
no shut
!

Switch 1 Config
===============

!
inteface fast 0/1
descrition *** LINK TO ROUTER FA0/1 ***
switchport mode access
switchport vlan 100
no shut
!

Your switches will need spanning tree. This will STP block
one of the links to the router. If the other link fails the blocking link wil
take over.

Hope this helps
Regards
Alex

Regards, Alex. Please rate useful posts.

thanku very much Alex

this is the answer i was looking for. 

one more thing to ask stp will work  by default ryt no any aditinal configuration require on switch?

thanx again.

i got it now.

i have attached final desing.

you can still configure hsrp between the switches vlan interfaces if you wish im just saying if its only to setup redundency for the server it just needs 2 connections one connected to each switch , as its layer 2 stp will shut one by default uintil the other fails and then come up, it does this to prevent loops

heres the config you need just change the ips to what you have , devices will still need to be dual homed to each switch if you want hsrp set

HSRP is usually by design configured on the layer 3 devices in your network so usually between the routers or between 6500 switches that would be layer 3 set.

Router A Configuration

Switch# configure terminal
Switch(config)# interface vlan1
Switch(config-if)# no switchport
Switch(config-if)# ip address 10.0.0.1 255.255.255.0
Switch(config-if)# standby 1 ip 10.0.0.3
Switch(config-if)# standby 1 priority 110
Switch(config-if)# standby 1 preempt
Switch(config-if)# standby 2 ip 10.0.0.4
Switch(config-if)# standby 2 preempt
Switch(config-if)# end
 

Router B Configuration

Switch# configure terminal
Switch(config)# interface vlan 1
Switch(config-if)# no switchport
Switch(config-if)# ip address 10.0.0.2 255.255.255.0
Switch(config-if)# standby 1 ip 10.0.0.3
Switch(config-if)# standby 1 preempt
Switch(config-if)# standby 2 ip 10.0.0.4
Switch(config-if)# standby 2 priority 110
Switch(config-if)# standby 2 preempt
Switch(config-if)# end

Hi Himanshu

Do make sure you are running spanning tree.

On your switches

show spanning-tree summary

You should see output something like this:-

Switch is in rapid-pvst mode
Root bridge for: none
Extended system ID           is enabled
Portfast Default             is disabled
PortFast BPDU Guard Default  is enabled
Portfast BPDU Filter Default is disabled
Loopguard Default            is disabled
EtherChannel misconfig guard is enabled
UplinkFast                   is disabled
BackboneFast                 is disabled
Configured Pathcost method used is short

Name                   Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------
VLAN0010                     0         0        0          1          1
....<MORE>.....

Regards
Alex

Regards, Alex. Please rate useful posts.
Review Cisco Networking for a $25 gift card