03-26-2019 03:35 AM
Hi all,
So I've put a HWIC 9ESW into a 2801 that I've been using for telephony, and am having problems getting to it work :-)
I've read all the similar posts on this subject that I can find, but am still stuck.
This is from the 2801 in question, minus lots of telephony stuff:
interface FastEthernet0/0 ip address 10.10.10.24 255.255.255.0 speed 100 full-duplex no mop enabled ! interface Service-Engine0/0 ip unnumbered FastEthernet0/0 ip virtual-reassembly in service-module ip address 10.10.10.14 255.255.255.0 service-module ip default-gateway 10.10.10.24 ! interface FastEthernet0/1 no ip address duplex auto speed auto ! interface FastEthernet0/3/0 no ip address ! interface FastEthernet0/3/1 no ip address ! interface FastEthernet0/3/2 no ip address ! interface FastEthernet0/3/3 no ip address ! interface FastEthernet0/3/4 no ip address ! interface FastEthernet0/3/5 no ip address ! interface FastEthernet0/3/6 no ip address ! interface FastEthernet0/3/7 no ip address ! interface FastEthernet0/3/8 no ip address ! interface Vlan1 ip address 10.10.11.24 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 10.10.10.15
ip route 10.10.10.14 255.255.255.255 Service-Engine0/0
The VLAN on a different subnet was an experiment - ideally everything would be on the same 10.10.10 subnet.
sh vlan-switch VLAN Name Status Ports ---- -------------------------------- --------- ------------------------------- 1 default active Fa0/3/0, Fa0/3/1, Fa0/3/2, Fa0/3/3, Fa0/3/4, Fa0/3/5, Fa0/3/6, Fa0/3/7, Fa0/3/8 1002 fddi-default act/unsup 1003 token-ring-default act/unsup 1004 fddinet-default act/unsup 1005 trnet-default act/unsup
The gateway machine, an 887, has a VLAN 1 on 10.10.10.15:
ip dhcp pool pool1 import all network 10.10.10.0 255.255.255.0 dns-server 1.1.1.1 default-router 10.10.10.15 option 150 ip 10.10.10.24 lease infinite
!
interface Ethernet0
no ip address
!
interface Ethernet0.101
encapsulation dot1Q 101
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface FastEthernet0
no ip address
duplex half
speed 10
!
interface FastEthernet1
no ip address
duplex half
speed 10
spanning-tree portfast
!
interface FastEthernet2
no ip address
duplex full
speed 100
spanning-tree portfast
!
interface FastEthernet3
no ip address
duplex full
speed 100
!
interface Vlan1
ip address 10.10.10.15 255.255.255.0
ip pim dense-mode
ip nat inside
ip virtual-reassembly in
!
interface Dialer1
mtu 1492
ip address negotiated
ip access-group Inbound-IPv4 in
ip access-group Outbound-IPv4 out
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
ppp mtu adaptive
etc...
I've tried any number of things, but here I am :-)
Any and all suggestions welcome!
03-26-2019 04:35 AM
Hi,
What is your issue?
Regards,
Deepak Kumar
03-26-2019 05:42 AM
Haha forgot to mention that :-)
If I plug a mac into the hwic, and do a netstat -nr, it shows every IP address in the subnet, and there is no connectivity.
This happens in most of the configurations that I have tried.
Thanks.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide