cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
9228
Views
35
Helpful
18
Replies

I can not ping from one PC2 (vlan 10) to PC1 (vlan 20) with trunking (ROAS)

Leerical
Level 1
Level 1

Good morning all,

I've been following a video series that teaches VLANs, trunking, and subinterfaces. However, no matter how much I try to follow along I am not able to replicate the results of the video series. I've tried at least 5 times. My problem starts when I try to configure the router with subnets (encapsulation dot1q, etc). I then create a trunking connection to the switch from the router. Yet, no success in being able to communicate between PC2 (VLAN 10) to PC1 (VLAN 20). Any suggestions?pinging from PC2 to PC1pinging from PC2 to PC1RouterRouterSwitch 1Switch 1Switch 2Switch 2

18 Replies 18

PC1 is plugged to fa0/20 of Switch2, and PC2 is plugged to fa0/1 of Switch1. Switch1 fa0/2 is connected to Switch2 fa0/1, and Switch1 gi0/1 is connected to Router. Is this correct?
If yes, please share the output of "sh run" on the Router. And also share the output of "sh int fa0/20 switchport" from Switch2.

HTH,
Meheretab

That is correct!

 

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/0.10

encapsulation dot1Q 10

ip address 192.168.1.1 255.255.255.0

!

interface GigabitEthernet0/0.20

encapsulation dot1Q 20

ip address 192.168.2.128 255.255.255.0

!

interface GigabitEthernet0/1

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/2

no ip address

duplex auto

speed auto

!

interface Vlan1

no ip address

shutdown

!

router rip

!

ip classless

!

ip flow-export version 9

!

!

!

no cdp run

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

---------------------------------------------------------------------------------------

 

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/0.10

encapsulation dot1Q 10

ip address 192.168.1.1 255.255.255.0

!

interface GigabitEthernet0/0.20

encapsulation dot1Q 20

ip address 192.168.2.128 255.255.255.0

!

interface GigabitEthernet0/1

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/2

no ip address

duplex auto

speed auto

!

interface Vlan1

no ip address

shutdown

!

router rip

!

ip classless

!

ip flow-export version 9

!

!

!

no cdp run

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

Leerical,

Make sure a couple of things:-
1) Check the IP address on the PCs. For example, if you configure on PC2: IP address:192.168.1.6, Subnet Mask: 255.255.255.128 and Gateway: 192.168.1.1; and on PC1: IP address 192.168.1.150, Subnet Mask: 255.255.255.128 and Gateway: 192.168.1.129, then you will need to correct the configuration on the Router as follows:

interface GigabitEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.1.1 255.255.255.128
!

interface GigabitEthernet0/0.20
encapsulation dot1Q 20
ip address 192.168.1.129 255.255.255.128
!

2) To be sure, configure fa0/20 on Switch1 as follows:
int fa0/20
switchport access vlan 10
switchport mode access
!

P.S.:- By the way, thank you for the rating. However, You do not need to rate for all replies.

HTH,
Meheretab
HTH,
Meheretab

Thanks! It was a subnetting issue. Which I think someone said but I don't think it was explained in a way I completely understood. Which is on me. I rated everyone's replies because they were taking time out of their lives to fix an issue I was having. I thought it was only right to give back something. So, thanks to everyone for helping me troubleshoot!

Review Cisco Networking for a $25 gift card