cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
6199
Views
10
Helpful
13
Replies
Highlighted

IE 1000

How can i configure a IE 1000 by command line? I find no description about the commands i can use.

 

Is this not a complete IOS i have on router ?

 

The command "configure terminal" is not available.

 

best regards

 

13 REPLIES 13
Highlighted
Beginner

Did you ever get an answer on this? I've got some ie 1000's and have the same limitation.
Highlighted

>From Cisco's Product Support Page -
https://www.cisco.com/c/en/us/td/docs/switches/lan/cisco_ie1000/release_notes/b_ie1k_1-7rn.html
Release Notes for the Industrial Ethernet 1000 Switch (Software Release 1.7)
**Web GUI interface only**
Through a user-friendly web device manager, the Cisco IE 1000 provides easy out-of-the-box configuration and simplified operational manageability to deliver advanced and secure industrial networks.
Highlighted

There is a CLI to the IE 1000.  The datasheet also mentions SSH.  Ever see a GUI via SSH?

 

If I do this from an SSH session:

Switch# sh ver 

 

I get this:

SID : 1
------------------
Chipset ID : VSC7428
Board Type : IE-1000-8P2S-LM
Port Count : 10
Product : Cisco ie1k Switch
Software Version : ie1kVersion saturn-1.00-pre-4
Build Date : 2016-02-19T14:46:04+01:00
Code Revision : ae25591de820d71ccad08c363e59e5b5bd683f9b

 

Notice that is with 1.0.0 firmware and the latest is 1.8.0.

Highlighted

Hello

 

So there is no configure terminal in the IE1000 

 

Only some commands like show, version, flash, and so on.

 

best regards

 

Highlighted

Mine does; I was in config t in it yesterday.  I can add VLAN's, modify ports, etc.

 

Just like this:

Switch# sh run
Building configuration...
hostname Switch
username default-administrator privilege 15 password encrypted 867c591c2fc79c3b7b689d4e5e89a392ce1d5307ce939854412ac6dc00127e117b97aa8bf5f96880273b3a528cf230a8def7f51d32fe7f7b9d502311a88b7fa3
vlan 1,106
!
!
!
!
ip igmp snooping vlan 1
ntp server 1 ip-address x.x.x.x
spanning-tree mst name e4-aa-5d-dc-db-80 revision 0
no snmp-server
qos map dscp-cos 0 cos 1 dpl 0
qos map dscp-cos 1 cos 1 dpl 0
qos map dscp-cos 2 cos 1 dpl 0
qos map dscp-cos 3 cos 1 dpl 0
qos map dscp-cos 4 cos 1 dpl 0
qos map dscp-cos 5 cos 1 dpl 0
qos map dscp-cos 6 cos 1 dpl 0
qos map dscp-cos 7 cos 1 dpl 0
qos map dscp-cos 8 cos 0 dpl 0
qos map dscp-cos 9 cos 0 dpl 0
qos map dscp-cos 10 cos 0 dpl 0
qos map dscp-cos 11 cos 0 dpl 0
qos map dscp-cos 12 cos 0 dpl 0
qos map dscp-cos 13 cos 0 dpl 0
qos map dscp-cos 14 cos 0 dpl 0
qos map dscp-cos 15 cos 0 dpl 0
qos map dscp-cos 16 cos 2 dpl 0
qos map dscp-cos 17 cos 2 dpl 0
qos map dscp-cos 18 cos 2 dpl 0
qos map dscp-cos 19 cos 2 dpl 0
qos map dscp-cos 20 cos 2 dpl 0
qos map dscp-cos 21 cos 2 dpl 0
qos map dscp-cos 22 cos 2 dpl 0
qos map dscp-cos 23 cos 2 dpl 0
qos map dscp-cos 24 cos 3 dpl 0
qos map dscp-cos 25 cos 3 dpl 0
qos map dscp-cos 26 cos 3 dpl 0
qos map dscp-cos 27 cos 3 dpl 0
qos map dscp-cos 28 cos 3 dpl 0
qos map dscp-cos 29 cos 3 dpl 0
qos map dscp-cos 30 cos 3 dpl 0
qos map dscp-cos 31 cos 3 dpl 0
qos map dscp-cos 32 cos 4 dpl 0
qos map dscp-cos 33 cos 4 dpl 0
qos map dscp-cos 34 cos 4 dpl 0
qos map dscp-cos 35 cos 4 dpl 0
qos map dscp-cos 36 cos 4 dpl 0
qos map dscp-cos 37 cos 4 dpl 0
qos map dscp-cos 38 cos 4 dpl 0
qos map dscp-cos 39 cos 4 dpl 0
qos map dscp-cos 40 cos 5 dpl 0
qos map dscp-cos 41 cos 5 dpl 0
qos map dscp-cos 42 cos 5 dpl 0
qos map dscp-cos 43 cos 5 dpl 0
qos map dscp-cos 44 cos 5 dpl 0
qos map dscp-cos 45 cos 5 dpl 0
qos map dscp-cos 46 cos 7 dpl 0
qos map dscp-cos 47 cos 5 dpl 0
qos map dscp-cos 48 cos 6 dpl 0
qos map dscp-cos 49 cos 6 dpl 0
qos map dscp-cos 50 cos 6 dpl 0
qos map dscp-cos 51 cos 6 dpl 0
qos map dscp-cos 52 cos 6 dpl 0
qos map dscp-cos 53 cos 6 dpl 0
qos map dscp-cos 54 cos 6 dpl 0
qos map dscp-cos 55 cos 6 dpl 0
qos map dscp-cos 56 cos 7 dpl 0
qos map dscp-cos 57 cos 7 dpl 0
qos map dscp-cos 58 cos 7 dpl 0
qos map dscp-cos 59 cos 7 dpl 0
qos map dscp-cos 60 cos 7 dpl 0
qos map dscp-cos 61 cos 7 dpl 0
qos map dscp-cos 62 cos 7 dpl 0
qos map dscp-cos 63 cos 7 dpl 0
!
interface FastEthernet 1/1
switchport hybrid port-type unaware
switchport mode hybrid
lldp cdp-aware
qos trust tag
qos trust dscp
!
interface FastEthernet 1/2
switchport hybrid port-type unaware
switchport mode hybrid
lldp cdp-aware
qos trust tag
qos trust dscp
!
interface FastEthernet 1/3
switchport hybrid port-type unaware
switchport mode hybrid
lldp cdp-aware
qos trust tag
qos trust dscp
!
interface FastEthernet 1/4
switchport hybrid port-type unaware
switchport mode hybrid
lldp cdp-aware
qos trust tag
qos trust dscp
!
interface FastEthernet 1/5
switchport hybrid port-type unaware
switchport mode hybrid
lldp cdp-aware
qos trust tag
qos trust dscp
!
interface FastEthernet 1/6
switchport hybrid port-type unaware
switchport mode hybrid
lldp cdp-aware
qos trust tag
qos trust dscp
!
interface FastEthernet 1/7
switchport hybrid port-type unaware
switchport mode hybrid
lldp cdp-aware
qos trust tag
qos trust dscp
!
interface FastEthernet 1/8
switchport access vlan 106
switchport hybrid port-type unaware
switchport mode hybrid
lldp cdp-aware
qos trust tag
qos trust dscp
!
interface GigabitEthernet 1/1
switchport hybrid port-type unaware
switchport mode hybrid
lldp cdp-aware
qos trust tag
qos trust dscp
!
interface GigabitEthernet 1/2
switchport hybrid port-type unaware
switchport mode hybrid
lldp cdp-aware
qos trust tag
qos trust dscp
!
interface vlan 1
ip address 192.168.1.254 255.255.255.0
ip igmp snooping
ip igmp snooping querier election
ip igmp snooping compatibility auto
ip igmp snooping priority 0
ip igmp snooping robustness-variable 2
ip igmp snooping query-max-response-time 100
ip igmp snooping query-interval 125
ip igmp snooping last-member-query-interval 10
ip igmp snooping unsolicited-report-interval 1
!
interface vlan 106
ip address 192.168.6.119 255.255.255.0
!
!
spanning-tree aggregation
spanning-tree link-type point-to-point
!
!
line console 0
!
line vty 0
!
line vty 1
!
Switch# config t
Switch(config)# no int vlan 106
Switch(config)# no vlan 106
Switch(config)# int vlan 1
Switch(config-if-vlan)# ip add 192.168.6.119 255.255.255.0

 

 

Switch(config)# int gi 1/1
Switch(config-if)# switchport ?

access Set access mode characteristics of the interface
forbidden Adds or removes forbidden VLANs from the current list of
forbidden VLANs
hybrid Change PVID for hybrid port
mode Set mode of the interface
trunk Change PVID for trunk port
voice Voice appliance attributes

 

 

All available options under config t:

Switch(config)# ?
aaa Authentication, Authorization and Accounting
access Access management
access-list Access list
aggregation Aggregation mode
alarm alarm
banner Define a login banner
default Set a command to its defaults
do To run exec commands in config mode
dot1x IEEE Standard for port-based Network Access Control
enable Modify enable password parameters
end Go back to EXEC mode
exit Exit from current mode
help Description of the interactive help system
hostname Set system's network name
interface Select an interface to configure
ip Interface Internet Protocol config commands
ipmc IPv4/IPv6 multicast configuration
ipv6 IPv6 configuration commands
json JavaScript Object Notation RPC
lacp LACP settings
line Configure a terminal line
lldp LLDP configurations.
logging System logging message
mac MAC table entries/configuration
monitor Monitoring different system events
no Negate a command or set its defaults
ntp Configure NTP
poe Power Over Ethernet.
port-security Enable/disable port security globally.
post Power On Self Test
privilege Command privilege parameters
qos Quality of Service
radius-server Configure RADIUS
rmon Remote Monitoring
snmp-server Set SNMP server's configurations
spanning-tree Spanning Tree protocol
tacacs-server Configure TACACS+
temperature Temperature
username Establish User Name Authentication
vlan VLAN commands
voice Voice appliance attributes
web Web

Highlighted

Sorry in my switch i don´t have this command 

 

No Configure terminal 

 

Switch# show version

MAC Address : 74-86-0b-ef-85-00
Previous Restart : Power on

System Contact :
System Name : Switch
System Location :
System Time : 2019-02-15T10:59:15+00:00
System Uptime : 156d 02:53:18


Bootloader
----------
Image : RedBoot (bootloader)
Version : version 1_31-8c579cc
Date : 15:14:13, Jun 1 2016

Active Image
------------
Image : ie1000-universalk9-mz.spa.1.6.bin (primary)
Version : 1.6#2017-04-05T23:06:27+00:00
Date : 2017-04-05T17:25:27+02:00
Upload filename : ie1000-universalk9-mz.spa.1.6.bin

Backup Image
------------
Image : ie1000-universalk9-mz.spa.1.6.bin (backup)
Version : 1.6#2017-04-05T23:06:27+00:00
Date : 2017-04-05T17:25:27+02:00
Upload filename : ie1000-universalk9-mz.spa.1.6.bin

------------------
SID : 1
------------------
Chipset ID : VSC7428
Board Type : IE-1000-4P2S-LM
Port Count : 6
Product : Cisco IE1000 Switch
Software Version : 1.6#2017-04-05T23:06:27+00:00
Build Date : 2017-04-05T17:25:27+02:00
Code Revision : 510f5011c13892039fba9df91dda1ebf7e4fd752

 

Switch# ?
alarm alarm
clear Reset functions
copy Copy from source to destination
delete Delete one file in flash: file system
dir Directory of all files in flash: file system
disable Turn off privileged commands
do To run exec commands in config mode
dot1x IEEE Standard for port-based Network Access Control
enable Turn on privileged commands
exit Exit from EXEC mode
firmware Firmware upgrade/swap
help Description of the interactive help system
ip IPv4 commands
logout Exit from EXEC mode
more Display file
no no
ping Send ICMP echo messages
platform Platform configuration
reload Reload system.
send Send a message to other tty lines
show Show running system information
terminal Set terminal line parameters
veriphy Veriphy keyword
Switch#

Highlighted

It appears that version 1.3 was the initial release. Anything prior is not available to download, the release notes for 1.3 shows open caveats resolved issues is not even listed and the release notes themselves don't have the version in the filename like 1.6, 1.7 and 1.8 do.

 

So with mine being 1.0.0, this was an early build that was never release.  If I perform the reset steps for the express setup, they do work until you get to the password to login.  If I use cisco, then I get a 404 error.  If I use anything else, it just keeps asking for the username and password.  So the system knows the difference between a failed and successful authentication.  What doesn't exist is index.html and thus the GUI is nonexistent; I only have the CLI to configure the switch.  On my switch, the build date was February 5th 2016 and the build date for both images was February 19th, 2016.  I haven't been able to find the exact release date for the IE1000 but it looks like it was July 2016 or later.  My belief is my IE 1000 was a early production unit that was used for complaisance and certification testing.  The label on mine is pretty much blank.  It lists the model number, the model ID is in Chinese, the serial number and it says Cisco.  So 90% of the label is blank.

 

So internally, Cisco has or had a CLI version of the software for the IE 1000.  I just so happen to have one that has that image.  The other interesting thing is the backup version:

Backup Image                                       

------------                                       
Image            : linux.bk (backup)               
Version          : dev-build by fj@soft-dev13.dk.vitesse.com 2016-02-19T08:36:08+01:00 Config:ie1k_riogrande SDK:v01.13

Date             : 2016-02-19T08:36:08+01:00  

 

vitesse.com is the company that designed VSC7428 that is used in this switch.  That company was bought by Microsemi.  Cisco wouldn't ship a product with firmware from a third party, even for the backup.  I haven't performed a firmware swap yet, as I don't know what will actually happen.  It could be that I could back the 1.0.0 up or I could get it into a state where getting the 1.0.0 firmware to run again is not easily done or could be done.  Not like TAC could assist in this case.

 

So for now, I have an IE 1000 that has a CLI and no GUI which is much preferred over the GUI only version.

Highlighted

do you know what command to find out serial number? not show version
Highlighted

is anyone know how to find out serial number by command line, show version not output the answer

Highlighted

show inventory would be the only other command that I can think of.

Highlighted

thanks Ianbrown, unfortunately no this command on IE1000

Highlighted

How about sh tech?

 

If that doesn't work, the IE1000 was designed to be configured via a web browser and not the CLI.  So if the above command doesn't work, then you'll need to get the serial number by using a browser.

Highlighted

Thank you so much Ianbrown, got serial No. by browser

really appreciate your help!

Content for Community-Ad