05-21-2023 12:34 PM
Im new here, idk if this config is good enough for a smaller network?
MY SETTINGS ON R1:
R1# configure terminal
R1(config)# hostname NAME
R1(config)# security passwords min-length 5
R1(config)# service password-encryption
R1(config)# login block-for 60 attempts 3 within 30
R1(config)# enable secret PASSWORD
R1(config)# no ip domain-lookup
R1(config)# banner motd MESSAGE
R1(config)# line console 0
R1(config-line)# password PASSWORD
R1(config-line)# login
R1(config-line)# logging synchronous
R1(config-line)# exec-timeout 0 0
R1(config)# line vty 0 4
S1(config)# line vty 0 15
S1(config)# int fa0/0
S1(config-if)# ip address 192.168.100.50 255.255.255.0
S1(config-if)# no shut
S1(config-if)# exit
S1(config)# ip default-gateway 192.168.100.1
MY DHCP SETTINGS:
R-1(config)# ip dhcp excluded 172.16.2.1 172.16.2.7
R-1(config)# ip dhcp pool LAN-2
R-1(dhcp-config)# network 172.16.2.0 255.255.255.128
R-1(dhcp-config)# default-router 172.16.2.1
VLAN:
S1(config)# vlan 10
S1(config-vlan)# name Management
S1(config)# interface fa0/12
S1(config)# interface range fa0/12 – 20
S1(config-if)# switchport mode access
S1(config-if)# switchport access vlan 10
S1(config)# int gi1/1
S1(config-if)# switchport trunk encapsulation dot1q
S1(config-if)# switchport mode trunk
S1(config-if)# switchport trunk native vlan 99
S1(config-if)# switchport trunk allowed vlan 1,10,20,99
R1(config)# interface Fa0/0 (select the main interface)
R1(config-if)# no ip address
R1(config-if)# interface Fa0/0.10
R1(config-if)# encapsulation dot1q 10
R1(config-if)# ip address 172.16.10.1 255.255.255.255
R1(config-if)# interface Fa0/0.99
R1(config-if)# encapsulation dot1q 99 native
OSPF:
R1(config)# interface loopback 10
R1(config)# router ospf 1
R1(config-router)# router-id 2.2.2.2
R1(config-router)# network 172.16.45.0 0.0.0.255 area 0
R1(config-router)# passive-interface fastethernet 0/1
R1(config-router)# ip ospf message-digest-key 1 md5 PASSWORD
R1(config-if)# ip ospf message-digest-key 1 md5 PASSWORD
R1(config-if)# ip ospf authentication message-digest
R1(config-if)# ip ospf cost 1562
R1(config-if)# ip ospf hello-interval seconds
R1(config-if)# ip ospf dead-interval seconds
R1(config-if)# ip ospf priority {0 - 255}
R-1(config)# interface fa0/0
R-1(config-if)# ip nat inside
R-1(config)# interface serial 0/0/0
R-1(config-if)# ip nat outside
R-1(config)# ip nat inside source static 192.168.10.22 73.2.34.137
R1(config)# ip route 192.168.52.0 255.255.255.0 192.168.1.2 | ser 0/0/0
R1(config)# ip route 0.0.0.0 0.0.0.0 nekthop | outside port
05-22-2023 07:18 AM
Config to use will depend on your network design so we can't comment on your config.
Look through best practice guides for general advice.
Specifically the last 2 lines of your config are not valid config.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide