cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2062
Views
15
Helpful
7
Replies

Inter Vlan, routing and a dedicated DHCP server

Powersj2577
Level 1
Level 1

2x 1941 router/serial

2x 2960 switch/fa

DHCP(fa on the switch) is handing out IP addresses to my vlans perfectly. However, when i try to route these vlans through the router to hand DHCP over another router to my second switch and so forth. I can ping from any device to the second router but not further. Also I really don't know how to setup the WR3000 but I seem to have a problem making my wi-fi router use IP addresses from the DHCP server.

7 Replies 7

Hello,

this looks like a Packet Tracer file, can you post the file (ZIP it first, otherwise you cannot upload) ?

Yessir, sorry should have done that in the first place.

Hello,

the problem is that you are trying to extend the same address space (Vlan 42) across a layer 3 domain. You have the same IP address configured for the Vlan 42 interface on the corporate and the stadium router. The solution is to create a new DHCP pool (e.g. 172.16.54.0), a new subinterface on the stadium router, and to assign the switchport to the new Vlan. I have made a few additions (marked in bold) to your configs, and added a screenshot of the new DHCP pool. I'll look at the wireless as well...

Stadium_SW

interface FastEthernet0/2
switchport access vlan 54
switchport mode access
spanning-tree portfast

Stadium_Router

version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Stadium_Router
!
ip cef
no ipv6 cef
!
no ip domain-lookup
!
spanning-tree mode pvst
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1.42
encapsulation dot1Q 42
ip address 172.16.42.254 255.255.255.0
ip helper-address 172.16.8.1
!
interface FastEthernet0/1.54
encapsulation dot1Q 54
ip address 172.16.54.254 255.255.255.0
ip helper-address 172.16.8.1
!
interface Serial0/0/0
ip address 10.25.0.6 255.255.255.0
clock rate 56000
shutdown
!
interface Serial0/0/1
bandwidth 1564
ip address 10.198.0.2 255.255.255.0
ip helper-address 172.16.8.1
clock rate 2000000
!
interface Vlan1
no ip address
shutdown
!
router ospf 123
log-adjacency-changes
network 10.25.0.0 0.0.0.255 area 0
network 10.198.0.0 0.0.0.255 area 0
network 10.10.10.0 0.0.1.255 area 0
network 172.16.42.0 0.0.0.255 area 0
network 172.16.8.0 0.0.0.255 area 0
network 172.16.38.0 0.0.0.255 area 0
network 172.16.48.0 0.0.0.255 area 0
network 172.16.54.0 0.0.0.255 area 0
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0/1
!
ip flow-export version 9
!
no cdp run
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end

Corporate_Router

version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Corporate_Router
!
ip cef
no ipv6 cef
!
no ip domain-lookup
!
spanning-tree mode pvst
!
interface Loopback0
ip address 10.89.49.12 255.255.255.255
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1.8
encapsulation dot1Q 8
ip address 172.16.8.254 255.255.255.0
!
interface FastEthernet0/1.38
encapsulation dot1Q 38
ip address 172.16.38.254 255.255.255.0
ip helper-address 172.16.8.1
!
interface FastEthernet0/1.42
encapsulation dot1Q 42
ip address 172.16.42.254 255.255.255.0
ip helper-address 172.16.8.1
!
interface FastEthernet0/1.48
encapsulation dot1Q 48
ip address 172.16.48.254 255.255.255.0
ip helper-address 172.16.8.1
!
interface Serial0/0/0
ip address 10.25.0.5 255.255.255.0
clock rate 2000000
!
interface Serial0/0/1
bandwidth 1564
ip address 10.198.0.1 255.255.255.0
ip helper-address 172.16.8.1
!
interface Vlan1
no ip address
shutdown
!
router ospf 123
log-adjacency-changes
network 10.10.8.0 0.0.1.255 area 0
network 10.25.0.0 0.0.0.255 area 0
network 10.198.0.0 0.0.0.255 area 0
network 172.16.42.0 0.0.0.255 area 0
network 172.16.38.0 0.0.0.255 area 0
network 172.16.48.0 0.0.0.255 area 0
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0/0
ip route 0.0.0.0 0.0.0.0 Loopback0
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end

Thank you so much for your quick reply. I forgot the helper address was suppose to go on the serial interfaces thank you for reminding me. I guess my actual question is; would it be better to run the dedicated DHCP server through the router or the switch? And is it possible to have the same vlan 42 on the corp side as well as the stadium side? and how would I go about doing that? Thank you again very much that did actually work and now i can ping all devices on/from either side. That did help thank you.

Hello,

in a 'real world' design you would want to keep the DHCP server as close to the source as possible. So your design looks good actually.

You can extend a Vlan/address space across a layer 3 device (corp side and stadium side). However that becomes kind of cumbersome; you could do that with LAM (Local Area Mobility). I don't think Packet Tracer supports that feature though.

Here is how you would configure LAM:

https://www.safaribooksonline.com/library/view/cisco-ios-cookbook/0596527225/ch24s02.html

Ok so, I kinda went back and redid some things. But, I was wondering is it possible to etherchannel from router to switch? I just can't remember...

**Answered my own question.

Im really just trying to get the dhcp server to hand out addresses across the serial interface to the next router and out to the switch.