cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
283
Views
0
Helpful
1
Replies
Highlighted
Beginner

Inter-vlan routing on 3560 not working.

I had posted this using the "Ask a question" button on the main community page but for whatever reason I couldn't find it after I submitted it so I am submitting it as a discussion instead.

 

Hello, I can't get inter-vlan routing to work on this 3560. Can anyone help me out?

 

Here's the issue below: 192.168.2.1 and 192.168.1.2 are vlan interfaces. 192.168.1.1 is an external linksys router on fa0/1. I can ping the router from 192.168.1.2, but I cannot ping the router from 192.168.2.1


Switch#ping 192.168.2.1 source 192.168.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.1.2
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/8 ms
Switch#ping 192.168.1.2 source 192.168.2.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
Packet sent with a source address of 192.168.2.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms
Switch#ping 192.168.1.1 source 192.168.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.1.2
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
Switch#ping 192.168.1.1 source 192.168.2.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.2.1
.....
Success rate is 0 percent (0/5)

 


Switch#sh run
Building configuration...

Current configuration : 2379 bytes
!
! Last configuration change at 21:39:00 UTC Sat Oct 3 2015
! NVRAM config last updated at 21:34:11 UTC Sat Oct 3 2015
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
enable secret 5 $1$ygVw$XXgBV4jZsIQkCWr39ao0e0
!
no aaa new-model
ip subnet-zero
ip routing
ip domain-name boggslab.com
ip name-server 192.168.2.30
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 2
 switchport mode trunk
!
interface FastEthernet0/12
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 2
 switchport mode trunk
!
interface FastEthernet0/13
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 2
 switchport mode trunk
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 ip address 192.168.1.2 255.255.255.0
!
interface Vlan2
 ip address 192.168.2.1 255.255.255.0
!
interface Vlan10
 ip address 192.168.10.1 255.255.255.0
!
interface Vlan11
 ip address 192.168.11.1 255.255.255.0
!
interface Vlan12
 ip address 192.168.12.1 255.255.255.0
!
interface Vlan20
 ip address 192.168.20.1 255.255.255.0
!
interface Vlan21
 ip address 192.168.21.1 255.255.255.0
!
interface Vlan22
 ip address 192.168.22.1 255.255.255.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.1 permanent
ip http server
!
access-list 101 permit icmp any any
!
control-plane
!
!
line con 0
line vty 0 4
 password cisco
 logging synchronous
 login
line vty 5 15
 password cisco
 login
!
ntp clock-period 36029545
ntp server 192.5.41.41 prefer
!
end

Switch#sh ip int bri
Interface              IP-Address      OK? Method Status                Protocol
Vlan1                  192.168.1.2     YES NVRAM up                    up
Vlan2                  192.168.2.1     YES NVRAM  up                    up
Vlan10                 192.168.10.1    YES NVRAM  up                    up
Vlan11                 192.168.11.1    YES NVRAM  up                    up
Vlan12                 192.168.12.1    YES NVRAM  up                    up
Vlan20                 192.168.20.1    YES NVRAM  up                    up
Vlan21                 192.168.21.1    YES NVRAM  up                    up
Vlan22                 192.168.22.1    YES NVRAM  up                    up
FastEthernet0/1        unassigned      YES unset  up                    up
FastEthernet0/2        unassigned      YES unset  down                  down
FastEthernet0/3        unassigned      YES unset  down                  down
FastEthernet0/4        unassigned      YES unset  down                  down
FastEthernet0/5        unassigned      YES unset  down                  down
FastEthernet0/6        unassigned      YES unset  down                  down
FastEthernet0/7        unassigned      YES unset  down                  down
FastEthernet0/8        unassigned      YES unset  down                  down
FastEthernet0/9        unassigned      YES unset  down                  down
FastEthernet0/10       unassigned      YES unset  down                  down
FastEthernet0/11       unassigned      YES unset  up                    up
FastEthernet0/12       unassigned      YES unset  up                    up
FastEthernet0/13       unassigned      YES unset  up                    up
FastEthernet0/14       unassigned      YES unset  down                  down
FastEthernet0/15       unassigned      YES unset  down                  down
FastEthernet0/16       unassigned      YES unset  down                  down
FastEthernet0/17       unassigned      YES unset  down                  down
FastEthernet0/18       unassigned      YES unset  down                  down
FastEthernet0/19       unassigned      YES unset  down                  down
FastEthernet0/20       unassigned      YES unset  down                  down
FastEthernet0/21       unassigned      YES unset  down                  down
FastEthernet0/22       unassigned      YES unset  down                  down
FastEthernet0/23       unassigned      YES unset  down                  down
FastEthernet0/24       unassigned      YES unset  down                  down
GigabitEthernet0/1     unassigned      YES unset  down                  down
GigabitEthernet0/2     unassigned      YES unset  down                  down
Switch#sh vlan bri

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4, Fa0/5, Fa0/6, Fa0/7, Fa0/8, Fa0/9, Fa0/10, Fa0/14, Fa0/15, Fa0/16, Fa0/17, Fa0/18, Fa0/19, Fa0/20
                                                Fa0/21, Fa0/22, Fa0/23, Fa0/24, Gi0/1, Gi0/2
2    servers                          active
10   voice10                          active
11   private11                        active
12   euc12                            active
20   voice20                          active
21   private21                        active
22   euc22                            active
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup
Switch#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.1.1 to network 0.0.0.0

C    192.168.12.0/24 is directly connected, Vlan12
C    192.168.10.0/24 is directly connected, Vlan10
C    192.168.11.0/24 is directly connected, Vlan11
C    192.168.21.0/24 is directly connected, Vlan21
C    192.168.20.0/24 is directly connected, Vlan20
C    192.168.22.0/24 is directly connected, Vlan22
C    192.168.1.0/24 is directly connected, Vlan1
C    192.168.2.0/24 is directly connected, Vlan2

S*   0.0.0.0/0 [1/0] via 192.168.1.1
Switch#
Switch#sh version
Cisco IOS Software, C3560 Software (C3560-IPBASE-M), Version 12.2(25)SEB4, RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2005 by Cisco Systems, Inc.
Compiled Tue 30-Aug-05 14:19 by yenanh

ROM: Bootstrap program is C3560 boot loader
BOOTLDR: C3560 Boot Loader (C3560-HBOOT-M) Version 12.2(25r)SEA, RELEASE SOFTWARE (fc)

 Switch uptime is 45 minutes
System returned to ROM by power-on
System restarted at 21:03:07 UTC Sat Oct 3 2015
System image file is "flash:c3560-ipbase-mz.122-25.SEB4/c3560-ipbase-mz.122-25.SEB4.bin"

cisco WS-C3560-24PS (PowerPC405) processor (revision N0) with 118784K/12280K bytes of memory.
Processor board ID CAT0941R0N1
Last reset from power-on
8 Virtual Ethernet interfaces
24 FastEthernet interfaces
2 Gigabit Ethernet interfaces
The password-recovery mechanism is enabled.

512K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address       : 00:15:C6:8B:BE:00
Motherboard assembly number     : 73-9673-06
Power supply part number        : 341-0029-04
Motherboard serial number       : CAT094106N7
Power supply serial number      : DTH0938903V
Model revision number           : N0
Motherboard revision number     : A0
Model number                    : WS-C3560-24PS-S
System serial number            : CAT0941R0N1
Top Assembly Part Number        : 800-25861-03
Top Assembly Revision Number    : B0
Version ID                      : V05
CLEI Code Number                : COM1X00ARB
Hardware Board Revision Number  : 0x01


Switch   Ports  Model              SW Version              SW Image
------   -----  -----              ----------              ----------
*    1   26     WS-C3560-24PS      12.2(25)SEB4            C3560-IPBASE-M


Configuration register is 0xF

1 REPLY 1
Highlighted
VIP Advisor

Hi there,

I suspect the Linksys router only has a default route and has no idea how to route packets to 192.168.2.0 /24 , or any of your other internal VLANs.

I possible you need to add the following routes to the Linksys device:

 

ip route 192.168.2.0 255.255.255.0 192.168.1.2
ip route 192.168.10.0 255.255.255.0 192.168.1.2
ip route 192.168.11.0 255.255.255.0 192.168.1.2
ip route 192.168.12.0 255.255.255.0 192.168.1.2
ip route 192.168.20.0 255.255.255.0 192.168.1.2
ip route 192.168.21.0 255.255.255.0 192.168.1.2
ip route 192.168.22.0 255.255.255.0 192.168.1.2

 

If you cannot install additional routes onto the Linksys, then you will need to look at inserting a NAT device between your inside VLANs and the Linksys with the INSIDE GLOBAL  on the 192.168.1.0/24 subnet.

 

cheers,

Seb.

 

 

Content for Community-Ad