11-04-2015 08:34 PM - edited 03-10-2019 12:36 PM
Hi guys, in my studies I bought the CCNA Routing and Switching portable command guide third ed., and I came accross the Inter-VLAN Communication configuration example on page 113. I programmed all switches and routers to the best of my ability but am having trouble seeing (on CORP) the 192.168.x.x network, and moving packets anywhere on that network, any help would be great. You'll have to change the file extension back to pkt on file, thanks!
11-04-2015 08:57 PM
Hello,
Cant able to read the file attached, helpful if you can post the configiration for assitance.
-GI
11-05-2015 04:21 AM
Hi, It would be great if you can upload configuration of routers and switches as file attached by you is not readable. However, Please find below sample configurtion for 2 inter-vlan scenerios.
Scenerio 1:
For router with L2 switch:
Vlan 21/ IP Segment: 1.1.1.0/24
Vlan 21/ IP Segment: 2.1.1.0/24
Configuration at router interface should be as below:
interface GigabitEthernet0/2.21
encapsulation dot1Q 21
ip address 1.1.1.1 255.255.255.0
exit
interface GigabitEthernet0/2.22
encapsulation dot1Q 22
ip address 2.1.1.1 255.255.255.0
exit
Above configuration will enable inter-vlan routing and this interface should be connected with switch with below configuration.
interface Gi1/1
switchport mode trunk
switchport trunk allowed vlan 21,22
exit
Scenerio 2:
vlan 21
name X
vlan 22
name Y
Using L3 switch:
SVI need to be created on switch:
interface vlan21
ip address 1.1.1.1 255.255.255.0
no shut
exit
interface Vlan22
ip address 2.1.1.1 255.255.255.0
no shut
exit
Ip routing should be enabled.
ip routing
11-05-2015 06:10 AM
Sorry thought maybe changing the file extension would work, but I have a JPEG and heres my config:
Router (CORP)
Current configuration : 1451 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname CORP
!
no ip cef
no ipv6 cef
!
no ip domain-lookup
!
interface FastEthernet0/0
description link to 3560 switch
ip address 172.31.1.5 255.255.255.252
duplex auto
speed auto
!
interface Serial0/0
description link to ISP
ip address 192.31.7.6 255.255.255.252
!
interface Serial0/1
no ip address
clock rate 2000000
shutdown
!
interface FastEthernet1/0
no ip address
duplex full
speed auto
!
interface FastEthernet1/0.1
description Management VLAN 1 - Native VLAN
encapsulation dot1Q 1 native
ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet1/0.10
description Sales VLAN 10
encapsulation dot1Q 10
ip address 192.168.10.1 255.255.255.0
!
interface FastEthernet1/0.20
description Engineering VLAN 20
encapsulation dot1Q 20
ip address 192.168.20.1 255.255.255.0
!
interface FastEthernet1/0.30
description Marketing VLAN 30
encapsulation dot1Q 30
ip address 192.168.30.1 255.255.255.0
!
interface FastEthernet1/1
no ip address
duplex auto
speed auto
shutdown
!
router eigrp 10
network 192.168.1.0
network 192.168.10.0
network 192.168.20.0
network 192.168.30.0
network 172.31.0.0
network 192.31.7.0
no auto-summary
!
ip classless
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end
Switch 2
Current configuration : 1784 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch2
!
no ip domain-lookup
!
spanning-tree mode pvst
!
interface FastEthernet0/1
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/2
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/3
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/4
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/5
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/6
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/7
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/8
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/9
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/10
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/11
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/12
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
description Trunk Link To CORP Router
switchport mode trunk
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
ip address 192.168.1.2 255.255.255.0
!
ip default-gateway 192.168.1.1
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
end
11-05-2015 06:18 AM
What exactly is the problem ie. what are you pinging that doesn't work.
If it is from the devices connected to the 3560 then have you added a network statement to the L3 switch under it's EIGRP configuration for the link between the L3 switch and your router eg.
"network 172.31.1.4 0.0.0.3"
If it is something else you are trying to do can you be specific in terms of src/dst IPs.
Jon
11-05-2015 06:26 AM
Its on the L2 switch which has the 192.168.x.x network which is out port Fa 1/0 on my CORP router. It has no routes for this network nor can I ping anything inside this network. I'm not sure if I have configured default-gateways for the hosts incorrectly, or if its a VLAN issue. How do I get the link between Switch2 and CORP router "UP".
11-05-2015 06:30 AM
A L2 switch shouldn't have any routes just one SVI ("int vlan <x>") and a default gateway and this is only used so you can remotely connect to the switch ie. it is not used as the default gateway for end clients.
All your clients should have their default gateways set to the corresponding subinterface IP on the router for their vlan.
Is the connection showing as up/up on both the router and the L2 switch ?
Jon
11-05-2015 06:41 AM
I meant routes displayed in the routers routing table. No, the route is not up and thats the problem I'm having. The cable is fa0/24 on switch2 is down, line protocol is down. The sending side on CORP router fa 1/0 line is up, protocol is down. I have no shut configured as well as sub-interfaces, but the line is down.
11-05-2015 07:00 AM
Sounds like an issue with PT.
Assuming you have done a "no shut" on both main interfaces ie. the router and the switch not sure what else to say.
Jon
11-05-2015 07:02 AM
Hi,
Configuration part seems fine. Have you configured gateway on your end points?
If yes, Please check your gateway reachability from end points and paste below outputs.
On Router:
sh ip int brief
sh ip route
sh ip arp
Thanks!!!
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide