cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

2344
Views
5
Helpful
3
Replies
Highlighted
Beginner

Inter-Vlan Routing with Cisco 2851

Hi Guys,

Hope some one can help on this, I'm very new to cisco and having problems with my configs,

I have one cisco 3750G-48 switch, one cisco 3560G-PS switch, Cisco UC520, cisco 2851 and cisco wireless access point.

i have setup up intervlan routing between the two cisco switches and the uc520 with a total of four VLANS, the problem i'm having is with the 2851 router, I have created a trunk between the 3750 switch and the 2851 router. should I create subinterfaces on the 2851 router for the four vlans by doing gigabieethernet 0/0.1, 0/0.100 and so on or should I create BVI subinterfaces.

reason I ask is I created four vlans on the vtp server switch which is the 3750 and I connected the uc520 to the 3750 switch via a trunk interface and set up vtp client on the uc520, after I setup p the vtp on the uc520 the vlans were automatically created on the uc520 with each vlan having its own BVI interface.

So I am not sure how to configure the 2851 router to interact with the four vlans. also the 2851 router have two hwic 1adsl wics installed which will have two adsl connections coming in.

it would be greatly appreciated with some one can point me in the right direction on how to set up the 2851.

thanks,

2 ACCEPTED SOLUTIONS

Accepted Solutions
Cisco Employee

Inter-Vlan Routing with Cisco 2851

You can configure subinterface with dot1q as below. This enable intervlan communication

For vlan 100

interface gi 0/0.100

encapsulation dot1q 100

ip addess< ip adress>

Configure this for all the four Vlans

Here is the link for your reference

http://www.cisco.com/en/US/tech/tk389/tk815/technologies_configuration_example09186a00800949fd.shtml

Thank you

Raju

View solution in original post

Rising star

Re: Inter-Vlan Routing with Cisco 2851

Hi,
On router you need to create subinterfaces:

Int g0/0.1
encapsulation dot1q 1
ip add 10.0.0.1 255.255.255.0 (for example)
no shut

To be able access to the Internet just point default route to outside interface

ip route 0.0.0.0 0.0.0.0 dialerX

Also you need to configure NAT translations. Create one ACL including all your local subnets that need Internet access and create NAT rule:

ip access-list 101
permit ip 10.0.0.0 0.0.0.255 any

ip nat inside source list 101 interface DialerX overload

Make your ADSL interface (dialer) as nat outside and internal subinterfaces as nat inside.

Int dialerX
ip nat outside

Int g0/0.1
ip nat inside

Hope it will help

Sent from Cisco Technical Support iPhone App

Hope it will help. Best regards, Abzal

View solution in original post

3 REPLIES 3
Cisco Employee

Inter-Vlan Routing with Cisco 2851

You can configure subinterface with dot1q as below. This enable intervlan communication

For vlan 100

interface gi 0/0.100

encapsulation dot1q 100

ip addess< ip adress>

Configure this for all the four Vlans

Here is the link for your reference

http://www.cisco.com/en/US/tech/tk389/tk815/technologies_configuration_example09186a00800949fd.shtml

Thank you

Raju

View solution in original post

Rising star

Re: Inter-Vlan Routing with Cisco 2851

Hi,
On router you need to create subinterfaces:

Int g0/0.1
encapsulation dot1q 1
ip add 10.0.0.1 255.255.255.0 (for example)
no shut

To be able access to the Internet just point default route to outside interface

ip route 0.0.0.0 0.0.0.0 dialerX

Also you need to configure NAT translations. Create one ACL including all your local subnets that need Internet access and create NAT rule:

ip access-list 101
permit ip 10.0.0.0 0.0.0.255 any

ip nat inside source list 101 interface DialerX overload

Make your ADSL interface (dialer) as nat outside and internal subinterfaces as nat inside.

Int dialerX
ip nat outside

Int g0/0.1
ip nat inside

Hope it will help

Sent from Cisco Technical Support iPhone App

Hope it will help. Best regards, Abzal

View solution in original post

Beginner

Inter-Vlan Routing with Cisco 2851


thank you for the quick reply

in regards to the uc520 do i have to delete the bvi subinteraces and create them like you stated above, cause the uc520 automatically created bvl interfaces instead of the g0/0.1.

also can you help me how I should tackle the two adsl connections, can i team the two connections to give me one connection and if that can be done how do I set which ip address would be by public ip out of the both.

once again thank you for you help

thanks,

CreatePlease to create content
Content for Community-Ad