03-30-2016 08:32 AM - edited 03-08-2019 05:09 AM
I am in the process of trying to configure a Cisco 2901 router to route 2 vlans from a single HP Procurve 2530 switch. As you might imagine, I have not had any success. I am looking for guidance/suggestions and all inputs are appreciated.
The router is pre-existing in the network and as such has a working configuration. The configuration is designed to route to 2 catalyst switches, each being on a different subnet. We are migrating to HP switches as our Cisco's fall out of support. The choice is not mine.
Pre-existing Cisco configuration;
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
ip address 10.14.2.10 255.255.255.0
ip flow ingress
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 10.14.1.10 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
encapsulation frame-relay IETF
!
interface Serial0/0/0.16 point-to-point
bandwidth 512
ip address 10.254.1.109 255.255.255.252
frame-relay interface-dlci 16
!
interface Serial0/0/0.17 point-to-point
bandwidth 512
ip address 10.254.XXX.XXX 255.255.255.252
frame-relay interface-dlci 17
!
interface Serial0/0/0.18 point-to-point
description link to A.R. Pump Station
bandwidth 512
ip address 10.254.XXX.XXX 255.255.255.252
frame-relay interface-dlci 18
!
!
router eigrp 1
network 10.14.1.0 0.0.0.255
network 10.14.2.0 0.0.0.255
network 10.254.XXX.XXX 0.0.0.3
network 10.254.XXX.XXX 0.0.0.3
network 10.254.1.XXX 0.0.0.3
!
ip forward-protocol nd
!
ip http server
ip http authentication local
no ip http secure-server
ip flow-export source GigabitEthernet0/0
ip flow-export version 9
ip flow-export destination 10.222.XXX.XXX XXXX
!
!
!
!
control-plane
!
!
!
line con 0
login local
line aux 0
line 2
no activation-character
no exec
transport preferred none
stopbits 1
line vty 0 4
login local
line vty 5 15
login local
!
scheduler allocate 20000 1000
!
end
03-30-2016 09:42 AM
that is just your basic config . It looks ok . Your issue is on the HP side , you will need to figure out how to make those work . I would think just out of the box they would work but you need to look at your current cisco switches and figure out how to convert what you have on the cisco switches to the HP switches. I'm sure HP has a pretty good support page where they give you config docs . If you are trying to route 2 vlans down a single link to the HP then you will have to convert your router config from 2 separate interfaces to a single interface using sub interfaces or the router on a stick design . http://www.cisco.com/c/en/us/support/docs/lan-switching/inter-vlan-routing/14976-50.html
03-30-2016 11:39 AM
Hi!
We should start with the starting configurations to check if switch and router are communicating at l2 level.
Can you check if the router's interfaces are in up/up state?
Can you enable lldp with lldp run in global configuration mode and show lldp neighbors?
Best regards!
JC
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide