01-12-2023 07:32 AM
We are having some intermittent issues with our switch infrastructure since we configured port channel between the switches. Our environment consists of SG350X switches connected to a SX550X core switch stack. The port channel is configured static on both ends (without LACP since we were experiencing LACP flapping). Below is an excerpt of the configuration of the SX550X.
interface TenGigabitEthernet1/0/8
channel-group 8 mode on
no macro auto smartport
!
interface TenGigabitEthernet2/0/8
channel-group 8 mode on
no macro auto smartport
!
interface Port-Channel8
switchport mode trunk
switchport trunk native vlan 3333
switchport trunk allowed vlan 100,240,666,990,3333
no macro auto smartport
!
The problem is that sometimes network connectivity between the switches will simply break and can only be fixed by manually shutting the port channel interface and bringing it back up. When doing that, some errors/warnings get logged (highlighted in bold below). Are those expected errors or is this something we have to fix? If yes, how would we fix that?
conf t
int po8
shutdown
12-Jan-2023 15:15:34 %TRUNK-W-PORTDOWN: Port te2/0/8 removed from Po8: port is down/notPresent
12-Jan-2023 15:15:34 %LINK-W-Down: te2/0/8
12-Jan-2023 15:15:34 %TRUNK-W-PORTDOWN: Port te1/0/8 removed from Po8: port is down/notPresent
12-Jan-2023 15:15:34 %LINK-W-Down: te1/0/8
12-Jan-2023 15:15:34 %LINK-W-Down: Po8
12-Jan-2023 15:15:35 %LINK-I-PortParamSuccessToRecover: Port te2/0/8 success to recover from error on port parameter configuration: speed
12-Jan-2023 15:15:36 %LINK-I-PortParamSuccessToRecover: Port te1/0/8 success to recover from error on port parameter configuration: speed
no shutdown
12-Jan-2023 15:15:41 %2SWTRUNK-I-TRNKPORTPARAM: auto-negotiation/adv. capabilities of port te1/0/8 differ from auto-negotiation/adv. capabilities of Po8
12-Jan-2023 15:15:41 %2SWTRUNK-I-TRNKPORTPARAM: auto-negotiation/adv. capabilities of port te2/0/8 differ from auto-negotiation/adv. capabilities of Po8
12-Jan-2023 15:15:42 %TRUNK-I-PORTADDED: Port te1/0/8 added to Po8
12-Jan-2023 15:15:42 %LINK-I-Up: te1/0/8
12-Jan-2023 15:15:42 %TRUNK-I-PORTADDED: Port te2/0/8 added to Po8
12-Jan-2023 15:15:42 %LINK-I-Up: te2/0/8
12-Jan-2023 15:15:42 %LINK-I-Up: Po8
12-Jan-2023 15:15:42 %STP-W-PORTSTATUS: Po8: STP status Forwarding
12-Jan-2023 15:15:43 %2SWTRUNK-I-TRNKPORTPARAM: auto-negotiation/adv. capabilities of port te1/0/8 differ from auto-negotiation/adv. capabilities of Po8
12-Jan-2023 15:15:44 %2SWTRUNK-I-TRNKPORTPARAM: auto-negotiation/adv. capabilities of port te2/0/8 differ from auto-negotiation/adv. capabilities of Po8
Solved! Go to Solution.
02-17-2023 12:52 AM
The issue seems to have gone away since we updated our SX550X to the latest firmware.
01-12-2023 07:50 AM
Hi,
Not familiar with this platform, but you may want to try and set the speed and duplex on ports 1/0/8 and 2/0/8 manually to 10Gig and full duplex and test again. If this does not solve the issue, it may be a bug in the IOS you are running and may need to upgrade or downgrade to a different version.
HTH
01-13-2023 12:03 AM
Setting the speed and duplex on the two physical interfaces does not change the error. In fact, those parameters are the default and when setting them to there is no visible change in show run.
int te1/0/8
duplex full
speed 10000
As soon as you put the two physical interfaces in the port channel, negotiation gets disabled and cannot be enabled.
int te1/0/8
negotiation 10000f
Fiber Ethernet port te1/0/8 doesn't support Auto Negotiation enabled mode
So what seems to be happening is the switch complains that negotiation is disabled on the physical interfaces but enabled on the port channel interface. This is the "mismatch". The error goes away when we disabled negotiation on the port channel interface. However I am not sure this is something we want to do (since on the port channel interface we can only set the speed manually, the duplex command is not available).
int po8
duplex ?
% Unrecognized command
speed 10000
no negotiation
sh
13-Jan-2023 07:49:17 %TRUNK-W-PORTDOWN: Port te2/0/8 removed from Po8: port is down/notPresent
13-Jan-2023 07:49:17 %LINK-W-Down: te2/0/8
13-Jan-2023 07:49:17 %TRUNK-W-PORTDOWN: Port te1/0/8 removed from Po8: port is down/notPresent
13-Jan-2023 07:49:18 %LINK-W-Down: te1/0/8
13-Jan-2023 07:49:18 %LINK-W-Down: Po8
13-Jan-2023 07:49:19 %LINK-I-PortParamSuccessToRecover: Port te1/0/8 success to recover from error on port parameter configuration: speed
13-Jan-2023 07:49:19 %LINK-I-PortParamSuccessToRecover: Port te2/0/8 success to recover from error on port parameter configuration: speed
no sh
13-Jan-2023 07:49:34 %TRUNK-I-PORTADDED: Port te1/0/8 added to Po8
13-Jan-2023 07:49:34 %LINK-I-Up: te1/0/8
13-Jan-2023 07:49:34 %TRUNK-I-PORTADDED: Port te2/0/8 added to Po8
13-Jan-2023 07:49:34 %LINK-I-Up: te2/0/8
13-Jan-2023 07:49:34 %LINK-I-Up: Po8
13-Jan-2023 07:49:36 %STP-W-PORTSTATUS: Po8: STP status Forwarding
As you can see in the messages above, when negotiation is disabled on the port channel interface, the mismatch warning does not appear.
01-13-2023 12:33 AM
check below thread may help you :
02-17-2023 12:52 AM
The issue seems to have gone away since we updated our SX550X to the latest firmware.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide