cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
827
Views
0
Helpful
4
Replies
Beginner

Intervlan Routing on Catalyst 4506 - Not Reaching Internet from Hosts

I'm having difficulty getting the IP Routing function to work properly on my Catalyst 4506. I'm trying to set up InterVLAN routing between VLANs 2, 3, and 4 for my building's network. I've issued the Switch(config)#ip routing several times now, but don't see anything in the configuration. In the picture attached, I've drawn a diagram of how I need to set the network up. Each VLAN dishes out it's own DHCP.
 
Currently, hosts will receive IPs but are unable to reach other networks or the internet. However, the switch is able to ping to the internet. Any help is greatly appreciated. I've attempted to erase the memory and start from scratch, trying various methods I found on these discussion boards, Cisco documents, and third-party approaches, all to meet the same end.
 
Below is the current configuration of the switch:
Current configuration : 13181 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service compress-config
!
hostname CAM-Core
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
ip dhcp excluded-address 10.2.102.1 10.2.102.9
ip dhcp excluded-address 10.2.103.1 10.2.103.9
ip dhcp excluded-address 10.2.104.1 10.2.104.9
ip dhcp excluded-address 10.2.105.1 10.2.105.9
!
ip dhcp pool VLAN2
   network 10.2.102.0 255.255.255.0
   default-router 10.2.102.1
!
ip dhcp pool VLAN3
   network 10.2.103.0 255.255.255.0
   default-router 10.2.103.1
!
ip dhcp pool VLAN4
   network 10.2.104.0 255.255.255.0
   default-router 10.2.104.1
!
ip dhcp pool VLAN5
   network 10.2.105.0 255.255.255.0
   default-router 10.2.105.1
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
power redundancy-mode redundant
!
!
!
vlan internal allocation policy ascending
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface GigabitEthernet2/1
 switchport access vlan 2
 switchport mode access
ainterface GigabitEthernet2/2
 switchport access vlan 2
 switchport mode access
!
interface GigabitEthernet2/3
 switchport access vlan 2
 switchport mode access
!
//Output Omitted\\
!
interface GigabitEthernet3/1
 switchport access vlan 3
 switchport mode access
!
interface GigabitEthernet3/2
 switchport access vlan 3
 switchport mode access
!
interface GigabitEthernet3/3
 switchport access vlan 3
 switchport mode access
!
//Output Omitted\\
!
interface GigabitEthernet4/1
 switchport access vlan 4
 switchport mode access
!
interface GigabitEthernet4/2
 switchport access vlan 4
 switchport mode access
!
interface GigabitEthernet4/3
 switchport access vlan 4
 switchport mode access
!
//Output Omitted\\
!
interface GigabitEthernet4/48
 no switchport
 ip address dhcp
!
interface Vlan1
 no ip address
!
interface Vlan2
 ip address 10.2.102.1 255.255.255.0
!
interface Vlan3
 ip address 10.2.103.1 255.255.255.0
!
interface Vlan4
 ip address 10.2.104.1 255.255.255.0
!
interface Vlan5
 ip address 10.2.105.1 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 10.2.10.1
ip route 0.0.0.0 0.0.0.0 GigabitEthernet4/48
no ip http server
!
!
!
!
!
line con 0
 stopbits 1
line vty 0 4
 no login
!
!
end
Everyone's tags (5)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Hall of Fame Guru

Your 4500 is routing.What you

Your 4500 is routing.

What you need for this to work is -

1) routes added to the Comcast router for the vlan 2/3/4 subnets. It's not a Cisco device but something like -

ip route 10.2.102.0 255.255.255.0 10.2.10.125 <-- this is the IP on the gi0/48 interface

ip route 10.2.103.0 255.255.255.0 10.2.10.125

etc.

2) you will also need NAT setup on the Comcast router for these subnets.

3) As a side issue currently your gi0/48 is using DHCP although in your diagram you have used the .125 IP address. If this could change on reboot then obviously your routes on the Comcast router would stop working so it would be better not to use DHCP and give it a static IP.

It can be the same one if you want.

Jon

View solution in original post

4 REPLIES 4
Highlighted
Rising star

I haven't specifically worked

I haven't specifically worked on a 4500 switch but looking at the config posted above, I see no obvious issues.

Once you plug a host into each of the ports, the SVI's should come up.

The command 'ip routing', usually does show in the running config but like anything Cisco, it may vary from model to model. 

Can you run the following command and post the output.

#show ip interface brief | i Vlan

Can you also post the results of the following:

#show ip route

Thanks

Highlighted
Beginner

Thanks for the response. Here

Thanks for the response. Here is the output:

CAM-Core#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.2.10.1 to network 0.0.0.0

     10.0.0.0/24 is subnetted, 3 subnets
C       10.2.10.0 is directly connected, GigabitEthernet4/48
C       10.2.102.0 is directly connected, Vlan2
C       10.2.103.0 is directly connected, Vlan3
S*   0.0.0.0/0 [1/0] via 10.2.10.1
               is directly connected, GigabitEthernet4/48
CAM-Core#show ip int brief | i Vlan
Vlan1                  unassigned      YES NVRAM  down       down
Vlan2                  10.2.102.1      YES NVRAM  up         up
Vlan3                  10.2.103.1      YES NVRAM  up         up
Vlan4                  10.2.104.1      YES NVRAM  up         down
CAM-Core#

 

Vlan 4 is down because nothing is attached to it at the moment, so neglect that if need be. Vlan 2 can ping 3 and vice versa, however neither are able to reach the outside gateway (10.2.10.1)

Highlighted
Hall of Fame Guru

Your 4500 is routing.What you

Your 4500 is routing.

What you need for this to work is -

1) routes added to the Comcast router for the vlan 2/3/4 subnets. It's not a Cisco device but something like -

ip route 10.2.102.0 255.255.255.0 10.2.10.125 <-- this is the IP on the gi0/48 interface

ip route 10.2.103.0 255.255.255.0 10.2.10.125

etc.

2) you will also need NAT setup on the Comcast router for these subnets.

3) As a side issue currently your gi0/48 is using DHCP although in your diagram you have used the .125 IP address. If this could change on reboot then obviously your routes on the Comcast router would stop working so it would be better not to use DHCP and give it a static IP.

It can be the same one if you want.

Jon

View solution in original post

Highlighted
Beginner

Thanks for your help, Jon! I

Thanks for your help, Jon! I forgot that the switch was running through an Untangled Firewall prior to the Comcast gateway; nevertheless, the solution was the same. 

 

CreatePlease to create content
Content for Community-Ad