06-05-2011 08:23 PM - edited 03-06-2019 05:20 PM
Hi all experts.
I was practicing ip pim accept-register and i encountered the following issue. Pls guide me in this
I have 3 routers connected as shown below
R1------------------R2--------------------R3
Source RP Client
Following is the relevant configuration of all 3 routers
R1
interface FastEthernet0/0
description Link to RP
ip address 10.1.2.1 255.255.255.0
ip pim sparse-mode
ip pim dr-priority 10
ip multicast-routing
ip pim rp-address 2.2.2.2 (loopback on R2)
R2
interface FastEthernet0/0
description Link to Source
ip address 10.1.2.2 255.255.255.0
ip pim sparse-mode
interface FastEthernet0/1
description Link to Client
ip address 10.1.3.2 255.255.255.0
ip pim sparse-mode
interface Loopback0
ip address 2.2.2.2 255.255.255.0
ip multicast-routing
ip pim rp-address 2.2.2.2
R3
interface FastEthernet0/1
description Link to RP
ip address 10.1.3.3 255.255.255.0
ip pim sparse-mode
interface Loopback0
ip address 3.3.3.3 255.255.255.0
ip igmp join-group 224.2.2.2
ip pim sparse-mode
ip multicast-routing
ip pim rp-address 2.2.2.2
Now If i ping from R1 to 224.2.2.2 the result is successful
R1#ping 224.2.2.2 rep 5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 224.2.2.2, timeout is 2 seconds:
Reply to request 0 from 10.1.3.3, 112 ms
Reply to request 1 from 10.1.3.3, 192 ms
Reply to request 2 from 10.1.3.3, 128 ms
Reply to request 3 from 10.1.3.3, 168 ms
Reply to request 4 from 10.1.3.3, 136 ms
R1#
Everything is fine till now. Now i want to apply restriction as to which source can be registered with RP. For test i want to block R1 from registering so i configured the following (and also cleared mroute on all routers)
R2
access-list 100 deny ip host 10.1.2.1 any
access-list 100 permit ip any any
ip pim accept-register list 100
R2# debug ip pim
Now sending ping from R1 showed the following debug output on R2
RP#
*Mar 1 00:17:49.935: PIM(0): Check RP 2.2.2.2 into the (*, 224.2.2.2) entry
*Mar 1 00:17:49.947: PIM(0): Received v2 Register on FastEthernet0/0 from 10.1
2.1
*Mar 1 00:17:49.951: for 10.1.2.1, group 224.2.2.2
*Mar 1 00:17:49.951: %PIM-4-INVALID_SRC_REG: Received Register from 10.1.2.1 f
r (10.1.2.1, 224.2.2.2), not willing to be RP
RP#
*Mar 1 00:17:49.955: PIM(0): Register for 10.1.2.1, group 224.2.2.2 rejected
*Mar 1 00:17:49.959: PIM(0): Send v2 Register-Stop to 10.1.2.1 for 10.1.2.1, g
oup 224.2.2.2
Its also cool. But when i send continously from R1, see what happens
*Mar 1 00:21:33.355: PIM(0): Received v2 Join/Prune on FastEthernet0/1 from 10.1.3.3, to us
*Mar 1 00:21:33.359: PIM(0): Join-list: (*, 224.0.1.40), RPT-bit set, WC-bit set, S-bit set
*Mar 1 00:21:33.367: PIM(0): Add FastEthernet0/1/10.1.3.3 to (*, 224.0.1.40), Forward state, by PIM *G Join
RP#
*Mar 1 00:21:34.667: PIM(0): Received v2 Join/Prune on FastEthernet0/1 from 10.1.3.3, to us
*Mar 1 00:21:34.671: PIM(0): Join-list: (*, 224.2.2.2), RPT-bit set, WC-bit set, S-bit set
*Mar 1 00:21:34.679: PIM(0): Add FastEthernet0/1/10.1.3.3 to (*, 224.2.2.2), Forward state, by PIM *G Join
*Mar 1 00:21:34.687: PIM(0): Add FastEthernet0/1/10.1.3.3 to (10.1.2.1, 224.2.2.2), Forward state, by PIM *G Join
RP#
*Mar 1 00:21:36.391: PIM(0): Received v2 Join/Prune on FastEthernet0/1 from 10.1.3.3, to us
*Mar 1 00:21:36.395: PIM(0): Join-list: (10.1.2.1/32, 224.2.2.2), S-bit set
*Mar 1 00:21:36.399: PIM(0): Update FastEthernet0/1/10.1.3.3 to (10.1.2.1, 224.2.2.2), Forward state, by PIM SG Join
RP#
*Mar 1 00:21:37.943: PIM(0): Received v2 Join/Prune on FastEthernet0/0 from 10.1.2.1, to us
*Mar 1 00:21:37.947: PIM(0): Join-list: (*, 224.0.1.40), RPT-bit set, WC-bit set, S-bit set
*Mar 1 00:21:37.955: PIM(0): Add FastEthernet0/0/10.1.2.1 to (*, 224.0.1.40), Forward state, by PIM *G Join
RP#u all
*Mar 1 00:21:44.967: PIM(0): Building Periodic (*,G) Join / (S,G,RP-bit) Prune message for 224.0.1.40
And on R1
R1#ping 224.2.2.2 rep 10
Type escape sequence to abort.
Sending 10, 100-byte ICMP Echos to 224.2.2.2, timeout is 2 seconds:
.........
Reply to request 9 from 10.1.3.3, 204 ms
R1#
Why does this happened ? First RP said its not willing to be RP and send register stop to R1. Then suddenly it lets it join and start forwarding the traffic to R3 !!!!
Please someone guide me
06-06-2011 07:41 AM
Please review the mroute table on each router. Does it have a 'T' in the flag section?
If so, it switched over from share-based tree to source-based tree.
The RP isn't being used for the multicast.
In a real world scenario where a multicast source is a real source and not the router itself, you can disable the switchover with the command 'ip pim spt-threshold infinity'.
You can also review this thread in the INE website
http://ieoc.com/forums/p/14965/129681.aspx
Regards,
Edison
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide