05-30-2015 05:29 AM - edited 03-08-2019 12:16 AM
I have made a small IPv6 network using my Cisco 1812 (12.4(15)T17).
-------------------- CONFIGURATION --------------------
!
ipv6 unicast-routing
ipv6 cef
!
ipv6 dhcp pool VLAN10
prefix-delegation pool VLAN10 lifetime infinite infinite
dns-server 2001:4860:4860::8888
dns-server 2001:4860:4860::8844
domain-name d5.int
!
!
interface Tunnel0
description Hurricane Electric IPv6 Tunnel Broker
no ip address
ipv6 address <prefix>::2/64
ipv6 enable
tunnel source y.y.y.y
tunnel destination h.h.h.h
tunnel mode ipv6ip
!
interface FastEthernet0
ip address dhcp
ip access-group acl in
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
no cdp enable
!
interface Vlan10
description CLIENTS
ip address x.x.x.x m.m.m.m
no ip proxy-arp
ip nat inside
ip virtual-reassembly
ipv6 address <prefix>:10::1/64
ipv6 enable
ipv6 mtu 1280
ipv6 nd other-config-flag
ipv6 dhcp server VLAN10
ipv6 virtual-reassembly
!
!
ipv6 route ::/0 Tunnel0
ipv6 local pool VLAN10 <prefix>:10::/64 64
!
-------------------------------------------------------
The first time I configured a DHCP address on my Linux it got an IPv6 address; all tries after a reboot fails.
Windows got an IPv6 address, after restart all tries fails.
Debug output:
# debug ipv6 dhcp detail
-------------------- DEBUG --------------------
May 30 12:12:31.392: IPv6 DHCP: Received SOLICIT from FE80::3473:7E72:C34F:3170 on Vlan10
May 30 12:12:31.392: IPv6 DHCP: detailed packet contents
May 30 12:12:31.392: src FE80::3473:7E72:C34F:3170 (Vlan10)
May 30 12:12:31.392: dst FF02::1:2
May 30 12:12:31.392: type SOLICIT(1), xid 4823206
May 30 12:12:31.392: option ELAPSED-TIME(8), len 2
May 30 12:12:31.392: elapsed-time 0
May 30 12:12:31.392: option CLIENTID(1), len 14
May 30 12:12:31.392: 000100011936CCAC3C970E510213
May 30 12:12:31.392: option IA-NA(3), len 12
May 30 12:12:31.392: IAID 0x18247703, T1 0, T2 0
May 30 12:12:31.392: option UNKNOWN(39), len 23
May 30 12:12:31.392: option VENDOR-CLASS(16), len 14
May 30 12:12:31.392: option ORO(6), len 8
May 30 12:12:31.392: DOMAIN-LIST,DNS-SERVERS,VENDOR-OPTS,UNKNOWN
May 30 12:12:31.392: IPv6 DHCP: Option IA-NA(3) is not supported yet
May 30 12:12:31.392: IPv6 DHCP: Sending ADVERTISE to FE80::3473:7E72:C34F:3170 on Vlan10
May 30 12:12:31.392: IPv6 DHCP: detailed packet contents
May 30 12:12:31.392: src FE80::217:95FF:FE4E:57E4
May 30 12:12:31.392: dst FE80::3473:7E72:C34F:3170 (Vlan10)
May 30 12:12:31.392: type ADVERTISE(2), xid 4823206
May 30 12:12:31.392: option SERVERID(2), len 10
May 30 12:12:31.392: 000300010017954E57E4
router#
May 30 12:12:31.392: option CLIENTID(1), len 14
May 30 12:12:31.392: 000100011936CCAC3C970E510213
May 30 12:12:31.392: option STATUS-CODE(13), len 15
May 30 12:12:31.392: status code NOADDRS-AVAIL(2)
May 30 12:12:31.392: status message: NOADDRS-AVAIL
May 30 12:12:32.392: IPv6 DHCP: Received SOLICIT from FE80::3473:7E72:C34F:3170 on Vlan10
May 30 12:12:32.392: IPv6 DHCP: detailed packet contents
May 30 12:12:32.392: src FE80::3473:7E72:C34F:3170 (Vlan10)
May 30 12:12:32.392: dst FF02::1:2
May 30 12:12:32.392: type SOLICIT(1), xid 4823206
May 30 12:12:32.392: option ELAPSED-TIME(8), len 2
May 30 12:12:32.392: elapsed-time 100
May 30 12:12:32.392: option CLIENTID(1), len 14
May 30 12:12:32.392: 000100011936CCAC3C970E510213
May 30 12:12:32.392: option IA-NA(3), len 12
May 30 12:12:32.392: IAID 0x18247703, T1 0, T2 0
May 30 12:12:32.392: option UNKNOWN(39), len 23
May 30 12:12:32.392: option VENDOR-CLASS(16), len 14
May 30 12:12:32.392: option ORO(6), len 8
May 30 12:12:32.392: DOMAIN-LIST,DNS-SERVERS,VENDOR-OPTS,UNKNOWN
May 30 12:12:32.392: IPv6 DHCP: Option IA-NA(3) is not supported yet
May 30 12:12:32.392: IPv6 DHCP: Sending ADVERTISE to FE80::3473:7E72:C34F:3170 on Vlan10
May 30 12:12:32.392: IPv6 DHCP: detailed packet contents
May 30 12:12:32.392: src FE80::217:95FF:FE4E:57E4
May 30 12:12:32.392: dst FE80::3473:7E72:C34F:3170 (Vlan10)
May 30 12:12:32.392: type ADVERTISE(2), xid 4823206
May 30 12:12:32.392: option SERVERID(2), len 10
May 30 12:12:32.392: 000300010017954E57E4
router#
May 30 12:12:32.392: option CLIENTID(1), len 14
May 30 12:12:32.392: 000100011936CCAC3C970E510213
May 30 12:12:32.392: option STATUS-CODE(13), len 15
May 30 12:12:32.392: status code NOADDRS-AVAIL(2)
May 30 12:12:32.392: status message: NOADDRS-AVAIL
--------------------------------------------------------------------------------
The last two entries:
May 30 12:12:32.392: status code NOADDRS-AVAIL(2)
May 30 12:12:32.392: status message: NOADDRS-AVAIL
Says that theres no addresses available?
Do I miss something in my configuration?
A lot of the documentation and examples on the internet uses the command:
# ipv6 dhcp pool SOME_POOL
address ...
But I don't have this command.
Anyone knows how to get this working?
Solved! Go to Solution.
05-30-2015 02:07 PM
Ronni,
Unfortunately, the support for the usual DHCPv6 address assignments was only added in IOS 12.4(24)T with the address prefix command.
http://www.cisco.com/c/en/us/td/docs/ios-xml/ios/ipv6/command/ipv6-cr-book/ipv6-a1.html#wp2812007540
Without this command, your DHCP server will not be able to assign individual addresses to clients. The prefix delegation you have configured is a different, unrelated feature which you should remove from your configuration. Your DHCP server should be currently capable of assigning supplementary configuration to your clients such as DNS, domain names, etc., but the address itself will need to be obtained via SLAAC rather than through DHCPv6. Your router appears to be configured correctly in that it tells the stations to get their address via SLAAC and other configuration via DHCPv6 but these two flags (Managed flag, Other config flag) may not be always properly honored by the clients.
So what I suggest doing is removing the prefix-delegation command from your current DHCPv6 pool, and trying again. Keep in mind that the client addresses will have to be obtained via SLAAC. If this does not work then you may need to upgrade the IOS.
Best regards,
Peter
05-30-2015 02:07 PM
Ronni,
Unfortunately, the support for the usual DHCPv6 address assignments was only added in IOS 12.4(24)T with the address prefix command.
http://www.cisco.com/c/en/us/td/docs/ios-xml/ios/ipv6/command/ipv6-cr-book/ipv6-a1.html#wp2812007540
Without this command, your DHCP server will not be able to assign individual addresses to clients. The prefix delegation you have configured is a different, unrelated feature which you should remove from your configuration. Your DHCP server should be currently capable of assigning supplementary configuration to your clients such as DNS, domain names, etc., but the address itself will need to be obtained via SLAAC rather than through DHCPv6. Your router appears to be configured correctly in that it tells the stations to get their address via SLAAC and other configuration via DHCPv6 but these two flags (Managed flag, Other config flag) may not be always properly honored by the clients.
So what I suggest doing is removing the prefix-delegation command from your current DHCPv6 pool, and trying again. Keep in mind that the client addresses will have to be obtained via SLAAC. If this does not work then you may need to upgrade the IOS.
Best regards,
Peter
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide