07-20-2017 03:08 PM - edited 03-08-2019 11:24 AM
In ipv4 we can add a default route to point to the global routing table. However if I try the same command format with IPv6 I don't have any option to add global at the end.
IPv4: ip route vrf DMZ 0.0.0.0 0.0.0.0 1.1.1.1 global
Is there a way to perform the same for ipv6?
(config)#ipv6 route vrf DMZ01 ::/0 2001:123:456:789::1 ?
<1-254> Administrative distance
multicast Route only usable by multicast
nexthop-vrf Nexthop IPv6 VRF
tag Tag value
unicast Route only usable by unicast
<cr>
Thanks
03-13-2021 09:20 AM
I'm trying to do something similar.
I have set up a 1941 router with a global routing instance and a VRF for guest wireless users. This is just with VRF-lite. I get a /48 IPv6 prefix by prefix delegation from the provider.
My IP connection to the provider is on Dialer0.
Also configured is zone-based policy firewall; Dialer0 is in the outside zone and the guest WLAN in the guest zone. A zone-pair and policy-map are configured to allow all IPv6 traffic from the guest zone to the outside zone.
There is a static IPv6 route configured as follows:
ipv6 route vrf vrf_GUEST ::/0 Dialer0
!
vrf definition vrf_GUEST
rd 1:100
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!
interface GigabitEthernet0/0.100
description *** GUEST LAN - VLAN 100 ***
encapsulation dot1Q 100
vrf forwarding vrf_GUEST
ip address 192.168.100.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
zone-member security seczone_GUEST
ip tcp adjust-mss 1452
no cdp enable
ipv6 address MY_IPv6_PREFIX ::64:0:0:0:1/64
!
interface Dialer0
zone-member security seczone_OUTSIDE
ip address negotiated
ipv6 address FE80::1 link-local
ipv6 address 2**2:8**1:D**0:3*2::/64
ipv6 enable
ipv6 dhcp client pd MY_IPv6_PREFIX
ppp chap etc.etc.
I have no problem with the IPv4 static default route in vrf_GUEST pointing at dialer0 in the global table:
ip route vrf vrf_GUEST 0.0.0.0 0.0.0.0 Dialer0
but the IPv6 default route (static configuration as above) doesn't appear in the IPv6 routing table for vrf_GUEST.
I can find no reason why not. Is this a bug perhaps?
Cisco 1941 router, IOS 15.6(3)M9
Thanks
ChrisSW
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide