cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Cisco Community Designated VIP Class of 2020

377
Views
0
Helpful
4
Replies
Highlighted
Beginner

Issue with interfaces in VRF

Hi,

We are currently experiencing an issue when we place a sub-if into a VRF.

What we are seeing is when the sub-interface in configured out of the VRF the service works correctly, however when we place the SUB-IF into the vrf the upstream switch doesn't even pick up the mac address of the interface.

Here is some of the configuration we have done for the VRF.

vrf definition vrf1

!

address-family ipv4

exit-address-family

!

interface GigabitEthernet0/1/3.701

description Descr

vrf forwarding vrf1

encapsulation dot1Q 701

ip address 1.1.1.1 255.255.255.248

upstream switch:

interface Ethernet1/31

  description **TRUNK **

  switchport mode trunk

  speed 1000

  duplex full

When the vrf forwarding is enabled the mac address is removed from the switches mac table pings drop etc.

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Cisco Employee

Issue with interfaces in VRF

Hello Scott,

A stupid question - are you using the vrf keyword in the ping command when pinging from the 1.1.1.1, i.e., ping vrf vrf1 1.1.1.2? If you ping 1.1.1.1 from 1.1.1.2, does it work with the subif in the VRF?

Also, I wonder... when on the 1.1.1.1, can it ping itself? I.e. ping vrf vrf1 1.1.1.1 - does that work? By the way, what switch platform is this?

Best regards,

Peter

View solution in original post

4 REPLIES 4
VIP Expert

Issue with interfaces in VRF

Can you add a rd to your vrf and try again?

vrf definition vrf1

rd 1:1

Also, what device is pinging what device (IPs)?

HTH

Beginner

Issue with interfaces in VRF

Have added the RD in, no luck.

We are pinging across layer 2 space here so trying to ping 1.1.1.2 from 1.1.1.1.

As i was saying if we remove the VRF configuration the sevice operates correctly.

Regards,
Scott

Hall of Fame Cisco Employee

Issue with interfaces in VRF

Hello Scott,

A stupid question - are you using the vrf keyword in the ping command when pinging from the 1.1.1.1, i.e., ping vrf vrf1 1.1.1.2? If you ping 1.1.1.1 from 1.1.1.2, does it work with the subif in the VRF?

Also, I wonder... when on the 1.1.1.1, can it ping itself? I.e. ping vrf vrf1 1.1.1.1 - does that work? By the way, what switch platform is this?

Best regards,

Peter

View solution in original post

Beginner

Issue with interfaces in VRF

Hi Peter,

Now who looks stupid! I was using the sub-if for the source rather than the vrf keyword.

The switch is N5k.

Thanks for your hlep.

Regards,
Scott

CreatePlease to create content
Content for Community-Ad