cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1307
Views
0
Helpful
6
Replies
Highlighted
Beginner

L2 bridge on 1921 Router interface

HI all- I need to set up a L2 llink between my LAN and this 1921 router. I though IRB would do it but its not working yet. Looking for some ideas. Here is the topology- I dont want to see another hop on this 1921 rtr so I hope I can just trunk it or something with IRB. Not working.

Everyone's tags (6)
1 ACCEPTED SOLUTION

Accepted Solutions
Rising star

L2 bridge on 1921 Router interface

Hi,

If I understood you correctly you want to reach Internet and WAN through g0/1 interface on Router? Correct me if I'm wrong.

Abzal

Hope it will help. Best regards, Abzal
6 REPLIES 6
Rising star

L2 bridge on 1921 Router interface

Hi,

If I understood you correctly you want to reach Internet and WAN through g0/1 interface on Router? Correct me if I'm wrong.

Abzal

Hope it will help. Best regards, Abzal
Beginner

Re: L2 bridge on 1921 Router interface

Ill get to the Internet and MPLS in time, right now I need to solve the problem on my LAN reching the L3 interface on the router form the LAN behind the 3750

Rising star

Re: L2 bridge on 1921 Router interface

Ok, then I'll try to help you I never done this before.

On router configure two subinterfaces, with dot1q tag 1 (e.g G0/1.1) and one for MPLS. Then put default route on 3750 pointing to interface G0/1.1. Assign IP address on router G0/1.1 interface from LAN subnet (10.116.1.x). Assign one separate /30 subnet between ASA and Router(G0/0). To access Internet put default route pointing to ASA inside interface.

And port connected to Router configure as trunk on 3750.

Is there any subnet behind MPLS you want to reach?

Abzal

Hope it will help. Best regards, Abzal
Beginner

Re: L2 bridge on 1921 Router interface

There is a simpler way. I havnt done this before either, but I dont think this is the answer im looking for. thanks though

Rising star

Re: L2 bridge on 1921 Router interface

Show me your router configuration. That's interesting case. I'll try to help you.

Abzal

Hope it will help. Best regards, Abzal
Beginner

L2 bridge on 1921 Router interface

Here is teh router config:

sh run

!

!

bridge irb

!

!

          !

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

description Connection to Inside_ASA

ip address 10.116.1.3 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/1

description Connection to MPOE_SWT1

no ip address

duplex auto

speed auto

vlan-range dot1q 1 70

  exit-vlan-config

!

bridge-group 1

!

ip forward-protocol nd

!

           ip http server

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

ip route 10.116.0.0 255.255.248.0 10.116.1.1

ip route 10.116.8.0 255.255.255.0 198.18.106.225

ip route 10.116.9.0 255.255.255.0 198.18.106.225

ip route 10.116.10.0 255.255.255.0 198.18.106.225

ip route 10.116.11.0 255.255.255.0 198.18.106.225

!

!

line con 0

login local

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line vty 0 4

access-class 23 in

privilege level 15

login local

transport input telnet ssh

line vty 5 15

access-class 23 in

privilege level 15

login local

transport input telnet ssh

!

scheduler allocate 20000 1000

end

MPOE_RTR-1#

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards