02-13-2017 02:27 PM - edited 03-08-2019 09:19 AM
Hi guys,
There is any way of passing two vlan through a l2 tunnel ? we are trying to setup and transport service for an ISP and we need to pass through the tunnel one admin vlan and one data vlan at the same time.
Thanks
02-13-2017 04:23 PM
Hi,
Yes this is possible using L2TPv3. Let me know if you need an example config
02-14-2017 05:57 AM
Hello,
The example would be great.
Thanks
02-14-2017 06:51 AM
Sure.
Please see attached example topology.
The goal is to allow the devices in Admin VLAN 11 and Data VLAN 12 to communicate with each other over the L3 link.
Simple explaination
The Admin and Data devices are members of their respective VLANs and the VLANs are being trunked by the switches to the router Gig0/2 interfaces. When the routers receive the dot1q tagged frames, it encapsulates them with a L2TPv3 header, inserts a new IP header and transports them over the WAN to the remote routers loopback address. The outer IP and L2TPv3 headers are then removed and the frame is sent out the Gig0/2 interface.
R1
l2tp-class class1
authentication
password 0 1234
!
pseudowire-class ethernet
encapsulation l2tpv3
protocol l2tpv3 class1
ip local interface Loopback1
ip pmtu
ip dfbit set
!
interface loopback1
ip address 192.168.0.1 255.255.255.255
!
interface GigabitEthernet0/1
ip address 10.0.0.1 255.255.255.252
!
interface GigabitEthernet0/2
!
interface GigabitEthernet0/2.11
encapsulation dot1Q 11
xconnect 192.168.0.2 11 encapsulation l2tpv3 pw-class ethernet
!
interface GigabitEthernet0/2.12
encapsulation dot1Q 12
xconnect 192.168.0.2 12 encapsulation l2tpv3 pw-class ethernet
!
ip route 192.168.0.2 255.255.255.255 10.0.0.2
R2
l2tp-class class1
authentication
password 0 1234
!
pseudowire-class ethernet
encapsulation l2tpv3
protocol l2tpv3 class1
ip local interface Loopback1
ip pmtu
ip dfbit set
!
interface loopback1
ip address 192.168.0.2 255.255.255.255
!
interface GigabitEthernet0/1
ip address 10.0.0.2 255.255.255.252
!
interface GigabitEthernet0/2
!
interface GigabitEthernet0/2.11
encapsulation dot1Q 11
xconnect 192.168.0.1 11 encapsulation l2tpv3 pw-class ethernet
!
interface GigabitEthernet0/2.12
encapsulation dot1Q 12
xconnect 192.168.0.1 12 encapsulation l2tpv3 pw-class ethernet
!
ip route 192.168.0.1 255.255.255.255 10.0.0.1
Hope this helps
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide