07-10-2012 12:25 PM - edited 03-07-2019 07:42 AM
Hi folks, we recently acquired a new company and I am trying to get my head wrapped around their network setup until I physically go out there to refresh the network.
I have a bit of a trivial situation and am wandering if someone can help me out.
I have 2 switches: Switch 4 and Switch 5 which are connected to one another over a trunk link
Switch 4 has Gi1/0/2 and Gi1/0/3 attached to a database server via a port channel (Po1). Server IP address is 192.168.218.19
Default Gateway for Switch 4 is Switch 5
When I do a traceroute to 192.168.218.19 from Switch4, trace goes to Switch 5 and then to 192.168.218.19
When I do show mac address-table address command on the MAC address of 192.168.218.19 on Switch 5, it says its connected to Gi1/0/1. Gi1/0/1 is connected to Switch4
When I go back to Switch4 and look up the MAC for 192.168.218.19, it says connected via Po1.
The database server has two NICs connecting to Switch 4 and two Connecting to Switch 5 for backup.
This causes a problem when I have a device connecting directly into Switch 4 and wants to send a file to the database server. It first goes from Switch 4 to Switch 5, then back over the trunk to Switch 4 and to the Po1.
Switch5 must stay as the default gateway for switch 4 as it's got further connectivity into the WAN from Switch 5.
Please advise how I can fix this?
07-10-2012 12:40 PM
Below is an output of basically everything that I talk about in my previous post, in Cisco's language
Username: xxxx
Password:
SW4>
SW4>en
Password:
SW4#
SW4#traceroute 192.168.218.19
Type escape sequence to abort.
Tracing the route to 192.168.218.19
1 172.18.6.16 0 msec 0 msec 0 msec
2 192.168.218.19 0 msec 0 msec 8 msec
SW4#
SW4#
SW4#172.18.6.16
Trying 172.18.6.16 ... Open
User Access Verification
Username: xxxxxxxxx
Password:
SW5>en
Password:
SW5#
SW5#
SW5#sh arp | inc 192.168.218.19
Internet 192.168.218.19 121 0060.163e.49bf ARPA Vlan2
SW5#
SW5#
SW5#sh mac address-table address 0060.163e.49bf
Mac Address Table
-------------------------------------------
Vlan Mac Address Type Ports
---- ----------- -------- -----
2 0060.163e.49bf DYNAMIC Gi1/0/1
Total Mac Addresses for this criterion: 1
SW5#
SW5#sh cdp nei
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone
Device ID Local Intrfce Holdtme Capability Platform Port ID
SW3 Gig 1/0/18 176 S I WS-C2960G Gig 0/2
SW3 Gig 1/0/20 176 S I WS-C2960G Gig 0/1
SW4 Gig 1/0/2 149 S I WS-C3750G Gig 1/0/1
SW4 Gig 1/0/1 154 S I WS-C3750G Gig 1/0/2
SW5#sh run int gig1/0/1
interface GigabitEthernet1/0/1
description etherchanne to SW4
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 3 mode active
end
SW5#sh run int gig1/0/2
interface GigabitEthernet1/0/2
description etherchanne to SW4
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 3 mode active
end
SW5#
SW5#sh run int po3
interface Port-channel3
switchport trunk encapsulation dot1q
switchport mode trunk
end
SW5#
SW5#exit
[Connection to 172.18.6.16 closed by foreign host]
SW4#
SW4#sh mac address-table address 0060.163e.49bf
Mac Address Table
-------------------------------------------
Vlan Mac Address Type Ports
---- ----------- -------- -----
2 0060.163e.49bf DYNAMIC Po5
1 0060.163e.49bf DYNAMIC Po5
Total Mac Addresses for this criterion: 2
SW4#
SW4#sh etherchannel summary
Flags: D - down P - in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
Number of channel-groups in use: 4
Number of aggregators: 4
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SD) LACP Gi1/0/24(I)
2 Po2(SD) -
3 Po3(SU) LACP Gi1/0/1(P)
5 Po5(SU) LACP Gi1/0/3(P) Gi1/0/4(P)
SW4#sh run int gi1/0/3
Building configuration...
Current configuration : 157 bytes
!
interface GigabitEthernet1/0/3
description EMC_Active cge1
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 5 mode active
end
SW4#sh run int gi1/0/4
Building configuration...
Current configuration : 157 bytes
!
interface GigabitEthernet1/0/4
description EMC_Active cge2
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 5 mode active
end
SW4#sh run int po5
Building configuration...
Current configuration : 92 bytes
!
interface Port-channel5
switchport trunk encapsulation dot1q
switchport mode trunk
end
07-10-2012 12:42 PM
Hi,
Could you provide a diagram of this setup? What switches are you using?
Adam
07-10-2012 01:01 PM
Hi Adam, I quickly created a drawing as per your note. It's not a master-piece but it sort of will help put things into perspective.
ORANGE lines and arrows show how traffic flows from a client to the server currently.
GREEN lines and arrows show how it should be flowing.
07-11-2012 01:02 AM
Hi,
Can you provide your running from sw4 and sw5 as well as ip config from client and server.
Regards.
Alain
Don't forget to rate helpful posts.
07-13-2012 07:20 AM
Hi Alain, here are the configs. Thanks.
SWITCH 4
SW4#sh run
Building configuration...
Current configuration : 3537 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname SW4
!
enable secret xxxxxxxxx
!
username xxxxxxxxx password xxxxxxxxxxx
no aaa new-model
clock timezone UTC -5
clock summer-time UTC recurring
switch 1 provision ws-c3750g-24t
system mtu routing 1500
ip subnet-zero
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Port-channel2
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Port-channel3
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Port-channel5
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet1/0/1
description etherchannel to SW5
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 3 mode active
!
interface GigabitEthernet1/0/2
description etherchannel to SW5
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet1/0/3
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 5 mode active
!
interface GigabitEthernet1/0/4
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 5 mode active
!
interface GigabitEthernet1/0/5
switchport access vlan 7
switchport mode access
!
interface GigabitEthernet1/0/6
switchport access vlan 7
switchport mode access
!
interface GigabitEthernet1/0/7
switchport access vlan 7
!
interface GigabitEthernet1/0/8
switchport access vlan 7
!
interface GigabitEthernet1/0/9
switchport access vlan 2
!
interface GigabitEthernet1/0/10
description RemusSQL_Lan
switchport access vlan 17
!
interface GigabitEthernet1/0/11
switchport mode access
!
interface GigabitEthernet1/0/12
switchport trunk encapsulation dot1q
switchport mode access
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
switchport access vlan 6
!
interface GigabitEthernet1/0/16
switchport mode access
!
interface GigabitEthernet1/0/17
description Romulus_Lan
switchport access vlan 17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
description Cleito_ILO
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
description From Firewall
switchport mode access
!
interface GigabitEthernet1/0/24
description Trunk to Swich 2
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode active
!
interface Vlan1
ip address 172.18.6.14 255.255.255.0
no ip route-cache
!
interface Vlan6
ip address 192.168.216.2 255.255.255.0
!
interface Vlan7
ip address 192.168.217.2 255.255.255.0
!
interface Vlan17
ip address 192.168.215.2 255.255.255.0
!
ip default-gateway 172.18.6.16
ip classless
ip http server
!
!
control-plane
!
!
line con 0
!
end
**********************************************************************
SWITCH5
**********************************************************************
SW5#sh run
Building configuration...
Current configuration : 5534 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log datetime localtime
no service password-encryption
!
hostname SW5
!
enable secret xxxxxxxxxxxx
!
no aaa new-model
clock timezone UTC -6
clock summer-time UTC recurring
switch 1 provision ws-c3750g-24t
system mtu routing 1500
ip subnet-zero
ip routing
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Port-channel2
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Port-channel3
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Port-channel4
switchport trunk encapsulation dot1q
switchport mode access
!
interface GigabitEthernet1/0/1
description etherchanne to SW4
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 3 mode active
!
interface GigabitEthernet1/0/2
description etherchanne to SW4
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 3 mode active
!
interface GigabitEthernet1/0/3
description EMC_Standby cge1
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 2 mode active
!
interface GigabitEthernet1/0/4
description EMC_Standby cge2
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 2 mode active
!
interface GigabitEthernet1/0/5
description EMC_Data1 cge0 - Active (Server_2)
switchport access vlan 6
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/6
description EMC_Data1 cge0 - Active (Server_3)
switchport access vlan 6
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/7
description EMC_Data1 RemusSQL (Teamed)
switchport access vlan 6
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/8
description EMC_Data1 RemusSQL (Teamed)
switchport access vlan 6
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/9
description EMC_Cifs
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/10
description RemusSQL_Lan
switchport access vlan 17
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/11
description EMC_Cifs
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/12
description EMC_Backup Cleito (to be configured)
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/13
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/14
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/15
description Cleito
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/16
description Cleito
switchport access vlan 7
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/17
description Romulus_Lan
switchport access vlan 17
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/18
switchport trunk encapsulation dot1q
switchport mode access
channel-group 4 mode active
spanning-tree portfast
!
interface GigabitEthernet1/0/19
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/20
switchport trunk encapsulation dot1q
switchport mode access
channel-group 4 mode active
spanning-tree portfast
!
interface GigabitEthernet1/0/21
description EMC Management Port
switchport access vlan 17
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/22
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/23
description Despina
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/24
switchport mode access
spanning-tree portfast
!
interface Vlan1
ip address 172.18.6.16 255.255.255.0
!
interface Vlan2
ip address 192.168.218.1 255.255.255.0
!
interface Vlan3
ip address 192.168.219.1 255.255.255.0
!
interface Vlan4
ip address 192.168.220.1 255.255.255.0
!
interface Vlan5
ip address 192.168.221.1 255.255.255.0
!
interface Vlan6
ip address 192.168.216.1 255.255.255.0
!
interface Vlan7
ip address 192.168.217.1 255.255.255.0
!
interface Vlan12
ip address 192.168.224.1 255.255.255.0
!
interface Vlan15
ip address 192.168.227.1 255.255.255.0
!
interface Vlan17
ip address 192.168.215.1 255.255.255.0
!
interface Vlan900
ip address 10.11.6.1 255.255.255.0
!
ip default-gateway 172.18.6.1
ip classless
ip route 0.0.0.0 0.0.0.0 172.18.6.1
ip route 10.0.0.0 255.0.0.0 172.18.6.2
ip route 172.16.0.0 255.248.0.0 172.18.6.2
ip route 192.168.0.0 255.255.0.0 172.18.6.2
ip http server
!
ip access-list extended wireless
deny ip 10.11.6.0 0.0.0.255 172.18.0.0 0.0.255.255
deny ip 10.11.6.0 0.0.0.255 192.168.0.0 0.0.255.255
permit ip 10.11.6.0 0.0.0.255 any
!
access-list 5 permit 172.18.120.0 0.0.0.255
!
control-plane
!
!
!
end
07-11-2012 06:51 AM
Hi Adam, I forgot to mention Switch models....they are both WS-C3750G-24T
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide