cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
165
Views
0
Helpful
7
Replies
Highlighted
Beginner

Layer 3 switching problem

I was doing this pt. I need help with it. the computer is under vlan 20 and access point is vlan 10. The computer is getting dhcp address but on the laptop its apipa.. Im missing something that i dont know what.

layer 3 configuration:

interface FastEthernet0/2

switchport access vlan 10

switchport mode access

interface FastEthernet0/3

switchport access vlan 20

switchport mode access

interface FastEthernet0/24

switchport access vlan 20

switchport mode access

interface GigabitEthernet0/1

switchport access vlan 20

switchport mode access

interface Vlan10

ip address 172.16.60.254 255.255.255.0

ip helper-address 192.168.60.221

interface Vlan20

ip address 192.168.60.249 255.255.255.0

ip helper-address 192.168.60.221

interface Vlan30

ip address 10.10.60.254 255.255.255.0

Everyone's tags (1)
7 REPLIES 7
Highlighted
Cisco Employee

Can you ping 192.168.60.221

Can you ping 192.168.60.221 from SVI 172.16.60.254?

Regards!

JC

Highlighted
Beginner

if i set the laptop to static

if i set the laptop to static ip address i can ping the 172.16.60.254. What im trying to do is to have the dhcp server to provide lease ip address to the laptop. Note that the dhcp server and the desktop computer is under vlan 20 and the access point is under vlan 10. Im not sure if that configuration is right to start with.

Highlighted
Enthusiast

IP helper.

IP helper.

Highlighted
Beginner

Here how it goes from the

Here how it goes from the external server DHCP i configured the port to 

Switchport mode trunk

encapsulation dot1q 

switchport trunk native vlan 20

allowed vlan 10, 20, 30.

i also added ip helper-address to the svi interface it points to the external server dhcp 192.168.60.221. For the vlan 20 ports its acquiring lease ip address which is 192.168.60.xx. but for the the laptop side its not acquiring the 172.16.60.xx address... the svi interfaces are up up. 

Highlighted
Beginner

I've fixed the problem. no

I've fixed the problem. no need to do switchport trunk for the f0/3 port for dhcp connection. access mode will do the job for vlan. ip helper address and svi should be configured correctly. Thanks everyone.

Highlighted
Beginner

   I think you need to define

   I think you need to define the interface Fa0/2 as trunk port that way the trunk port will carry the traffic from  all vlans. and also pls verified that all vlans are up.

    

  Switchport mode trunk

  encapsulation dot1q 

  allowed vlan 10, 20, 30.

    Thanks 

Beginner

Hi LC O,

Hi LC O,

I hope, you should add another interface in the server part for two vlan setup and has to configure a static IP vlan 10 for the wifi pool.

1- Already, Fa0/3 configured for vlan 20 assigned for desktop

2 - make connectivity between interface fa0/4 and server - assign it to vlan 10 in switch side

it will work even if you have removed the helper-address. Here there is no routing involved so, it won't consider to be L3 switching issue FYKI.

BR

Prem

CreatePlease to create content
Content for Community-Ad