cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
9921
Views
0
Helpful
7
Replies
UARadiation
Beginner

Major Version Mismatch

We have a switch stack of two Catalyst 3750's and are trying to add a Catalyst 3750E.

One of the 3750's is the stack master.

Upon reloading the 3750E it prompts:

%STACKMGR-5-MAJOR_VERSION_MISMATCH: Major Version Mismatch (Local 6 - Received 1) with neighbor-1

and then elects itself the master because it did not join the existing stack.

I did some digging using the show platform stack-manager all command to find out that the 3750's have the stack version number 1.45 and the 3750E has 6.45. This would obviously confirms the mismatch but from what I have read if the systems have the IOS then this should not be an issue and all switches have 12.2(55)SE1.

I don't know if the IOS packages matter to resolve this issue but they are c3750-ipservicesk9-m and c3750e-universialk9npe-mz.

Hopefully this will be a simple fix so I can get the stack up and running quickly.

1 ACCEPTED SOLUTION

Accepted Solutions

Hello I have two switches with the same issue

 

Master WS-C3750X-24P-L - Firmware c3750e-ipbasek9-mz.150-2.SE8

Slave WS-C3750G-12S-S - Firmware c3750-ipbasek9-mz.122-55.SE10

 

I'm getting the error STACKMGR-5-MAJOR_VERSION_MISMATCH do you know what could be causing this issue?

 

 

View solution in original post

7 REPLIES 7
mutiatadetutu
Beginner

Hi,

The ios you install on the stack switches must be exactly the same. If there is mismatch ios,then the switch with a different ios would not be part of the stack. You can use this ios (c3750-ipservicesk9-m) on all the switches and that should resolve the issue.

Hello I have two switches with the same issue

 

Master WS-C3750X-24P-L - Firmware c3750e-ipbasek9-mz.150-2.SE8

Slave WS-C3750G-12S-S - Firmware c3750-ipbasek9-mz.122-55.SE10

 

I'm getting the error STACKMGR-5-MAJOR_VERSION_MISMATCH do you know what could be causing this issue?

 

 

View solution in original post

ranraju
Cisco Employee

The stack would definitely come up if you have the same version and the feature set in all its member switches. But if you want to have a mixed feature set and mixed hardware then it would be best if you could go through the following link once.

http://www.cisco.com/en/US/docs/switches/lan/catalyst3750x_3560x/software/release/12.2_55_se/configuration/guide/swstack.html#wp1142379

Can you paste here the exact model numbers of the switches and the image that you are running in each of them.

Regards,

ranraju

The 3750s are:

WS-C3750G-24T-S(Stack Master)

WS-C3750G-24TS-S

They have C3750-IPServicesk9-m

The new switch is actually not a 3750E it's a WS-C3750X-24T-L V01

I must have confused the model with the IOS package because the package is C3750e-univeralk9npe-mz

I have read multiple times that article and I know that this will be a mixed hardware stack but I am unsure of mixed software because the naming convention is differnet between the old switches and the new one ie Ipservices vs. Universal.

Thank you.

Leo Laohoo
VIP Community Legend

I must have confused the model with the IOS package because the package is C3750e-univeralk9npe-mz

Don't use the "universal" package if you are going to mix the stack with a plain 3750.  If you have IP Services then you need to downgrade the feature set accordingly.

So to clarify you are saying to downgrade both of the swtich IOS's to a IPBase package?

tj.mitchell
Enthusiast

You need to run the same version of IOS on all the switches. You "universal" on the X series and a none "universal" on the other.

There's your issue.

Sent from Cisco Technical Support iPhone App