cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1895
Views
5
Helpful
3
Replies
Braian Jacomelli
Beginner

ME3400 problem to forward layer2 between the interfaces

Hello,

I'm having a problem with a ME3400 switch. When the interfaces are configured to work as a switch, the layer 2 traffic is not forwarded between the switch. I tried to put two devices on the same net (10.0.0.1/24 and 10.0.0.2/24) and send ping packets from the 10.0.0.2 to 10.0.0.1, but the ICMP packets aren't received.

If I configure two interfaces with diferent IP adresses (10.0.0.1/24 and 10.2.2.1/24) and enable de "ip routing", the switch can route the packets without no problem.

I already tried to reset the switch to default factory config, upgrade and downgrade the IOS, but the problem is the same.

Does someone know how to resolve this problem?

1 ACCEPTED SOLUTION

Accepted Solutions
acampbell
Advocate

Hi.

By default all fast ethernet ports on ME3400
are in Vlan 1 but they are all of a type UNI

This means they are all isolated from each other (like private vlans)

If you want the switch to opeate like 3560/3570/3550 etc

You need the IOS feature set IPACCESS you can then set all your ports to be type NNI

!
interface range fas0/1 - 24
shut
port-type nni
! ANY OTHER COMMON SETTINGS YOU WANT
no shut
!

Please the the config guides for your IOS version
e.g.
http://www.cisco.com/c/en/us/td/docs/switches/metro/me3400/software/release/12-2_25_seg_seg1/configuration/guide/3400scg/swint.html#wp1554661

Hope this helps

Regards
Alex

Regards, Alex. Please rate useful posts.

View solution in original post

3 REPLIES 3
John Blakley
Advisor

The only thing that I can think of is, when in L2, are the two devices on the same vlan? If they're in separate vlans, you won't be able to ping between them. Make sure that both ports are configured for the same vlan, disable routing, and then you should be able to ping between as long as they're in the same subnet.

HTH,

John

HTH, John *** Please rate all useful posts ***
acampbell
Advocate

Hi.

By default all fast ethernet ports on ME3400
are in Vlan 1 but they are all of a type UNI

This means they are all isolated from each other (like private vlans)

If you want the switch to opeate like 3560/3570/3550 etc

You need the IOS feature set IPACCESS you can then set all your ports to be type NNI

!
interface range fas0/1 - 24
shut
port-type nni
! ANY OTHER COMMON SETTINGS YOU WANT
no shut
!

Please the the config guides for your IOS version
e.g.
http://www.cisco.com/c/en/us/td/docs/switches/metro/me3400/software/release/12-2_25_seg_seg1/configuration/guide/3400scg/swint.html#wp1554661

Hope this helps

Regards
Alex

Regards, Alex. Please rate useful posts.
Braian Jacomelli
Beginner

Thank you! I don't have too much experience with this device, but configure the ports to "NNI" solved the problem.

 

Regards

Braian