12-10-2012 12:08 PM - edited 03-07-2019 10:31 AM
I have an 1811 with several subnets connected to it.
I recently installed a 3750x plant and want to bring my interior routing back to it.
All the routing is handled by the 1811 via secondary interfaces on vlan1
I have 192 ports, and subnets show up on almost all of them. None of the ports are assigned to any specific vlans. Most ports have several subnets on them.
What is the best approach to getting the 3750x to handle the routing?
Thanks
Solved! Go to Solution.
12-11-2012 09:55 AM
Disclaimer
The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
Liability Disclaimer
In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
Posting
Perhaps the "easiest" thing to do would be to transfer all the gateway IPs to a single SVI on the 3750-X. In effect, mimicking what you have now on you 1811. If you still need the 1811 for other routing, e.g. WAN, then you'll likely need to reconfigure how the 1811 and 3750-X interact; various ways you can do that. For example, you could have the 1811 and 3750-X with interface on all your subnets, or you could set up a L3 transit link between them and route between them.
12-10-2012 01:52 PM
Are you doing MPLS now or will you be doing MPLS? If yes, then 3750X will NOT support MPLS but only VRF-lite.
12-10-2012 01:57 PM
My switch default route will still point at my router. My client machines should look to the switch for the default route.
12-10-2012 02:06 PM
You should be able to create the SVI's on the switch and enable IP routing, that should be it.
12-11-2012 07:31 AM
Here is my config so far. I have two devices connected
10.10.23.185 (Internet Router)
10.10.44.2 (XP VMware connected to one of the Gb interfaces)
I cannot ping 10.10.44.185 from XP
The port channel is to another office, using LACP to a nortel baystack switch.
ip routing
!
interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
speed nonegotiate
!
interface Port-channel2
!
interface FastEthernet0
ip address 10.10.23.1 255.255.255.0
ip rip send version 1 2
no ip route-cache cef
no ip route-cache
no ip mroute-cache
!
!
interface GigabitEthernet1/0/41
description .185
!
interface GigabitEthernet1/0/42
description Sniffer Box
!
interface GigabitEthernet1/0/43
description DSL line
!
!
interface GigabitEthernet1/1/1
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
speed nonegotiate
channel-group 1 mode active
!
interface GigabitEthernet1/1/2
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
speed nonegotiate
channel-group 1 mode active
!
!
interface Vlan1
no ip address
!
interface Vlan2
ip address 10.10.24.1 255.255.255.0
ip rip send version 1 2
!
interface Vlan20
ip address 10.10.48.185 255.255.252.0
!
interface Vlan30
ip address 10.10.44.185 255.255.252.0
ip rip send version 1 2
!
router rip
network 10.0.0.0
neighbor 10.10.23.185
!
ip default-gateway 10.10.23.185
ip classless
ip route 0.0.0.0 0.0.0.0 10.10.23.185
12-11-2012 08:08 AM
You do not need "ip default-gateway ..." statement when you are running in L3 mode. Make sure on your end devices 10.10.44.185 is your default gateway with a subnet mask of 255.255.252.0 for starters. Can you ping the router from the switch i.e; 10.10.23.1?
12-11-2012 08:13 AM
Yes, I can ping the router from the switch, and ssh to it. Yes my end device has an IP of 10.10.44.2/22 and it's default gateway is 10.10.44.185.
I do have rip setup and my 10.10.23.185 router has CDP setup... So I am starting to think that is messing with things.
When I do a ping from 10.10.44.2 to 10.10.44.185 I get a mac of 00-00-00-00-00 in my arp table on the xp machine.
12-11-2012 08:27 AM
Can you post the show runn interface for the ports those two devices are connected to? Also did you check the firewall on the XP machine perhaps that might be blocking it?
Can you ping 10.10.44.185 at least from the two devices? You mentioned VMWARE so is the NIC configured for the VLAN's? Which means the port should be trunked too.
12-11-2012 08:39 AM
Nothing is configured on the interfaces that xp is connected to. I can ping 10.10.44.185 from the router via 10.10.23.1
There is no firewall configured on the xp machine. I will make a new VM to test as this is my crash and burn VM
#sho run int gi2/0/36
Building configuration...
Current configuration : 39 bytes
!
interface GigabitEthernet2/0/36
end
This is where the router is connected
interface FastEthernet0
ip address 10.10.23.1 255.255.255.0
ip rip send version 1 2
no ip route-cache cef
no ip route-cache
no ip mroute-cache
12-11-2012 08:54 AM
Thank you Mike however I need to see the routers port how that is configured. Also I meant can you ping 10.10.44.185 from the XP machine and the VM?
Secondly the ports that XP machine is connected to is that the gi2/0/36 port? if that is the case then it will need to be configured something like this so it knows which VLAN it needs to be on:
interface gi2/0/36
switchport mode access
switchport access vlan 30
And the port VM is connected to depends on how you have the VM NIC configured.
12-11-2012 09:10 AM
Here is the interface on the router, it's currently got all of our subnets in Vlan1
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-FE 2$$ES_LAN$$FW_INSIDE$
ip address yyy.yyy.yyy.185 255.255.255.0 secondary
ip address 10.170.10.254 255.255.255.0 secondary
ip address 10.173.10.254 255.255.255.0 secondary
ip address 10.162.10.254 255.255.255.0 secondary
ip address 10.4.158.1 255.255.255.0 secondary
ip address 10.109.111.1 255.255.255.0 secondary
ip address 192.168.100.1 255.255.255.0 secondary
ip address 192.168.22.129 255.255.255.192 secondary
ip address 10.19.250.185 255.255.255.0 secondary
ip address 10.236.80.254 255.255.255.0 secondary
ip address 10.10.23.185 255.255.255.0 secondary
ip address 10.10.50.185 255.255.252.0 secondary
ip address xxx.xxx.xxx.185 255.255.255.0
12-11-2012 09:29 AM
If I put switchport on the interface the XP machine is connected to, it will put that interface in L2 mode, which I do not want to do.
12-11-2012 09:38 AM
Mike you have to connect a end devices like that to a switch.
And the interface you gave me on the router is the VLAN 1 with the secondary IP's connected to it. What about the physical interface?
12-11-2012 09:44 AM
Fair enough, I will test that with another interface. We are installing a VOIP system (Cisco Call Manager). Each port will have at least 2 vlans on them, one for voice and the other for Data. Will all of our ports need to be configured as trunk ports?
12-11-2012 08:18 AM
I am trying to avoid putting the vlans into specific interfaces as our subnets are all across the interfaces. Lots of vmware here.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide