cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
6944
Views
0
Helpful
3
Replies
Highlighted

Multicast over GRE tunnel

I setup a GRE tunnel between two cisco 1800 & 1900 routers. I can't received multicast.

Here is a copy of my configs:

R3#
Building configuration...

Current configuration : 1238 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
dot11 syslog
ip source-route
!
ip cef
ip multicast-routing
no ipv6 cef
!
multilink bundle-name authenticated
!
archive
log config
  hidekeys
!
interface Loopback0
ip address 10.0.0.3 255.255.255.255
!
interface Tunnel0
ip address 192.168.24.2 255.255.255.252
ip pim sparse-mode
tunnel source Loopback0
tunnel destination 10.0.0.1
!
interface FastEthernet0/0
ip address 10.0.3.1 255.255.255.0
ip pim sparse-mode
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.23.2 255.255.255.252
ip pim sparse-mode
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
shutdown
no fair-queue
clock rate 2000000
!       
router eigrp 1
network 10.0.0.3 0.0.0.0
network 10.0.3.1 0.0.0.0
network 192.168.23.2 0.0.0.0
no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
control-plane
!
line con 0
line aux 0
line vty 0 4
exec-timeout 5 0
privilege level 15
no login
!
scheduler allocate 20000 1000
end

R2#
Building configuration...

Current configuration : 1029 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
dot11 syslog
ip source-route
!
ip cef
ip multicast-routing
no ipv6 cef
!
multilink bundle-name authenticated
!
archive
log config
  hidekeys
!
interface Loopback0
ip address 10.0.0.2 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.23.1 255.255.255.252
ip pim sparse-mode
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.12.2 255.255.255.252
ip pim sparse-mode
duplex auto
speed auto
!
router eigrp 1
network 10.0.0.2 0.0.0.0
network 192.168.12.2 0.0.0.0
network 192.168.23.1 0.0.0.0
no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
control-plane
!
line con 0
line aux 0
line vty 0 4
exec-timeout 5 0
privilege level 15
no login
!
scheduler allocate 20000 1000
end

R1#
Building configuration...

Current configuration : 1316 bytes
!
! Last configuration change at 04:25:02 UTC Mon Sep 3 2012
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
no ipv6 cef
ip source-route
ip cef
!
ip multicast-routing
!
multilink bundle-name authenticated
!
crypto pki token default removal timeout 0
!
license udi pid CISCO1921/K9 sn FGL152624YV
!
interface Loopback0
ip address 10.0.0.1 255.255.255.255
!
interface Tunnel0
ip address 192.168.24.1 255.255.255.252
ip pim sparse-mode
tunnel source Loopback0
tunnel destination 10.0.0.3
!
interface GigabitEthernet0/0
ip address 192.168.12.1 255.255.255.252
ip pim sparse-mode
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 10.0.1.1 255.255.255.0
ip pim sparse-mode
duplex auto
speed auto
!
router eigrp 1
network 10.0.0.1 0.0.0.0
network 10.0.1.1 0.0.0.0
network 192.168.12.1 0.0.0.0
!
ip forward-protocol nd
!
ip mroute 10.0.3.0 255.255.255.0 Tunnel0
ip mroute 10.0.0.3 255.255.255.255 Tunnel0
no ip http server
no ip http secure-server
!
control-plane
!
line con 0
line aux 0
line vty 0 4
exec-timeout 5 0
privilege level 15
no login
transport input all
!
scheduler allocate 20000 1000
end

R3#

Cisco IOS Software, 1841 Software (C1841-ADVIPSERVICESK9-M), Version 12.4(24)T1, RELEASE SOFTWARE (fc3)

R2#

Cisco IOS Software, 1841 Software (C1841-ADVIPSERVICESK9-M), Version 12.4(24)T1, RELEASE SOFTWARE (fc3)

R1#

Cisco IOS Software, C1900 Software (C1900-UNIVERSALK9-M), Version 15.1(3)T1, RELEASE SOFTWARE (fc2)

Thank you very much

Everyone's tags (5)
3 REPLIES 3
Highlighted

Multicast over GRE tunnel

now, i changed configure:

R1(config)#no ip mroute 10.0.3.0 255.255.255.0 Tunnel0

R1(config)#no ip mroute 10.0.0.3 255.255.255.255 Tunnel0

R1(config)#ip pim rp-address 10.0.0.2

R2(config)#ip pim rp-address 10.0.0.2

R3(config)#ip pim rp-address 10.0.0.2

receiver can received. but not pass through gre tunnel ?

R1#sho ip mro 239.12.9.3
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group,
       V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.12.9.3), 02:35:44/stopped, RP 10.0.0.2, flags: SJC
  Incoming interface: GigabitEthernet0/0, RPF nbr 192.168.12.2
  Outgoing interface list:
    GigabitEthernet0/1, Forward/Sparse, 00:03:55/00:02:09

(10.0.3.2, 239.12.9.3), 00:15:30/00:02:04, flags: JT
  Incoming interface: GigabitEthernet0/0, RPF nbr 192.168.12.2
  Outgoing interface list:
    GigabitEthernet0/1, Forward/Sparse, 00:03:55/00:02:09

Highlighted
Beginner

Re: Multicast over GRE tunnel

Highlighted

Re: Multicast over GRE tunnel

now I no configuration about multicast on R2.

and only enable ip pim sparse-mode on Tunnel GRE and LAN interface of R1 and R3.

R3#

!

ip multicast-routing

!

interface Loopback0

ip address 10.0.0.3 255.255.255.255

!

interface Tunnel0

ip address 192.168.24.2 255.255.255.252

ip pim sparse-mode

tunnel source Loopback0

tunnel destination 10.0.0.1

!

interface FastEthernet0/0

description to source multicast

ip address 10.0.3.1 255.255.255.0

ip pim sparse-mode

!

interface FastEthernet0/1

ip address 192.168.23.2 255.255.255.252

!

router eigrp 1

network 10.0.0.3 0.0.0.0

network 10.0.3.1 0.0.0.0

network 192.168.23.2 0.0.0.0

no auto-summary

R2#

!

interface Loopback0

ip address 10.0.0.2 255.255.255.255

!

interface FastEthernet0/0

ip address 192.168.23.1 255.255.255.252

!

interface FastEthernet0/1

ip address 192.168.12.2 255.255.255.252

!

router eigrp 1

network 10.0.0.2 0.0.0.0

network 192.168.12.2 0.0.0.0

network 192.168.23.1 0.0.0.0

no auto-summary

R1#

!

ip multicast-routing

!

interface Loopback0

ip address 10.0.0.1 255.255.255.255

!

interface Tunnel0

ip address 192.168.24.1 255.255.255.252

ip pim sparse-mode

tunnel source Loopback0

tunnel destination 10.0.0.3

!

interface GigabitEthernet0/0

ip address 192.168.12.1 255.255.255.252

!

interface GigabitEthernet0/1

ip address 10.0.1.1 255.255.255.0

ip pim sparse-mode

!

router eigrp 1

network 10.0.0.1 0.0.0.0

network 10.0.1.1 0.0.0.0

network 192.168.12.1 0.0.0.0

!

ip mroute 10.0.3.0 255.255.255.0 Tunnel0

It worked. multicast can passed GRE Tunnel, but I must use 224.0.1.40 for source. I can't change to other IP. What should I do ? (I use 239.x.x.x in real network.)

CreatePlease to create content
Content for Community-Ad