cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
47575
Views
165
Helpful
28
Replies

Multiple OSPF Processes

visitor68
Level 4
Level 4

Why would someone run multiple OSPF processes on the same router?

What are the implications?

Are there two SEPARATE databases that are established, one for each process?

Are these processes totally isolated?

What about the RIB? Are there effectively separate routing tables?

lets say a route is learned through both OSPF processes, what happens then....?

Another quick question:

router ospf 499

router-id 10.199.254.38

log-adjacency-changes

auto-cost reference-bandwidth 1000000

nsf

area 1 authentication message-digest

redistribute static metric-type 1 subnets route-map into-ospf

network 10.195.48.40 0.0.0.7 area 1

network 10.195.48.48 0.0.0.15 area 1

network 10.199.254.38 0.0.0.0 area 1

network 99.207.255.8 0.0.0.0 area 1

!

router ospf 599

log-adjacency-changes

auto-cost reference-bandwidth 1000000

nsf

area 0 authentication message-digest

area 2 authentication message-digest

redistribute static

passive-interface default

no passive-interface GigabitEthernet4/1

no passive-interface Vlan98

no passive-interface Vlan99

network 10.195.48.8 0.0.0.3 area 2

network 10.195.48.32 0.0.0.7 area 2

network 10.195.48.248 0.0.0.7 area 0

network 10.195.49.0 0.0.0.127 area 2

network 10.195.50.0 0.0.0.127 area 2

network 10.195.64.0 0.0.15.255 area 2

network 10.195.80.0 0.0.0.255 area 2

<b>interface GigabitEthernet4/1

ip address 10.195.48.53 255.255.255.240</b>

Notice the IP address of this interface. OSPF 499 is running OSPF on this interface (see the network statement), yet the interface is un-passived out in OSPF599....why is that? Typos?

Thanks

28 Replies 28

Yes if a router is running 2 separate OSPF processes then each process can have its own separate area 0.

HTH

Rick

HTH

Rick

Hi,

 

Please find attached for your reference.

R4 acting as ABR and not sending routes from R6 to R2 and vice-versa is this expected? And that is what you want to say in your explanation?

 

Also as we all know OSPF process is locally significant to router..then why this rule is not applicable here? 

 

Regards,

Deepak

Hi Richard ,

Yes if a router is running 2 separate OSPF processes then each process can have its own separate area 0. it was mentioned by you in the thread.

I have a requirement where in i have to run another OSPF process which will be part of area 0 on Nexus 7k switches . Currently we are running ospf process 10 which is part of area 0 and legacy switches are cnnected to Nexus 7k using ospf 10.

I would like to know , If We run two ospf porcesses in area 0 , do we need redistribution between two ospf processes .
If any documents which explains two ospf porcesses in area 0 on nexus 7k would be very helpful.


Diagram is as below :

Cisco ACI ---> OSPF  area 0 ----> FW ---> OSPF area 0 ----> Cisco 6800 ----> WAN N/W

Legacy n/w --OSPF area 0 -------> Nexus 7k (WAN_VDC) ----Static routes ----- > Cisco ACI


Between Cisco ACI and Nexus 7ks we have static routes configured which will be replaced with Dynamic routing protocol , OSPF or EBGP.

We are checking possiblity of OSPF in area 0 on Nexus 7k between Cisco ACI and Nexus 7k.

Currently we are running ospf 10 in area 0 for legacy network on Nexus 7k.If we connect Cisco ACI in area 0 by using another ospf process (example 20) ,

1)do we need route filters under each ospf process to allow only routes required under them.
2) Do we need redistribution of ospf porcesses because if we allow same subnets under each ospf process then how Nexus 7k identifies them as we are going to have single RIB.
any example document which shows different ospf processes in area 0 on nexus 7ks.
what are pros and cons if we use OSPF between Cisco ACI and Nexus 7ks ..



Hi diagram is as below.cisco aci and nexus 7k design.jpg

Had a similar question, thanks alot this answer was helpful 

According to this link: https://www.quora.com/What-is-the-purpose-of-OSPF-process-ID

the router choose the first route learned instead of load balancing.

I tried with GNS3 and it does seem to be the case. 

"Why would someone run multiple OSPF processes on the same router? --you can do it but to able to achieve routing between them you have to use the redistribution."

Actually, not exactly. By default, running multiple OSPF processes works much like running multiple routing protocols on the same device. I.e. each will have its own OSPF topology database, but (without using VRFs) there will only be one global route table. Redistribution is only needed if you want to distribute one process's routes to be advertised to the other's routing domain. I.e. although the device hosting the multiple OPSF processes will "know" of each OSPF process's topology, other routers in those routing topologies will not.

As to OP's original question, why do it? Well, again by default, to not "share" each OSPF process topology with all the routers in each topology.

"What about the RIB? Are there effectively separate routing tables? -yes"

No, not without using VRFs.

"lets say a route is learned through both OSPF processes, what happens then....? "

See first answers, above.

Hi Joseph ,

 

Thank you for the information..

 

But actually, we got the requirement to run two OSPF processes on nexus 7ks in area 0 .

To avoid learning same subnet from these two OSPF processes , we have to use filters along with redistribution as per my knowledge. Since I have very less knowledge on OSPF to OSPF redistribution can you suggest filtering mechanism of subnets for both incoming and outgoing with an example if any .

 

As per the diagram , when we establish ospf connectivity with process id 20 between Cisco ACI and nexus 7ks  ( static routes would be replaced with ospf 20 ) we would learn routes from CIsco ACI through ospf 20 (area 0 ) and we already advertised legacy networks using existing  ospf process 10 (area 0 ) and also ospf process 10 is redistributed into BGP and vice-versa,

 

Would like to know what precautions to be taken care while redistributing ospf pro 10 into ospf pro 20 and vice versa.

 

Many Thanks

 

"Would like to know what precautions to be taken care while redistributing ospf pro 10 into ospf pro 20 and vice versa."

 

Should be pretty much same precautions taken when working with two different routing protocols on the same device.  What's different, ADs will be the same and no issues with metric "translations".

Hi Joseph ,

thank you very much for the information..
Do we have any document of nexus 7k where we have ospf to ospf redistribution scenario .

Many Thanks..

None that I'm aware of.

Hi Joseph , thank you ..I would like to know equivalent command in ospf similar to no-export in BGP..Is there any way to stop propagation of routes to other ospf processes ..am looking same functionality commands in ospf as that of no-export ..Many Thanks

"Is there any way to stop propagation of routes to other ospf processes"

Yes, believe you can run your export routes through a route-map and select what routes you want to export. Also, I've also redistribute using route tags, which makes in much easier to determine source of redistributed routes. (BTW, no OSPF auto equivalent of BGP's "no-export" [of which I'm aware].)

I am a little puzzled why this discussion camped on to a very old discussion rather than starting a new thread. But here it is and so we will attempt to respond to it.

 

I do not believe that there is anything in OSPF equivalent to BGP no-export.

 

You ask this question

Is there any way to stop propagation of routes to other ospf processes

The question seems to assume that propagation of routes to other ospf process will happen automatically. That is not the case. Routes learned in one OSPF process will not propagate to another OSPF process unless you configure redistribution. And if you configure redistribution then you can control that redistribution to allow only specified routes to be redistributed.

 

There is much about the topology in this new discussion that I do not understand. The question seems to based on having a single area 0 with multiple processes running in it. But that is not how OSPF works. Each OSPF process has its own area 0. Perhaps the poster of this newer question can provide some clarification about what is going on and what the requirements are?

 

HTH

 

Rick

 

 

 

HTH

Rick
Review Cisco Networking for a $25 gift card