cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
7276
Views
9
Helpful
5
Replies
Highlighted
Beginner

multiple vlans on one switch

hi all,

I'm having some issues creating multiple vlans on one swtich (2950).

This is a lab setup that I'm going through in an attempt to learn a bit more about Cisco. I bought 3 1841 routers, and 3 2950 switches and I'm trying different setups.

A particular senario I'm unable to get past is the following:

I'm trying to create two vlans on one switch:

SW1: vlan 30 and vlan 100

ports 23 and 24 are trunks to sw2

SW2: ports 21, 22, 23, 24 are trunks

SW3: vlan 30 and vlan 200

ports 23 and 24 are trunks to sw2

seems simple enough:

R1 connects fa0/1 to vlan 100

R1 connects fa0/0 to vlan 30

R2 connects fa0/0 to vlan 30

R2 connects fa0/1 to vlan 200

and I've a computer plugged in with respective addresses to each vlan 100 and 200

The problem is as follows:

whenever I issue a no shut command on a vlan in any of the switches, I get the error:

%LINK-3-UPDOWN: Interface Vlan23, changed state to up

%LINK-5-CHANGED: Interface Vlan200, changed state to administratively down

%LINEPROTO-5-UPDOWN: Line protocol onInterface Vlan23, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol onInterface Vlan200, changed state to down

And it happens on both switches. It seems I can only have one vlan up at the one time..? Is this a genuine restriction or am I doing something wrong/missing something in the way I'm setting things up?

My configuration is as simiple as:

SW1:

vlan 30

name blue

vlan 100

name orange

int range fa0/1 - 2

switchport mode access

switchport access vlan 100

no shut

int fa0/9

switchport mode access

switchport access vlan 30

no shut

int range fa0/23 - 24

switchport mode trunk

no shut

SW3:

vlan 30

name blue

vlan 300

name green

int range fa01 - 2

swithcport mode access

switchport access vlan 200

no shut

int fa0/9

switchport mode access

switchport access vlan 30

no shut

int range fa0/23 - 24

switchport mode trunk

no shut

SW2:

int range fa0/21 - 24

switchport mode trunk

no shut

Everyone's tags (3)
5 REPLIES 5
Highlighted
Advisor

multiple vlans on one switch

Hi,

this is indeed a restriction on pure L2 switches( like the 2950)  as the Vlan interface is just used for management purposes.

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
Highlighted
Advisor

multiple vlans on one switch

  Cadet has pretty much explained it .  Think about your OSI model, a 2950 is a pure layer 2 switch so it does no routing so why would you need more than a single SVI active on the switch other than to manage the switch. So you have a single SVI (ip management) address on the switch with a default gateway pointing to the L3 routing devices which would be your routers to manage the switch . On a 2950 it can only have a single SVI active so it disables the other SVI's which is normal behavior. think you are getting confused  between Layer 2 and Layer 3 where the routing is done. Do a show vlan and make sure all your layer 2 vlans on the switch show. When you create a layer 3 SVI it does not create a layer 2 vlan instance.

Highlighted
Beginner

multiple vlans on one switch

Hi, thanks for the reply and clarification.

I think I'm getting confused by more than just the layers.

Does this mean that additional vlans are pointless in L2 switches?

Aside from switch management, what would be the reason to create additional vlans?

Highlighted
VIP Expert

multiple vlans on one switch

Does this mean that additional vlans are pointless in L2 switches?

It is pointless if you don't have a layer-3 device to route between vlans.  Don't forget, you can create a lot of layer-2 vlans on your 2950, the restriction is that you can only have one layer-3 SVI or interface.

So, for example you can simply create multiple layer-2 vlans on the 2950, but in order to route between multiple vlans, you need a device that is capable of doing layer-3, like a 3550, 3560 or a 3750 or a router.

Is that more clear now?

HTH

Beginner

multiple vlans on one switch

Hi Ivan,

Does this mean that additional vlans are pointless in L2 switches?

Aside from switch management, what would be the reason to create additional vlans?

VLAN on l2 are not pointless they are always useful to segregate the traffic from different VLAN.....

We create multiple VLANs on L2 switch to limit broadcast domain.So traffic for one Vlan is not sent to another VLAN hence limiting unnecessary broadcast.

Now if we want communication between devices connected to separate VLANS then we have to connect one of the Switch interface to L3 device and on that L3 device create subinterfaces for each Vlan.

For eg if if i ll take your switch 3 and connect it's interface fa 0/9 to Router fa 0/0 then configuration will be like this:-

Sw3(config)#interface FastEthernet0/9
Sw3(config-if)#switchport trunk encapsulation dot1q
Sw3(config-if)#switchport mode trunk

Router(config)#interface FastEthernet0/0
Router(config-if)#no ip address
Router(config-if)#interface FastEthernet0/0.5
Router(config-su

bif)#encapsulation dot1Q 5
Router(config-subif)#ip add  
Router(config-subif)#interface FastEthernet0/0.10
Router(config-subif)#encapsulation dot1Q 10
Router(config-subif)#ip add  

Always keep in mind that u have to create a trunk interface between router and switch otherwise traffic for all the VLANS will not move.

HTH

MJ

CreatePlease to create content
Content for Community-Ad