cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Popup Hotspot Using ISR 1000 with WiFi/LTE for Teleworkers and Micro Branchesr
244
Views
10
Helpful
11
Replies
Highlighted
Beginner

N9K - OSPF Totally stubby area

Hello All,

I have the below topology, the OSPF neighborship is established but the default route is not being generated in OSPF Area as it's a totally stub area.

Topology Sample.PNG

Configuration as the below;

N9K-SW1

router ospf 1
area 0.0.0.2 stub no-summary

interface Vlan210
ip ospf network broadcast
ip router ospf 1 area 0.0.0.2

interface port-channel4
ip ospf network broadcast
ip router ospf 1 area 0.0.0.2

 

N9K-SW2

router ospf 1
area 0.0.0.2 stub no-summary

interface Vlan210
ip ospf network broadcast
ip router ospf 1 area 0.0.0.2

interface port-channel4
ip ospf network broadcast
ip router ospf 1 area 0.0.0.2

 

VSS-Core

router ospf 1
area 0.0.0.2 stub no-summary

interface Vlan200
ip ospf network broadcast
ip router ospf 1 area 0.0.0.2

 

Please advice.

Regard,

 

2 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted
Collaborator

Re: N9K - OSPF Totally stubby area

Hi,

 

    On the VSS, you're running two OSPF processes, one runs in AREA 0, the other one in the stub area. You would have to remove OSPF PID 1 and reconfigure your stub settings in OSPF PID 2:

 

 

Routing Process 2 with ID 1.1.1.1 VRF default

Routing Process Instance Number 2

Number of active areas is 1, 1 normal, 0 stub, 0 nssa

Area BACKBONE(0.0.0.0)

Interfaces in this area: 1 Active interfaces: 1

 

Routing Process 1 with ID 1.1.1.1 VRF default

Routing Process Instance Number 1

Number of active areas is 1, 0 normal, 1 stub, 0 nssa

Interfaces in this area: 1 Active interfaces: 1

Area (0.0.0.2)

This area is a STUB area

 

Also, if the Nexuses are not ABR's, there is no need for the "no-summary" keyword when you define the stub area; this keyword does not mean any additional flags that would need to be matched for OSPF adjacency to come up; this keyword just tells the ABR to also filter Type3 LSA's in that area.

 

 

Regards,

Cristian Matei.

View solution in original post

Highlighted
Participant

Re: N9K - OSPF Totally stubby area

Hi,

Your Area 0 is in OSPF process 2, while your Stub Area 2 is in OSPF process 1. They are basically unrelated.

 

( To avoid duplicated discussion in this thread, Let's refer to @Cristian Matei 's reply to keep on going if you have further questions. I think his explanation is quite clear.)

View solution in original post

11 REPLIES 11
Highlighted
Participant

Re: N9K - OSPF Totally stubby area

Hi,

The diagram show that it's area 2, but the configuration show that it's area 4.

But it's not the point... The point is, ABR will send out the default route to Totally Stub Area.

However, I can't see there is a ABR (with area 0) in your diagram nor the configuration.

Is it a single area design? or backbone area is hidden in somewhere else? Please check.
Highlighted
Beginner

Re: N9K - OSPF Totally stubby area

Hi,
As for the Area it's 2, as for the backbone area it's configured on the core switch but not shown in the diagram.

Regards,
Highlighted
Participant

Re: N9K - OSPF Totally stubby area

Hi,

1. Kindly use 'show ip ospf' to verify the role on core switches are ABR.

IOU2# show ip ospf
Routing Process "ospf 1" with ID 1.1.1.1
Start time: 00:01:13.133, Time elapsed: 00:03:10.218
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS)
Supports area transit capability
Supports NSSA (compatible with RFC 3101)
Supports Database Exchange Summary List Optimization (RFC 5243)
Event-log enabled, Maximum number of events: 1000, Mode: cyclic
It is an area border router <------------------------


2. Kindly use 'show ip ospf database summary' on core switches, check if there is a Type-3 with LSID 0.0.0.0 in Area 2 (your stub area).

Summary Net Link States (Area 2) <---------------

LS age: 89
Options: (No TOS-capability, DC, Upward)
LS Type: Summary Links(Network)
Link State ID: 0.0.0.0 (summary Network Number) <----------
Advertising Router: 1.1.1.1
LS Seq Number: 80000001
Checksum: 0x93A6
Length: 28
Network Mask: /0

3. Also make sure Area 2 is present on your ABR (the core switch), and configured that Area 2 is a totally stub area type.

Highlighted
Beginner

Re: N9K - OSPF Totally stubby area

Hi,
1- The core switch is acting as ABR as the below;

AREA0

Routing Process 2 with ID 1.1.1.1 VRF default
Routing Process Instance Number 2
Stateful High Availability enabled
Graceful-restart is configured
Grace period: 60 state: Inactive
Last graceful restart exit status: None
Supports only single TOS(TOS0) routes
Supports opaque LSA
Administrative distance 110
Reference Bandwidth is 40000 Mbps
SPF throttling delay time of 200.000 msecs,
SPF throttling hold time of 1000.000 msecs,
SPF throttling maximum wait time of 5000.000 msecs
LSA throttling start time of 0.000 msecs,
LSA throttling hold interval of 5000.000 msecs,
LSA throttling maximum wait time of 5000.000 msecs
Minimum LSA arrival 1000.000 msec
LSA group pacing timer 10 secs
Maximum paths to destination 8
Number of external LSAs 0, checksum sum 0
Number of opaque AS LSAs 0, checksum sum 0
Number of areas is 1, 1 normal, 0 stub, 0 nssa
Number of active areas is 1, 1 normal, 0 stub, 0 nssa
Install discard route for summarized external routes.
Install discard route for summarized internal routes.
Area BACKBONE(0.0.0.0)
Area has existed for 02:30:34
Interfaces in this area: 1 Active interfaces: 1
Passive interfaces: 0 Loopback interfaces: 0
No authentication available
SPF calculation has run 8 times
Last SPF ran for 0.000358s
Area ranges are
Number of LSAs: 3, checksum sum 0x147bf

 

AREA2

Routing Process 1 with ID 1.1.1.1 VRF default
Routing Process Instance Number 1
Stateful High Availability enabled
Graceful-restart is configured
Grace period: 60 state: Inactive
Last graceful restart exit status: None
Supports only single TOS(TOS0) routes
Supports opaque LSA
Administrative distance 110
Reference Bandwidth is 40000 Mbps
SPF throttling delay time of 200.000 msecs,
SPF throttling hold time of 1000.000 msecs,
SPF throttling maximum wait time of 5000.000 msecs
LSA throttling start time of 0.000 msecs,
LSA throttling hold interval of 5000.000 msecs,
LSA throttling maximum wait time of 5000.000 msecs
Minimum LSA arrival 1000.000 msec
LSA group pacing timer 10 secs
Maximum paths to destination 8
Number of external LSAs 0, checksum sum 0
Number of opaque AS LSAs 0, checksum sum 0
Number of areas is 1, 0 normal, 1 stub, 0 nssa
Number of active areas is 1, 0 normal, 1 stub, 0 nssa
Install discard route for summarized external routes.
Install discard route for summarized internal routes.
Area (0.0.0.2)
Area has existed for 02:31:45
Interfaces in this area: 1 Active interfaces: 1
Passive interfaces: 0 Loopback interfaces: 0
This area is a STUB area
Summarization is disabled
No authentication available
SPF calculation has run 11 times
Last SPF ran for 0.000456s
Area ranges are
Number of LSAs: 6, checksum sum 0x494e9
2- There's no LSA ID 0.0.0.0

Highlighted
Beginner

Re: N9K - OSPF Totally stubby area

Hi,
Please find the below output;
Hi,
ABR
----
show ip ospf
Routing Process 2 with ID 1.1.1.1 VRF default
Routing Process Instance Number 2
Stateful High Availability enabled
Graceful-restart is configured
Grace period: 60 state: Inactive
Last graceful restart exit status: None
Supports only single TOS(TOS0) routes
Supports opaque LSA
Administrative distance 110
Reference Bandwidth is 40000 Mbps
SPF throttling delay time of 200.000 msecs,
SPF throttling hold time of 1000.000 msecs,
SPF throttling maximum wait time of 5000.000 msecs
LSA throttling start time of 0.000 msecs,
LSA throttling hold interval of 5000.000 msecs,
LSA throttling maximum wait time of 5000.000 msecs
Minimum LSA arrival 1000.000 msec
LSA group pacing timer 10 secs
Maximum paths to destination 8
Number of external LSAs 0, checksum sum 0
Number of opaque AS LSAs 0, checksum sum 0
Number of areas is 1, 1 normal, 0 stub, 0 nssa
Number of active areas is 1, 1 normal, 0 stub, 0 nssa
Install discard route for summarized external routes.
Install discard route for summarized internal routes.
Area BACKBONE(0.0.0.0)
Area has existed for 02:47:28
Interfaces in this area: 1 Active interfaces: 1
Passive interfaces: 0 Loopback interfaces: 0
No authentication available
SPF calculation has run 8 times
Last SPF ran for 0.000358s
Area ranges are
Number of LSAs: 3, checksum sum 0x147bf

Routing Process 1 with ID 1.1.1.1 VRF default
Routing Process Instance Number 1
Stateful High Availability enabled
Graceful-restart is configured
Grace period: 60 state: Inactive
Last graceful restart exit status: None
Supports only single TOS(TOS0) routes
Supports opaque LSA
Administrative distance 110
Reference Bandwidth is 40000 Mbps
SPF throttling delay time of 200.000 msecs,
SPF throttling hold time of 1000.000 msecs,
SPF throttling maximum wait time of 5000.000 msecs
LSA throttling start time of 0.000 msecs,
LSA throttling hold interval of 5000.000 msecs,
LSA throttling maximum wait time of 5000.000 msecs
Minimum LSA arrival 1000.000 msec
LSA group pacing timer 10 secs
Maximum paths to destination 8
Number of external LSAs 0, checksum sum 0
Number of opaque AS LSAs 0, checksum sum 0
Number of areas is 1, 0 normal, 1 stub, 0 nssa
Number of active areas is 1, 0 normal, 1 stub, 0 nssa
Install discard route for summarized external routes.
Install discard route for summarized internal routes.
Area (0.0.0.2)
Area has existed for 02:48:29
Interfaces in this area: 1 Active interfaces: 1
Passive interfaces: 0 Loopback interfaces: 0
This area is a STUB area
Summarization is disabled
No authentication available
SPF calculation has run 11 times
Last SPF ran for 0.000456s
Area ranges are
Number of LSAs: 6, checksum sum 0x488ef

show ip ospf database summary 0.0.0.0
OSPF Router with ID (1.1.1.1) (Process ID 2 VRF default)

OSPF Router with ID (1.1.1.1) (Process ID 1 VRF default)

OSPF configuration
router ospf 1
area 0.0.0.2 stub no-summary
router ospf 2

interface Vlan200
ip ospf network broadcast
ip router ospf 1 area 0.0.0.2

interface te1/3
ip ospf network broadcast
ip router ospf 2 area 0.0.0.0

From Nexus side the command "show ip ospf border-routers" shows nothing! as well as the command "show ip ospf database summary"!!
Highlighted
Participant

Re: N9K - OSPF Totally stubby area

Hi,

Your Area 0 is in OSPF process 2, while your Stub Area 2 is in OSPF process 1. They are basically unrelated.

 

( To avoid duplicated discussion in this thread, Let's refer to @Cristian Matei 's reply to keep on going if you have further questions. I think his explanation is quite clear.)

View solution in original post

Highlighted
Collaborator

Re: N9K - OSPF Totally stubby area

Hi,

 

   Whenever you make an area stub, you stop sending in that area Type5/Type4 LSA's, or Type5/Type4/Type3. The scope of the default route is to provide connectivity from the stub area with now those missing prefixes; and this connectivity, to be loop free guaranteed by OSPF, has to happen through the only default transit area, area 0. For this reason, regardless of your configuration, only an ABR is able to unconditionally inject a Type3 LSA as default route into a stub or totally-stub area. To become an ABR,a router needs minimum one link in the UP/UP state (like a loopback) in area 0, se area 0 adjacency is not needed. Note that the ABR itself does NOT locally install a default route in RIB, it just advertises one out as LSA Type3.

   Which of the presented devices are actually ABR's, cause only those should inject the default route.


Regards,

Cristian Matei.

Highlighted
Beginner

Re: N9K - OSPF Totally stubby area

Hi,
The ABR in the presented topology is the Core switch (VSS Node).

Regards,
Highlighted
Collaborator

Re: N9K - OSPF Totally stubby area

Hi,

 

   Can you post the complete output of the following commands from the ABR: "show ip ospf" and "show ip ospf database summary 0.0.0.0" and "show run | sec router ospf". And from the Nexus the output of "show ip ospf border-routers" and "show ip ospf database summary 0.0.0.0".

 

Regards,

Cristian Matei.

Highlighted
Beginner

Re: N9K - OSPF Totally stubby area

Hi,
ABR
----
show ip ospf
Routing Process 2 with ID 1.1.1.1 VRF default
Routing Process Instance Number 2
Stateful High Availability enabled
Graceful-restart is configured
Grace period: 60 state: Inactive
Last graceful restart exit status: None
Supports only single TOS(TOS0) routes
Supports opaque LSA
Administrative distance 110
Reference Bandwidth is 40000 Mbps
SPF throttling delay time of 200.000 msecs,
SPF throttling hold time of 1000.000 msecs,
SPF throttling maximum wait time of 5000.000 msecs
LSA throttling start time of 0.000 msecs,
LSA throttling hold interval of 5000.000 msecs,
LSA throttling maximum wait time of 5000.000 msecs
Minimum LSA arrival 1000.000 msec
LSA group pacing timer 10 secs
Maximum paths to destination 8
Number of external LSAs 0, checksum sum 0
Number of opaque AS LSAs 0, checksum sum 0
Number of areas is 1, 1 normal, 0 stub, 0 nssa
Number of active areas is 1, 1 normal, 0 stub, 0 nssa
Install discard route for summarized external routes.
Install discard route for summarized internal routes.
Area BACKBONE(0.0.0.0)
Area has existed for 02:47:28
Interfaces in this area: 1 Active interfaces: 1
Passive interfaces: 0 Loopback interfaces: 0
No authentication available
SPF calculation has run 8 times
Last SPF ran for 0.000358s
Area ranges are
Number of LSAs: 3, checksum sum 0x147bf

Routing Process 1 with ID 1.1.1.1 VRF default
Routing Process Instance Number 1
Stateful High Availability enabled
Graceful-restart is configured
Grace period: 60 state: Inactive
Last graceful restart exit status: None
Supports only single TOS(TOS0) routes
Supports opaque LSA
Administrative distance 110
Reference Bandwidth is 40000 Mbps
SPF throttling delay time of 200.000 msecs,
SPF throttling hold time of 1000.000 msecs,
SPF throttling maximum wait time of 5000.000 msecs
LSA throttling start time of 0.000 msecs,
LSA throttling hold interval of 5000.000 msecs,
LSA throttling maximum wait time of 5000.000 msecs
Minimum LSA arrival 1000.000 msec
LSA group pacing timer 10 secs
Maximum paths to destination 8
Number of external LSAs 0, checksum sum 0
Number of opaque AS LSAs 0, checksum sum 0
Number of areas is 1, 0 normal, 1 stub, 0 nssa
Number of active areas is 1, 0 normal, 1 stub, 0 nssa
Install discard route for summarized external routes.
Install discard route for summarized internal routes.
Area (0.0.0.2)
Area has existed for 02:48:29
Interfaces in this area: 1 Active interfaces: 1
Passive interfaces: 0 Loopback interfaces: 0
This area is a STUB area
Summarization is disabled
No authentication available
SPF calculation has run 11 times
Last SPF ran for 0.000456s
Area ranges are
Number of LSAs: 6, checksum sum 0x488ef

show ip ospf database summary 0.0.0.0
OSPF Router with ID (1.1.1.1) (Process ID 2 VRF default)

OSPF Router with ID (1.1.1.1) (Process ID 1 VRF default)

OSPF configuration
router ospf 1
area 0.0.0.2 stub no-summary
router ospf 2

interface Vlan200
ip ospf network broadcast
ip router ospf 1 area 0.0.0.2

interface te1/3
ip ospf network broadcast
ip router ospf 2 area 0.0.0.0

From Nexus side the command "show ip ospf border-routers" shows nothing! as well as the command "show ip ospf database summary"!!

Highlighted
Collaborator

Re: N9K - OSPF Totally stubby area

Hi,

 

    On the VSS, you're running two OSPF processes, one runs in AREA 0, the other one in the stub area. You would have to remove OSPF PID 1 and reconfigure your stub settings in OSPF PID 2:

 

 

Routing Process 2 with ID 1.1.1.1 VRF default

Routing Process Instance Number 2

Number of active areas is 1, 1 normal, 0 stub, 0 nssa

Area BACKBONE(0.0.0.0)

Interfaces in this area: 1 Active interfaces: 1

 

Routing Process 1 with ID 1.1.1.1 VRF default

Routing Process Instance Number 1

Number of active areas is 1, 0 normal, 1 stub, 0 nssa

Interfaces in this area: 1 Active interfaces: 1

Area (0.0.0.2)

This area is a STUB area

 

Also, if the Nexuses are not ABR's, there is no need for the "no-summary" keyword when you define the stub area; this keyword does not mean any additional flags that would need to be matched for OSPF adjacency to come up; this keyword just tells the ABR to also filter Type3 LSA's in that area.

 

 

Regards,

Cristian Matei.

View solution in original post

CreatePlease to create content
Content for Community-Ad