cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

1078
Views
0
Helpful
0
Replies
Highlighted

Native Vlan and HSRP and sub interface

Hello All,

I have following topology, Edge routers and 3750 switch Stack with Mamgt Vlan :-

Test.JPG

Currenlty all the devices are runnign with L2 vlan on all coonected ports to ASAs and Routers with vlan Id 10. Switch has a vlan intetface vlan 20 with subnet 192.168.1.1/24 that is a kind of out of band, where as Vlan 10 is used for Producation data flow between Edge routers and FWs.

Current config on Edge routers:-

Router1:-

interface FastEthernet0/1
description Connect to Edge_SW Gi2/0/1
ip address 10.10.10.3 255.255.255.0
duplex auto
speed 100
ntp disable
standby 1 ip 10.10.10.1
standby 1 priority 110
standby 1 preempt

Router2:-

interface FastEthernet0/1
description Connect to Edge_SW Gi1/0/1
ip address 10.10.10.13 255.255.255.0
no ip redirects
duplex auto
speed auto
ntp disable
standby 1 ip 10.10.10.1
standby 1 priority 90
standby 1 preempt

Switch (3750 Stack):-

interface GigabitEthernet1/0/1
description  Router1- FE0/1
switchport access vlan 10
switchport mode access
spanning-tree portfast

interface GigabitEthernet2/0/1
description Router2 - FE0/1
switchport access vlan 10
switchport mode access
spanning-tree portfast

Proposed Config :-

Switch:-

interface GigabitEthernet1/0/1
description Router1 - FE0/1
switchport trunk encapsulation dot1q
switchport mode trunk
  switchport trunk native vlan 80
switchport trunk allow vlan  254
no shut

interface GigabitEthernet2/0/1
description Router2 - FE0/1
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk native vlan 80
switchport trunk allow vlan 254
no shut

Router01:-

interface FastEthernet0/1
description Connect to Edge_SW Gi1/0/1
ip address 10.10.10.13 255.255.255.0
no ip redirects
duplex auto
speed auto
ntp disable
standby 1 ip 10.10.10.1
standby 1 priority 90
standby 1 preempt
!
!
interface FastEthernet0/0.254
description **Mgmt Link**
encapsulation dot1Q 254
ip address 192.168.1.50 255.255.255.0
no ip redirects
no sh


Router02:-

interface FastEthernet0/1
description Connect to Edge_SW  Gi2/0/1
ip address 10.10.10.3 255.255.255.0
duplex auto
speed 100
ntp disable
standby 1 ip 10.10.10.1
standby 1 priority 110
standby 1 preempt
!
!
interface FastEthernet0/0.254
description **Mgmt Link**
encapsulation dot1Q 254
ip address 192.168.1.51 255.255.255.0
no ip redirects
no sh

I am confused or the switch port config should be like

switchport trunk native vlan 254

switchport trunk allow vlan 80,254

After going through following link:-

http://rednectar.net/2012/03/11/the-access-vlan-is-dead-long-live-the-native-vlan/

Thansk

Jagdev

Everyone's tags (6)
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards