cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
2026
Views
0
Helpful
4
Replies
rhamietron
Beginner

Native vlan issues

Please I dont seems to see what the issue is here.

Find below the output from the sh run

SoneraCloud#sh interfaces gigabitEthernet 0/1 switchport

Name: Gi0/1

Switchport: Enabled

Administrative Mode: static access

Operational Mode: static access

Administrative Trunking Encapsulation: negotiate

Operational Trunking Encapsulation: native

Negotiation of Trunking: Off

Access Mode VLAN: 301 (VLAN0301)

Trunking Native Mode VLAN: 1 (default)

Administrative Native VLAN tagging: enabled

Voice VLAN: none

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Administrative private-vlan trunk native VLAN: none

Administrative private-vlan trunk Native VLAN tagging: enabled

Administrative private-vlan trunk encapsulation: dot1q

Administrative private-vlan trunk normal VLANs: none

Administrative private-vlan trunk private VLANs: none

Operational private-vlan: none

Trunking VLANs Enabled: ALL

Pruning VLANs Enabled: 2-1001

Capture Mode Disabled

Capture VLANs Allowed: ALL

--More--

01:49:58: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on GigabitEthernet0/1 (301), with Valimo FastEthernet0        .

Protected: false

Unknown unicast blocked: disabled

Unknown multicast blocked: disabled

Appliance trust: none

Valimo#sh int fa0/1 switchport

Name: Fa0/1

Switchport: Enabled

Administrative mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: Disabled

Access Mode VLAN: 0 ((Inactive))

Trunking Native Mode VLAN: 451 (VLAN0451)

Trunking VLANs Enabled: 1,197,451,1002-1005

Trunking VLANs Active: 1,451

Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0

Override vlan tag priority: FALSE

Voice VLAN: none

Appliance trust: none

Self Loopback: No

Look forward to your help.

Regards

Raheem

4 REPLIES 4
Kyle McKay
Beginner

When comparing the two outputs it is clear that the native VLAN is different on each of the ports.

On Valimo it is 451 and on SoneraCloud it is 1 (default).

CDP identifies this through its message exchange and provides the log message that you have pasted.

You will need to correct this configuration on either side in order to make them consistent otherwise you will continually see these log messages.

Here is the command to change the native vlan for your reference:

switchport trunk native vlan x     (where x i the VLAN you choose)

Hi,

on Sonera Cloud is :

Access Mode VLAN: 301 (VLAN0301)

Mind the fact that you have static access on one side and trunking on the other side.

Regards

Yes it is.

Thanks for pointing that outabout the static access.

I have got it fixed. What I did was to have simlar configuration as that of the fa0/1 interface on a gi0/2 interface.

Immideiately I did this, it all went ok and the QinQ tunnelling config allows traffic from the non tagged access port.

But could you tell me the implication of the static access for future situation.

Regards

I have used switchport native vlan x command earlier before posting.

But I guess i chose a wrong vlan ID