cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
190
Views
0
Helpful
4
Replies
Beginner

NCS520 dropping MPLS packets

I am running a transparency test for NCS 520. Software release 16.11.01, licence metroaccess.

 

UNI port gi 0/0/3 has an Ethernet service with default encapsulation and NNI port gi-0/0/2 pushes a VLAN tag to frames received from the UNI port.

 

I have used a Netrounds tester to test transparency of multiple protocols. Protocols I expect to be transparent are ok except for MPLS (ethertype 0x8847), which is not forwarded by the NCS520.

 

Am I missing something from the configuration, which would enable forwarding of MPLS packets?

 

bridge-domain 102

!

interface GigabitEthernet0/0/2
description NNI to NCS540
no ip address
load-interval 30
media-type sfp
negotiation auto
service instance 102 ethernet
encapsulation dot1q 102
rewrite ingress tag pop 1 symmetric
l2protocol forward cdp stp vtp pagp dot1x lldp lacp udld loam esmc elmi ptppd R4 R5 R6 R8 R9 RA RB RC RD RF mmrp mvrp
bridge-domain 102

!

interface GigabitEthernet0/0/3
description UNI
no ip address
load-interval 30
media-type sfp
negotiation auto
service instance 102 ethernet
encapsulation default
l2protocol forward cdp stp vtp pagp dot1x lldp lacp udld loam esmc elmi ptppd R4 R5 R6 R8 R9 RA RB RC RD RF mmrp mvrp
bridge-domain 102
!

 

Regards

Tapio

4 REPLIES 4
Hall of Fame Expert

Re: NCS520 dropping MPLS packets

Hello Tapio,

according to the Restrictions section in configuration guide for your IOS release the only ethertype allowed is 0x8100.

see

https://www.cisco.com/c/en/us/td/docs/routers/ncs5xx/ncs520/configuration/guide/CE/16-11-1/b-ce-xe-16-11-1-ncs520/b-ce-xe-16-11-1-ncs520_chapter_010.html#restrictions-evc

 

Try to repeat the tests using frames with an external (first ) ethertype of 0x8100 vlan-id=100 and then followed by the MPLS header with ethertype 0x8847.

these frames should pass and this is the aspect of MPLS frames in Vlan 100 (the 802.1Q header is the first followed by MPLS header).

 

Hope to help

Giuseppe

 

Beginner

Re: NCS520 dropping MPLS packets

Hi Giuseppe

Thank you for the suggestion.

Looks like it is not the problem however. I am able to switch IP packets with and without a VLAN tag through the 520, but MPLS packets are dropped also when they are VLAN tagged.

 

I did get a confirmation from Cisco that they are aware of the problem and they are talking with the ASIC vendor. No solution yet.

 

Regards

Tapio

Hall of Fame Expert

Re: NCS520 dropping MPLS packets

Hello Tapio,

I do agree that if MPLS frames with an external 802.1Q tag vlan 100 are blocked this is a serius issue.

I guess you have opened a ticket with Cisco TAC for this.

The restrictions section provides also limitations on ethertype internal of frames with double 802.1Q tag.

The ASIC firmware needs to be updated to allow this kind of frames to pass.

You may rise a feature request and likely someone else has already done this.

 

Hope to help

Giuseppe

 

Beginner

Re: NCS520 dropping MPLS packets

Hi Giuseppe

 

I have opened a TAC case. I think this is a bug, but has not been confirmed by Cisco yet.

 

Regards

Tapio

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards