09-15-2020 08:20 PM
en
conf t
hostname ESTswitch
enable secret ****
ip default-gateway 172.22.1.1
vlan 90
name WIFI
vlan 99
name LAN
vlan 201
name SERVER
exit
int range g0/1-4
switchport mode access
switchport access vlan 201
no shut
int range g0/5-8
switchport mode access
switchport access vlan 99
no shut
int range g0/9-12
switchport mode access
switchport access vlan 90
no shut
int g0/48
switchport trunk encaps dot1q
switchport mode trunk
switchport trunk allowed vlan 1,90,99,201
no shut
int vlan 99
ip add 172.22.99.254 255.255.255.0
exit
i'm new with cisco switch and im using catalyst 3560 switch.
above is my config.
1. my goal is that the interfaces will be able to ping to the gateway. but seems cannot. need to know what's wrong with my config.
Thank you
09-15-2020 08:29 PM
no shut
int vlan 99
ip add 172.22.99.254 255.255.255.0
ip default-gateway 172.22.1.1
The gateway (172.22.1.1) needs to be in the same IP subnet as the interface vlan 99 IP.)
So, if vlan 99 ip address is 172.22.99.254, change the ip default-gateway address to look like this:
ip default-gateway 172.22.99.1
and test
HTH
09-16-2020 02:59 AM
no ip default-gateway 172.22.1.1
ip default-gateway 172.22.99.1 <-- change this as per the gateway
i have suggesgted based on the below config only -
int vlan 99
ip add 172.22.99.254 255.255.255.0
exit
09-16-2020 08:30 AM
There is much about this environment that we do not know and which might impact the advice that we would give. But here are things that we do know:
- the switch has one configured vlan interface which is vlan 99. So this is the management interface/management subnet for the switch.
- the subnet configured on vlan 99 is 172.22.99.254 255.255.255.0
- the configured default gateway is 172.22.1.1
So there is a mismatch between the management subnet and the default gateway. One or the other needs to be changed so that they will match. We do not know which one is correct. So we can not tell you at this point which one needs to change.
I will also note that we do not know anything about what this switch will connect to. But we do see an interface configured as a trunk and assume that this is the connection to the router. So does the router have that interface configured for dot1q trunking? And does the router have a subinterface configured for vlan 99, with an IP address that matches the subnet for vlan 99?
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide