cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

768
Views
3
Helpful
3
Replies
Highlighted
Beginner

Needing Assistance with Network Scheme involving 1 router and 2 switches.

I have an issue with my current network that I am working on.  I am  studying to achieve my CCNA and have ran into a problem.  In my network  scheme, I have 1 1841 Cisco Router that is directed connected to two  2950 Cisco Switches.  These switches are directly connected to hosts. 

My  problem is I cannot get the hosts on one end to connect to the hosts on  the other end of the network.  I have attempted to create a VLAN  structure but have ran into an issue here because my router does not  accept VTP information so the switches cannot pass VTP info. 

Can someone give me any insight as to what I am doing incorrect or what path I need to take? 

I have also attached my .PKT file from Packet Tracer Version 5.1

Everyone's tags (3)
2 ACCEPTED SOLUTIONS

Accepted Solutions
Engager

Re: Needing Assistance with Network Scheme involving 1 router an

Hello Marc,

VTP information can not be passed through the router. The requirement for this to work is a layer 2. i.e. your switches need to be connected to each other. It seems like you're trying to route between VLAN's and also do VTP at the same time.

I'll try to go through this in a easy way so you can understand what is required. This is bare minimal config for you to get end to end connectivity, so please don't mind if I take any existing configuration out. (Attached will be my version of the PKT file so you can see) There are two versions to this.

  1. Without VTP (Just router that is routing between subnets)
  2. With VTP - everything will need to change in terms of the topology

We'll start with option 1 - on R1. Your overall config seems fine, however I do want to mention that in a 'router on a stick' scenario you don't normally assign an IP to the physical interfaces themselves, you only assign active IP addresses on the Sub interfaces:

e.g. instead of this:

interface FastEthernet0/1

ip address 192.168.30.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1.2

encapsulation dot1Q 2

ip address 192.168.20.5 255.255.255.0

you do not need the address on fa0/1 you can just specify the sub interfaces address as you have done correctly for int Fa0/1.2

Since all of your PC's are in VLAN 2 we'll just have this:

interface FastEthernet0/1

no ip address

duplex auto

speed auto

!

interface FastEthernet0/1.2

encapsulation dot1Q 2

ip address 192.168.20.5 255.255.255.0

Subsequent to this I have removed the VLAN interfaces on the switch as they aren't serving any purpose interms of routing. However you can assign the SVI's back if you wish.

I also did the same for vlan 3 (your servers)

I noticed you are running EIGRP? You only have one router here so EIGRP isn't required. Your router knows about all subnets since they are connected subnets. And it will route between subnets if necessary.

Your default gateway was also misconfigured on the finance and web servers.

I have split this out so that all Servers are on VLAN 3

All PC's are in VLAN 2

All clients and servers have the default gateway of the local router's interface address. And the router is doing the routing between subnets.

No VTP is operational.

If you would like me to go through the VTP side of it, please tell me which PC's and servers should be in which VLAN. And only then I will be able to try and show you the difference between these.

Hope this helps

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

View solution in original post

VIP Advisor

Re: Needing Assistance with Network Scheme involving 1 router an

Hello

The can  use the router for the communication between the switches and hosts.

router

#####

int fa0/0

no shut

int fa0/0.10

Description Vlan 10

encap dot1.q 10

ip address 10.10.10.254 255.255.255.0

int fa0/0.20

Descritop  vlan 20

encap dot1.q 10

ip address 20.20.20.254 255.255.255.0

Switch1:

conf  t

vlan10,20

exit

int vlan 10

ip address 10.10.10.1 255.255.255.0

int x/x

switchport trunk encp dot1

switch mode trunk

no shut

int fax/x

description access port for host

switchport-access vlan 10

switchport host

no shut

ip default-gateway 10.10.10.254

Switch2:

conf  t

vlan10,20

exit

int vlan 20

ip address 20.20.20.1 255.255.255.0

int x/x

switchporttrunk encp dot1

switch mode trunk

no shut

int fax/x

description access port for host

switchport-access vlan 20

switchporthost

no shut

ip default-gateway 20.20.20.254

Please don't forget to rate any posts that have been helpful.

Thanks.



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future

View solution in original post

3 REPLIES 3
Engager

Re: Needing Assistance with Network Scheme involving 1 router an

Hello Marc,

VTP information can not be passed through the router. The requirement for this to work is a layer 2. i.e. your switches need to be connected to each other. It seems like you're trying to route between VLAN's and also do VTP at the same time.

I'll try to go through this in a easy way so you can understand what is required. This is bare minimal config for you to get end to end connectivity, so please don't mind if I take any existing configuration out. (Attached will be my version of the PKT file so you can see) There are two versions to this.

  1. Without VTP (Just router that is routing between subnets)
  2. With VTP - everything will need to change in terms of the topology

We'll start with option 1 - on R1. Your overall config seems fine, however I do want to mention that in a 'router on a stick' scenario you don't normally assign an IP to the physical interfaces themselves, you only assign active IP addresses on the Sub interfaces:

e.g. instead of this:

interface FastEthernet0/1

ip address 192.168.30.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1.2

encapsulation dot1Q 2

ip address 192.168.20.5 255.255.255.0

you do not need the address on fa0/1 you can just specify the sub interfaces address as you have done correctly for int Fa0/1.2

Since all of your PC's are in VLAN 2 we'll just have this:

interface FastEthernet0/1

no ip address

duplex auto

speed auto

!

interface FastEthernet0/1.2

encapsulation dot1Q 2

ip address 192.168.20.5 255.255.255.0

Subsequent to this I have removed the VLAN interfaces on the switch as they aren't serving any purpose interms of routing. However you can assign the SVI's back if you wish.

I also did the same for vlan 3 (your servers)

I noticed you are running EIGRP? You only have one router here so EIGRP isn't required. Your router knows about all subnets since they are connected subnets. And it will route between subnets if necessary.

Your default gateway was also misconfigured on the finance and web servers.

I have split this out so that all Servers are on VLAN 3

All PC's are in VLAN 2

All clients and servers have the default gateway of the local router's interface address. And the router is doing the routing between subnets.

No VTP is operational.

If you would like me to go through the VTP side of it, please tell me which PC's and servers should be in which VLAN. And only then I will be able to try and show you the difference between these.

Hope this helps

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

View solution in original post

Engager

Re: Needing Assistance with Network Scheme involving 1 router an

Just thought I should do the VTP version too just so we can see the difference.

Here is the topology change that I was talking about in my previous post. Note that to get VTP to work we have to connect the switches together.

VTP packets are sent in either Inter-Switch Link (ISL) frames or in IEEE 802.1Q (dot1q) frames. Therefore the router could not 'carry' this for us like switches do. Its not like the role that the 'transparent mode' that switches can be.

SW1#show vtp status

VTP Version                     : 2

Configuration Revision          : 0

Maximum VLANs supported locally : 255

Number of existing VLANs        : 7

VTP Operating Mode              : Server

VTP Domain Name                 : lungi

VTP Pruning Mode                : Disabled

VTP V2 Mode                     : Disabled

VTP Traps Generation            : Disabled

MD5 digest                      : 0x9A 0xE3 0x0A 0xC6 0x2B 0xB7 0x85 0x18

Configuration last modified by 192.168.20.4 at 3-1-93 02:29:35

Local updater ID is 0.0.0.0 (no valid interface found)

Switch#show vtp status

VTP Version                     : 2

Configuration Revision          : 0

Maximum VLANs supported locally : 255

Number of existing VLANs        : 7

VTP Operating Mode              : Client

VTP Domain Name                 : lungi

VTP Pruning Mode                : Disabled

VTP V2 Mode                     : Disabled

VTP Traps Generation            : Disabled

MD5 digest                      : 0x9A 0xE3 0x0A 0xC6 0x2B 0xB7 0x85 0x18

Configuration last modified by 192.168.20.4 at 3-1-93 02:29:35

Router configuration:

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.2

encapsulation dot1Q 2

ip address 192.168.20.5 255.255.255.0

!

interface FastEthernet0/0.3

encapsulation dot1Q 3

ip address 172.16.10.5 255.255.255.0

The switches are not doing any routing and layer 3 is serving no purpose. hence I have left them out again. But you can include this in the configuration if you wish for things like telnet/SSH/TFTP access etc...

Example on how to configure VTP and more info here:

http://www.cisco.com/en/US/tech/tk389/tk689/technologies_configuration_example09186a0080890607.shtml

http://www.cisco.com/en/US/tech/tk389/tk689/technologies_tech_note09186a0080094c52.shtml

Hope this helps

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.
VIP Advisor

Re: Needing Assistance with Network Scheme involving 1 router an

Hello

The can  use the router for the communication between the switches and hosts.

router

#####

int fa0/0

no shut

int fa0/0.10

Description Vlan 10

encap dot1.q 10

ip address 10.10.10.254 255.255.255.0

int fa0/0.20

Descritop  vlan 20

encap dot1.q 10

ip address 20.20.20.254 255.255.255.0

Switch1:

conf  t

vlan10,20

exit

int vlan 10

ip address 10.10.10.1 255.255.255.0

int x/x

switchport trunk encp dot1

switch mode trunk

no shut

int fax/x

description access port for host

switchport-access vlan 10

switchport host

no shut

ip default-gateway 10.10.10.254

Switch2:

conf  t

vlan10,20

exit

int vlan 20

ip address 20.20.20.1 255.255.255.0

int x/x

switchporttrunk encp dot1

switch mode trunk

no shut

int fax/x

description access port for host

switchport-access vlan 20

switchporthost

no shut

ip default-gateway 20.20.20.254

Please don't forget to rate any posts that have been helpful.

Thanks.



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future

View solution in original post

CreatePlease to create content
Content for Community-Ad