03-29-2010 08:53 PM - edited 03-06-2019 10:22 AM
Hi,
I have been attempting to configure QoS on the nexus 4k blade switch to set the CoS value of incoming traffic off the internal 10G interfaces, but have come across an error on which I can find no information on. Any advice would be appreciated
Configuration
ip access-list Mark-CoS-0
ip access-list Mark-CoS-1
ip access-list Mark-CoS-6
ip access-list Mark-CoS-2
ip access-list Mark-CoS-4
10 remark *** ESX vMotion ***
ip access-list Mark-CoS-5
10 remark *** NFS Data Store - NetApp ***
30 remark *** iSCSI Data Store - NetApp ***
!
class-map type qos match-all Classify-Gold
match access-group name Mark-CoS-6
class-map type qos match-all Classify-Bronze
match access-group name Mark-CoS-2
class-map type qos match-all Classify-Silver
match access-group name Mark-CoS-4
class-map type qos match-all Classify-Platinum
match access-group name Mark-CoS-5
class-map type qos match-all Classify-Scavenger
match access-group name Mark-CoS-1
class-map type qos match-all Classify-Best-Effort
match access-group name Mark-CoS-0
!
policy-map type qos Global-Classify-CoS
class Classify-Platinum
set cos 5
class Classify-Gold
set cos 6
class Classify-Silver
set cos 4
class Classify-Bronze
set cos 2
class Classify-Scavenger
set cos 1
class Classify-Best-Effort
set cos 0
!
interface Ethernet1/1
service-policy type qos input Global-Classify-CoS
Issue
When I attempt to add to any of the ACLs defined for CoS I get the following error message:
"ERROR: lou allocation failure"
This only occurs when I attempt to specify a port be it TCP, UDP, ICMP. For example when I try to add the following "permit tcp any any eq 2049"
If I drop the portion "eq 2049" it is accepted, but doesn't really help define the QoS I'm tring to do on a converged network.
Also if I remove the service policy from the interface and then try, it is accepted, but adding the policy back on the 10G interface produces a similiar message - ERROR: Module 1 returned status "lou allocation failure"
The switch is running the latest version of NX-OS so I'm a little stumped on what I have done/doing wrong
Regards
Steve
08-20-2020 08:13 AM
How did you resolve this?
08-20-2020 10:11 AM
(check if that can be applicable to your platform too)
M.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide