cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1810
Views
0
Helpful
2
Replies

Nexus 5k VRF route leaking

parsonsproject1
Level 1
Level 1

I'm looking to leak routes between the default route table and various other VRFs on Nexus 5548. We are on 7.0 code which should support this, but I'm not finding any official configuration guides relating to route-leaking on the nexus 5ks.

Whether this is done via route-target's and bgp or otherwise (I do see an 'export' and 'import' option under vrf context>address-family ipv4 unicast which looked promising, though my playing with that has not been successful) I don't care too much about, as long as it works. Does anybody have some documentation they could point me towards?

Thanks!

2 Replies 2

parsonsproject1
Level 1
Level 1

I created a TAC case and they pointed towards documentation of mpls route leaking, and other doc which referenced ip vrf commands which didn't follow the same syntax as N5K. But they stated you can distribute from default to non-default, but not the other way around. 

 

I never could get things to work with the default vrf, so I ditched the default vrf for an 'external' vrf, and got route leaking to work using the meat and potatoes below:

 

vrf context app
  address-family ipv4 unicast
    route-target import 65000:777
    route-target export 65000:114

vrf context dmz
  address-family ipv4 unicast
    route-target import 65000:777
    route-target export 65000:110

vrf context external
  ip route 0.0.0.0/0 172.17.21.1
  address-family ipv4 unicast
    route-target import 65000:110
    route-target import 65000:114
    route-target export 65000:777

 

interface Vlan114
  no shutdown
  vrf member app
  ip address 172.17.14.2/24
  hsrp 114
    preempt
    ip 172.17.14.1
    track 1

interface Vlan110
  no shutdown
  vrf member dmz
  ip address 172.17.10.2/24
  hsrp 110
    preempt
    ip 172.17.10.1
    track 1

interface Vlan120
  no shutdown
  vrf member external
  no ip redirects
  ip address 172.17.20.2/24
  hsrp 120
    preempt
    ip 172.17.20.1
    track 1


ip prefix-list test seq 5 permit 0.0.0.0/0
route-map allow-any-route-map permit 10
  match ip address prefix-list test

 

router bgp 65000
  vrf app
    address-family ipv4 unicast
      network 172.17.14.0/24
      redistribute direct route-map allow-any-route-map
  vrf dmz
    address-family ipv4 unicast
      network 172.17.10.0/24
      redistribute direct route-map allow-any-route-map
  vrf external
    address-family ipv4 unicast
      network 0.0.0.0/0
      network 172.17.20.0/24
      redistribute direct route-map allow-any-route-map
      redistribute static route-map allow-any-route-map

Thanks, very helpful, it works.

Review Cisco Networking for a $25 gift card