02-20-2024 02:34 AM
Hello Guys,
I hope y'all are doing great. So basically, I'm trying to ping the SVI for VLAN 10 IP or 7.7.1.94 from the Linux VM or the other way around but it's timing out even though the 9K is able to dynamically learn the MAC address of 7.7.1.65 just fine even after I `clear mac address-table`.
The hypervisor is a VMWare ESXi.
Here is a high level overview of the topology,
VM ([Linux] 7.7.1.65/27) <---> VM ([Nexus 9K] 7.7.1.94/27) <---> Physical NIC
Nexus 9K configuration below
```
!Command: show running-config
!Running configuration last done at: Tue Feb 20 10:22:23 2024
!Time: Tue Feb 20 10:22:31 2024
version 10.1(1) Bios:version
vdc switch id 1
limit-resource vlan minimum 16 maximum 4094
limit-resource vrf minimum 2 maximum 4096
limit-resource port-channel minimum 0 maximum 511
limit-resource m4route-mem minimum 58 maximum 58
limit-resource m6route-mem minimum 8 maximum 8
feature interface-vlan
mac address-table aging-time 120
username admin password 5 $5$DAPIFN$qskJ3acZMmRtMc0nDywE/EnvoE9lHXlDHoamYhvZfX8
role network-admin
ip domain-lookup
copp profile strict
snmp-server user admin network-admin auth md5 0xc8f962dbe98d83204064426fc062ce5b
priv aes-128 0xc8f962dbe98d83204064426fc062ce5b localizedkey
rmon event 1 log trap public description FATAL(1) owner PMON@FATAL
rmon event 2 log trap public description CRITICAL(2) owner PMON@CRITICAL
rmon event 3 log trap public description ERROR(3) owner PMON@ERROR
rmon event 4 log trap public description WARNING(4) owner PMON@WARNING
rmon event 5 log trap public description INFORMATION(5) owner PMON@INFO
vlan 1,10-11
vlan 10
name PRE-Admin
vlan 11
name PRE-Aux
vrf context management
interface Vlan1
interface Vlan10
no shutdown
no ip redirects
ip address 7.7.1.94/27
interface Vlan11
no shutdown
no ip redirects
ip address 7.7.2.94/27
interface Ethernet1/1
switchport
switchport access vlan 10
no shutdown
interface Ethernet1/2
switchport
switchport access vlan 11
no shutdown
interface Ethernet1/3
interface Ethernet1/4
interface Ethernet1/5
interface Ethernet1/6
interface Ethernet1/7
interface Ethernet1/8
interface Ethernet1/9
interface Ethernet1/10
interface Ethernet1/11
interface Ethernet1/12
interface Ethernet1/13
interface Ethernet1/14
interface Ethernet1/15
interface Ethernet1/16
interface Ethernet1/17
interface Ethernet1/18
interface Ethernet1/19
interface Ethernet1/20
interface Ethernet1/21
interface Ethernet1/22
interface Ethernet1/23
interface Ethernet1/24
interface Ethernet1/25
interface Ethernet1/26
interface Ethernet1/27
interface Ethernet1/28
interface Ethernet1/29
interface Ethernet1/30
interface Ethernet1/31
interface Ethernet1/32
interface Ethernet1/33
interface Ethernet1/34
interface Ethernet1/35
interface Ethernet1/36
interface Ethernet1/37
interface Ethernet1/38
interface Ethernet1/39
interface Ethernet1/40
interface Ethernet1/41
interface Ethernet1/42
interface Ethernet1/43
interface Ethernet1/44
interface Ethernet1/45
interface Ethernet1/46
interface Ethernet1/47
interface Ethernet1/48
interface Ethernet1/49
interface Ethernet1/50
interface Ethernet1/51
interface Ethernet1/52
interface Ethernet1/53
interface Ethernet1/54
interface Ethernet1/55
interface Ethernet1/56
interface Ethernet1/57
interface Ethernet1/58
interface Ethernet1/59
interface Ethernet1/60
interface Ethernet1/61
interface Ethernet1/62
interface Ethernet1/63
interface Ethernet1/64
interface mgmt0
vrf member management
icam monitor scale
line console
line vty
```
Any help would be truly appreciated,
Thanks,
02-20-2024 01:03 PM
Does removing the "no ip redirects" from the SVI make a difference?
HTH
02-20-2024 01:42 PM
Hi Reza,
Yes, it's the same behavior both ways. I actually configured the "no ip redirect" myself, after trying to figure out what's happening with this 9k since it's one of our production Nexus's. Please find output below,
interface Vlan10
no shutdown
ip address 7.7.1.94/27
interface Vlan11
no shutdown
ip address 7.7.2.94/27
interface Ethernet1/1
switchport
switch(config-if)# ping 7.7.1.65
PING 7.7.1.65 (7.7.1.65): 56 data bytes
Request 0 timed out
Request 1 timed out
Request 2 timed out
Request 3 timed out
Request 4 timed out
--- 7.7.1.65 ping statistics ---
5 packets transmitted, 0 packets received, 100.00% packet loss
switch(config-if)#
02-20-2024 01:55 PM
Thank you for the output that I requested. I am especially interested in the output of the arp table which shows that the 9K and the VM are successfully communicating. So I think that indicates that interfaces, vlans, etc are configured correctly. I do not see anything in the 9K that would impact ping and wonder if there is something on the VM that is causing this?
02-20-2024 02:06 PM
Hi Rick,
As I mentioned previously to @Reza Sharifi, I deployed a test router (VyOS) to make sure it is not related to an issue in the guest VM or the hypervisor itself, and it worked perfectly fine. So It's only the 9K that isn't able to ping it for some reason
02-20-2024 02:14 PM
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide