I have 2 Nexus 9K to be bundled together using vPC.
First Nexus:
vrf context management
ip route 0.0.0.0/0 172.25.100.1
vpc domain 1
peer-keepalive destination 172.25.100.2
interface port-channel1 ----<<< 2x10G connected to other nexus
switchport mode trunk
spanning-tree port type network
vpc peer-link
interface mgmt0 -----<<< Connected to other nexus
vrf member management
ip address 172.25.100.3/24
Second Nexus:
vrf context management
ip route 0.0.0.0/0 172.25.100.1
vpc domain 1
role priority 1000
peer-keepalive destination 172.25.100.3
interface port-channel1 ----<<< 2x10G connected to other nexus
switchport mode trunk
spanning-tree port type network
vpc peer-link
interface mgmt0 -----<<< Connected to other nexus
vrf member management
ip address 172.25.100.2/24
line console
The show vpc and vpc keepalive all shows fine. Now with the access level I have 2 4500, I have configured them as VSS which makes them 1 logically. I want to connect them with the nexus, I have configured normal LACP-Portchannel on 4500 (2 ports total) and connected the first cable to first nexus while the second cable is connected to second nexus. Below is nexus config
First Nexus:
interface port-channel10
description to Core
switchport mode trunk
interface Ethernet1/46
description to Core1
switchport mode trunk
channel-group 10 mode active
Second Nexus:
interface port-channel10
description to 4500
switchport mode trunk
interface Ethernet1/46
description to Core2
switchport mode trunk
channel-group 10 mode active
I created SVI on 4500 with VLAN1 and also on SVI on Nexus. Tried to ping and it works fine both ways and I believe all is working as expected, below is show vpc information.
NK9-2# sh vpc
Legend:
(*) - local vPC is down, forwarding via vPC peer-link
vPC domain id : 1
Peer status : peer adjacency formed ok
vPC keep-alive status : peer is alive
Configuration consistency status : success
Per-vlan consistency status : success
Type-2 consistency status : failed
Type-2 inconsistency reason : SVI type-2 configuration incompatible
vPC role : secondary
Number of vPCs configured : 0
Peer Gateway : Disabled
Dual-active excluded VLANs : -
Graceful Consistency Check : Enabled
Auto-recovery status : Disabled
Delay-restore status : Timer is off.(timeout = 30s)
Delay-restore SVI status : Timer is off.(timeout = 10s)
vPC Peer-link status
---------------------------------------------------------------------
id Port Status Active vlans
-- ---- ------ --------------------------------------------------
1 Po1 up 1
NK9-2# sh vpc peer-keepalive
vPC keep-alive status : peer is alive
--Peer is alive for : (5342) seconds, (785) msec
--Send status : Success
--Last send at : 2016.06.29 16:18:00 482 ms
--Sent on interface : mgmt0
--Receive status : Success
--Last receive at : 2016.06.29 16:18:00 482 ms
--Received on interface : mgmt0
--Last update from peer : (0) seconds, (36) msec
vPC Keep-alive parameters
--Destination : 172.25.100.2
--Keepalive interval : 1000 msec
--Keepalive timeout : 5 seconds
--Keepalive hold timeout : 3 seconds
--Keepalive vrf : management
--Keepalive udp port : 3200
--Keepalive tos : 192
My question here is to confirm if i have setup the things properly or I need to connect the 4500 in a different way . I understand that it shows Type-2 consistency status failed and thats because of config mismatch and I am working on it.