cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
1936
Views
0
Helpful
2
Replies
Adis Cato
Beginner

Nexus OSPF neighbors stuck in EXSTART/DROTHER

Hi there,

I have a strange issue with OSPF between two NON-directly connected Nexus switches:

 

N7k-1# sh ip ospf neighbors 172.22.22.204
OSPF Process ID 100 VRF default
Total number of neighbors: 38
Neighbor ID Pri State Up Time Address Interface
172.22.22.204 1 EXSTART/DROTHER 00:23:01 10.2.0.4 Vlan10

 

N7k-4# sh ip ospf neighbors 172.22.22.201
OSPF Process ID 100 VRF default
Total number of neighbors: 26
Neighbor ID Pri State Up Time Address Interface
172.22.22.201 15 EXSTART/DR 00:24:09 10.2.0.1 Vlan10

 

N7k-4# sh run interface vlan 10

 

interface Vlan10
description ospf_transit
no shutdown
no ip redirects
ip address 10.2.0.4/24

 

router ospf 100
router-id 172.22.22.204

 

 

N7k-1# sh run int vlan 10

 

interface Vlan10
description ospf_transit
no shutdown
no ip redirects
ip address 10.2.0.1/24
ip ospf priority 15

 

router ospf 100
router-id 172.22.22.201

 

And yes, I've checked it is not MTU issue! This is the output of the "sh ip ospf event-history adjacency" command executed on the N7k-4 switch :

 


2019 May 17 15:33:19.396439 ospf 100 [6681]: : Sending DBD to 10.2.0.1 on Vlan10
2019 May 17 15:33:19.396294 ospf 100 [6681]: : 10.2.0.1 also master,negotiation incomplete
2019 May 17 15:33:19.396290 ospf 100 [6681]: : seqnr 0x62475166, dbdbits 0x7, mtu 1500, options 0x42

 

I have to admit I've never seen this before and I tried to Google it but without success. Maybe some of you Cisco gurus out here can help me out?

 

Thank you in advance!

 

Cheers,

 

Adis

 

 

2 REPLIES 2
Giuseppe Larosa
Hall of Fame Master

Hello Adis,

I agree it is quite strange.

MTUs are the same 1500 bytes

OSPF RIDs are set to different values and are seen by the other device.

N7k-4 should be recognized as Master for his higher OSPF Router-id by N7k-1. It should give up to claim to be Master in this Exchange.

 

I understand that you cannot clear the OSPF process or shut down the interface as this Vlan 10 is transit.

 

Are the two devices running different versions of NX-OS ?

This is the only neighborship stucked in Exstart state in both devices?

 

Hope to help

Giuseppe

 

Are you utilizing a vPC? Or some kind of MLAG?

 

I had a similar problem and this required configuring layer3 peer-router in my vPC to fix the stuck in ExStart state.