12-07-2022 04:11 PM
Hi Team,
I'm working to create a connection between an IOS 3850 switch and a Nexus 9300 switch.
Our architecture requires me to establish a single connection between the nexus and the ios but also within a port channel.
I'm attempting to ping with no luck, any idea what I'm missing ?? I'm using a layer 2 port channel and vlan interface on both switches.
Here's what I have:
%%%%%%%%
switch1 - IOS 3850
%%%%%%%%
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
2 Po2(SU) LACP Gi0/1(P) Gi0/2(s)
GigabitEthernet0/1 unassigned YES unset up up
GigabitEthernet0/2 unassigned YES unset up down
Port-channel2 unassigned YES unset up up
Vlan100 10.113.100.254 YES manual up up
!
interface GigabitEthernet0/1
description SWITCH02 47
switchport trunk encapsulation dot1q
switchport mode trunk
negotiation auto
channel-group 2 mode active
end
!
interface Port-channel2
description switch02/3
switchport trunk encapsulation dot1q
switchport mode trunk
end
%%%%%%%%%%%%%%%%%%%%%%%%
switch2 -- nexus 9300
%%%%%%%%%%%%%%%%%%%%%%%%
feature scp-server
feature interface-vlan
feature lacp
ip route 10.113.100.0/24 10.113.100.254
vlan 1,100
interface Vlan100
no shutdown
ip address 10.113.100.253/24
interface port-channel2
switchport mode trunk
interface Ethernet1/1
switchport mode trunk
channel-group 2 mode active
12-07-2022 07:50 PM
remove "ip route 10.113.100.0/24 10.113.100.254"
your port channel is UP, ping again and run this command, do you see arp as incomplete ?
show ip arp 10.113.100.254
12-07-2022 09:20 PM
I agree that the static route should be removed. Subnet 10.113.100.0 is a locally connected subnet. There is no point in configuring a static route for a locally connected subnet, especially when the next hop in the static route is an address that is inside the subnet.
Perhaps it might help us understand the issue a bit better if we could see the output from both switches to the command show cdp neighbor detail.
12-08-2022 10:28 AM
Hi Rick,
I removed that routing command and it had no effect.
The output from CDP neighbor is below. Not sure why my connection would be UP but unable to ping.
switch02# show cdp neighbors
Capability Codes: R - Router, T - Trans-Bridge, B - Source-Route-Bridge
S - Switch, H - Host, I - IGMP, r - Repeater,
V - VoIP-Phone, D - Remotely-Managed-Device,
s - Supports-STP-Dispute
Device-ID Local Intrfce Hldtme Capability Platform Port ID
Switch.m Eth1/1 167 R S I Gig0/1
Switch01#show cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
D - Remote, C - CVTA, M - Two-port Mac Relay
Device ID Local Intrfce Holdtme Capability Platform Port ID
switch02.m.m(9BGQCXG3NMJ)
Gig 0/1 172 R S I C N9K-9000v Eth 1/1
12-08-2022 10:34 AM
Hi Ammahend,
On the nexus, switch02, I get the following when I ask it to resolve the address of switch01 (10.113.100.254):
switch02.m# show ip arp 10.113.100.254
Flags: * - Adjacencies learnt on non-active FHRP router
+ - Adjacencies synced via CFSoE
# - Adjacencies Throttled for Glean
CP - Added via L2RIB, Control plane Adjacencies
PS - Added via L2RIB, Peer Sync
RO - Re-Originated Peer Sync Entry
D - Static Adjacencies attached to down interface
IP ARP Table
Total number of entries: 1
Address Age MAC Address Interface Flags
10.113.100.254 00:01:23 0c35.c1da.8064 Vlan100
On the IOS, switch01, I get the following wen I ask to resolve address of switch02 (10.113.100.253)
switch01#show ip arp 10.113.100.253
Protocol Address Age (min) Hardware Addr Type Interface
Internet 10.113.100.253 2 0c35.c12f.1a07 ARPA Vlan100
I did remove that route command, but still unable to ping.
12-08-2022 11:26 AM
2 Po2(SU) LACP Gi0/1(P) Gi0/2(s)
there is one line suspend, so there is issue with port-channel
can you share
show port-channel summary in both SW?
12-08-2022 12:42 PM
The portchannel summary for switch02 shows:
--------------------------------------------------------------------------------
Group Port- Type Protocol Member Ports
Channel
--------------------------------------------------------------------------------
2 Po2(SU) Eth LACP Eth1/1(P)
And the etherchannel summary for switch01 is shown in original question where Gi0/1 is (P).
We are looking to create a connection between switch01 and switch02 without having to also go and configure switch03 which would be connnected via Gi0/2 to switch01, forming the other half of that port channel on the remote side (from switch01 perspective).
12-08-2022 12:47 PM
show interface status in N9K are you see speed and duplex set ?
12-08-2022 01:07 PM
Appears to be full duplex and 1000 Mb/s on the nexus Eth1/1.
On the IOS Gi0/1 it has Auto Duplex, Auto speed.
12-08-2022 01:28 PM
can you hardcode the speed/duplex in IOS side ?
12-08-2022 01:37 PM
I'm playing with it on both interfaces. The IOS side I had to run 'no negotiation auto'. Once I changed the settings, the Gi0/1 interface on IOS portchannel went suspended and the Gi0/2 interface went to (P) status.
Trying a bunch of stuff
12-08-2022 02:10 PM
I do lab using N9K and IOSL2 and N9K port-channel showing in
show interface status in N9K
noOperMem <<- I check this error it seem to be the order of command we enter is effect port-channel in NSK.
do you face same issue ?
12-08-2022 05:08 PM
shut no shut, if it doesn't work, remove config and reconfigure in sequential order as shown here
https://www.youtube.com/watch?v=eszcAJhUwiA
12-09-2022 02:11 AM
I am somewhat puzzled about this issue. The output of show cdp neighbor confirms that at layer 2 the devices see each other. The output of show arp confirms that at layer 3 there is visibility. Why would ping not work? Is there some aspect of the configuration that we do not know about? (perhaps some security policy/acl impacting ping)
If all else fails I would suggest running debug for ip, attempt the ping, and post debug output. (or is there is lots of ip traffic then perhaps use the option of debug ip with an acl that specifies addresses)
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide