cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
529
Views
5
Helpful
13
Replies
Highlighted
Beginner

Not getting ISP speed on 1921 router

Hello guys, hope everyone is well and staying safe. I'm studying for my CCNA and in my lab I have a 1921 router with a EHWIC-4ESG installed, which provides gig speed. I'm paying for 1Gbps to my ISP so would take advantage of that and if I connect any device directly to the modem, I get that speed. But when I connect those same devices to the gig switchports on the 1921, at max, I'll get 250Mbps. Here's what I've tried to far:

1. Changing cables and ports...same results

2. Changing speed on ports to 1000 and duplex to FULL...same

 

My thinking is pointing me to something in my configuration but I'm not sure what. Any suggestions?

 

Here's my configuration:

R1(config-if)#sh run
^
% Invalid input detected at '^' marker.

R1(config-if)#do sh run
Building configuration...

Current configuration : 4424 bytes
!
! Last configuration change at 08:20:45 EAST Wed Sep 9 2020
! NVRAM config last updated at 08:28:26 EAST Wed Sep 9 2020
!
version 15.5
no service pad
service tcp-keepalives-in
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$.Vne$JpIW7s1hSQ.rND74jlN8A1
!
aaa new-model
!
!
!
!
!
!
!
!
aaa session-id common
ethernet lmi ce
clock timezone EAST -4 0
!
!
!
!
!
!
no ip source-route
!
!
!
ip dhcp excluded-address 10.1.3.254
ip dhcp excluded-address 10.1.2.254
ip dhcp excluded-address 10.1.4.254
!
ip dhcp pool WiFi
network 10.1.2.0 255.255.255.0
default-router 10.1.2.254
dns-server 9.9.9.9
domain-name MyHome
!
ip dhcp pool EXP
network 10.1.3.0 255.255.255.0
domain-name MyHome
default-router 10.1.3.254
dns-server 9.9.9.9
!
ip dhcp pool PC
network 10.1.4.0 255.255.255.0
dns-server 9.9.9.9
domain-name MyHome
default-router 10.1.4.254
!
ip dhcp pool SW1
host 10.1.3.253 255.255.255.0
hardware-address 001d.454e.cc00
!
ip dhcp pool SW2
host 10.1.3.252 255.255.255.0
hardware-address 001d.45ce.ae00
!
!
!
no ip bootp server
ip domain name joey.net
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
!
!
license udi pid CISCO1921/K9 sn FJC2007E299
!
!
!
spanning-tree portfast bpduguard
spanning-tree vlan 30 priority 8192
vtp domain CISCO
vtp mode transparent
vtp version 2
username admin privilege 15 secret 5 $1$ILlm$q2tS0uNPM8qL/W7BkFSoA1
username admin1 privilege 15 secret 9 $9$V40rT5ZlMeZPZE$KFh3viwTwmcAsRnT7kHImwLOylVif2GhWp/kpIic4Vk
!
redundancy
!
!
vlan 20
name WiFi
!
vlan 30
name EXP
!
vlan 40
name PC
!
vlan 1004
bridge 0
stp type ieee
!
!
!
!
!
interface Loopback1
ip address 2.2.2.1 255.255.255.248
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
ip address 192.168.1.9 255.255.255.0
ip access-group INBOUND in
ip access-group OUTBOUND out
no ip redirects
no ip unreachables
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
ntp broadcast client
!
interface GigabitEthernet0/1
no ip address
ip nat outside
ip virtual-reassembly in
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
shutdown
!
interface GigabitEthernet0/1/0
switchport access vlan 40
no ip address
spanning-tree portfast
!
interface GigabitEthernet0/1/1
switchport access vlan 20
no ip address
spanning-tree portfast
!
interface GigabitEthernet0/1/2
switchport access vlan 30
no ip address
duplex full
!
interface GigabitEthernet0/1/3
switchport access vlan 30
no ip address
duplex full
!
interface Vlan1
no ip address
shutdown
!
interface Vlan20
description WIFI
ip address 10.1.2.254 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface Vlan30
description EXPERIMENTAL
ip address 10.1.3.254 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface Vlan40
description PC
ip address 10.1.4.254 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
ip default-gateway 192.168.1.1
no ip classless
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat inside source list 2 interface GigabitEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 192.168.1.1
ip route 10.1.2.0 255.255.255.0 Loopback1
ip route 10.1.3.0 255.255.255.0 Loopback1
ip route 10.1.4.0 255.255.255.0 Loopback1
ip ssh version 2
!
ip access-list extended INBOUND
deny ip 10.1.0.0 0.0.255.255 any log
deny ip 127.0.0.0 0.255.255.255 any log
deny ip 240.0.0.0 7.255.255.255 any log
deny ip 192.0.2.0 0.0.0.255 any log
deny ip 169.254.0.0 0.0.255.255 any log
deny ip host 0.0.0.0 any log
permit ip any any
!
!
!
access-list 2 permit 10.1.0.0 0.0.255.255
access-list 2 permit 192.168.1.0 0.0.0.255
access-list 2 deny any log
!
!
!
control-plane
!
!
vstack
!
line con 0
password 7 06220E3347430817574232
line aux 0
session-timeout 5 output
timeout login response 300
password 7 02220549000B0E2F1E1B29
transport input ssh
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
session-timeout 5 output
access-class 2 in
exec-timeout 5 0
timeout login response 300
privilege level 15
password 7 072B205E4504180B45472B
transport input ssh
!
scheduler allocate 20000 1000
ntp server 129.6.15.28 source GigabitEthernet0/0
!
end

13 REPLIES 13
Highlighted
VIP Mentor

here is the performance report which you maximum router can go.

 

you may not get on router Line speed. required additional license or more, you need to look different model.

 

BB
*** Rate All Helpful Responses ***
Highlighted

Ok. Thanks. If I understand correctly, I'm capped at 2770Mbps? If I calculate correctly that gives me 2.7Gbps. Correct?

 

Also, I forgot to add that I get about 600-700Mbps on my wireless devices connected to my TP-lInk access point that connects  to one of the LAN ports.

Highlighted

Correct, the maximum documented (aggregate) performance is 2.7 Gbps (table 1), but conversely, figure 1 recommends the 1921 for only WAN links of 15 Mbps.  ISR performance is very variable depending on your configuration and your traffic mix.

If your CPU is hitting 100%, you've bumped into the performance limits of your router.

Changing your configuration might yield more throughput.

BTW, the 2921 doesn't have a performance limit beyond what the hardware is capable of.

Also BTW, something like the 2921 was designed as a WAN router when having gig WAN links wasn't really expected.

Highlighted

Great thanks for the response. Let me see if I understand correctly...Sorry I'm new to networking, just been doing it for about 5 months now.

What you're saying is that the CPU of the 1921 is maxed out, therefore limiting my speed? Like a hardware limitation?

 

"Changing your configuration might yield more throughput."

Any recommendations?

 

Also, do you know if the 2921 is loud? I had gotten the 1921 because I had read that it didn't make much noise, that's why I got it.

Highlighted

"What you're saying is that the CPU of the 1921 is maxed out, therefore limiting my speed? Like a hardware limitation?"

Yup!

"Changing your configuration might yield more throughput."

"Any recommendations?"

Would need to see your current config.

"Also, do you know if the 2921 is loud? I had gotten the 1921 because I had read that it didn't make much noise, that's why I got it."

Would depend on your definition of "loud".  In general, "Enterprise" class network devices are often tucked away in a closet or data center, not usually something you want next to your desk.  So, they can be somewhat noisy.  Much of their noise comes from their fans, which often are variable speed.  If they start to heat up, their fans get much louder.

Highlighted

"What you're saying is that the CPU of the 1921 is maxed out, therefore limiting my speed? Like a hardware limitation?"

Yup!

I was hoping that wasn't the case....

 

Would need to see your current config.

I posted my routers config in a previous post. As far as my physical set up I only have the 1921 connected to the ISP modem. Also a AP connected to the 1921.

 

Would depend on your definition of "loud".  In general, "Enterprise" class network devices are often tucked away in a closet or data center, not usually something you want next to your desk.  So, then can be, somewhat, noisy.  Much or their noise comes from their fan(s), which are often variable speed.  If they start to hit up, their fans get much louder.

Well, for example, I also have two Catalyst 3750s, which I don't use much, only for experimental stuff so I leave them off unless I want to mess around and they are pretty loud compared to the 1921. I can still hear the 1921s fan but its not unbearable. This whole set up is in my bedroom, so Im trying to keep it the sound at a minimum.

Highlighted

"I posted my routers config in a previous post."

Oops, indeed you do!  My bad. 

ACL with logging, is a slow process.  I assume you gotten few, if any, hits for your "INBOUND" ACL?  You might consider removing that ACL.

Post results from "show proc cpu s|ex 0.00".

Highlighted

Ok, removed the ACLs completely.

 

I've attached a pic of the output

show proc.jpg

 

Highlighted

That particular CPU shows half your processor CPU being used by SSH.

Can you do a similar posting when you push to max throughput?

Highlighted

This is the same output once I ran the command again this morning. 

show proc1.jpg

Can you do a similar posting when you push to max throughput?

How do I do that?

Highlighted

How did you "discover" your throughput limit?

Highlighted

I "discovered" it via the document that was posted by user balaji.bandj

Highlighted
Enthusiast

@j.defrank25

 

you probably are not getting all throughput due the that particular model not supporting at all, i do recall those router would required a extra license to bump up the total traffic aggregate, but i beleive it only starts with the 4k routers.

 

so if you don't want to replace that, probably you can call your ISP to drop the speed and cache in some money :), after a few months you can replace that old router with something high grade. Also check your ssh sessions on your router, you might have some pending consuming resources and dropping some performance when comes to forward traffic.

Please mark it helpfull if it was the case, and i have this problem too. Double touchdown is amazing. Thanks to make Engineering easy.
Content for Community-Ad