05-25-2024 05:35 PM
Hello guys,
i want to enable ssh on management port of C2960 and connect that port to gig 1/0/10 core switch,
C2960 MGMT-VRF interface
#interface gig0/0
#no shut
#vrf forwarding mgmt-vrf
#ip address 192.168.10.10 255.255.255.0
#ip route 0.0.0.0 0.0.0.0 192.168.10.1 (Core IP SVI)
------------------SSH----------------------------
#hostname SW-C2960
#ip domain-name test.com
#crypto key generate rsa 2048
#ip ssh version 2
#line vty 0 4
#transport input ssh
#login local
#username admin password test123
---------------------------------------------
I think do not need to define vlan on the management int as long as its on L3, do i need to put the core interface gig1/0/10 access mode or trunk or what ? i need a bit clear configuration command and idea.
Thank you.
Solved! Go to Solution.
05-26-2024 12:19 AM
Cat 9300 is your core and ort connected to interface gig1/0/10 - then this should be access VLAN for MGMT where the VLAN has same IP as gateway 192.168.10.1
You also need to mentioned source as mgmt-vrf for this to work.
Also your VRF routing -
ip route vrf Mgmt-intf 0.0.0.0 0.0.0.0 192.168.10.1
05-26-2024 07:28 AM
correct -
interface gig 1/0/10
switchport mode access
switchport access vlan 850.
no shutdown.
you should able to ping 192.168.10.10 using SVI VLAN 850
05-26-2024 12:06 AM
>... do i need to put the core interface gig1/0/10 access mode or trunk or what ?
- Access mode will be sufficient ,
M.
05-26-2024 03:18 AM
and #switchport access vlan 90/mgmt ?
05-26-2024 03:20 AM
- Depends what the vlan number is on the core , for accessing the mgmt port of these devices ,
M.
05-26-2024 06:40 AM
#vlan 850
#name mgmt
#exit
#interface vlan 850
#no shut
#ip add 192.168.240.1/24
#exit
Now from C2960 MGMT Interface is connected to CORE interface gig 1/0/10.
what configuration is needed on core interfa
05-26-2024 12:19 AM
Cat 9300 is your core and ort connected to interface gig1/0/10 - then this should be access VLAN for MGMT where the VLAN has same IP as gateway 192.168.10.1
You also need to mentioned source as mgmt-vrf for this to work.
Also your VRF routing -
ip route vrf Mgmt-intf 0.0.0.0 0.0.0.0 192.168.10.1
05-26-2024 07:14 AM
so the interface gig1/0/10 on the core should have this config ?
#int gig1/0/10
#switchport access vlan 850 (MGMT SVI VLAN)
#exit
? or what ?
05-26-2024 07:28 AM
correct -
interface gig 1/0/10
switchport mode access
switchport access vlan 850.
no shutdown.
you should able to ping 192.168.10.10 using SVI VLAN 850
05-26-2024 07:42 AM
Right Thanks. if i connect it to an ACCESS switch rather CORE so what will the port config on Access switch please ?
05-26-2024 08:22 AM - edited 05-26-2024 08:24 AM
Depends on requirement inbound or outoff band management.
Inland you can use VLAN SVI and configure IP. (if you already have connection to Access switch that is connected to Core using Layer2 or port-channel connection.)
out of band you already have configuration which you posted in the OP
inband :
vlan 850
name MGMT
interface vlan 850
ip address 192.168.10.10 255.255.255.0
ip route 0.0.0.0 0.0.0.0 192.168.10.1 (if the switch acting as Layer 3) if layer 2 you can have default-gateway command.
(make sure VLAN 850 allowed in the trunk)
CORE--(layer 2 trunk)--Access--(Layer2 Trunk)-Another access switch (which you looking to configuration)
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide