cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
375
Views
15
Helpful
9
Replies
AshP83606
Beginner

OSPF Line Protocol is Down for Interfaces under 172.16.23.0/30 subnet and no routing information sources

I have a network of 5 routers that are connected with OSPF. I should be able to ping any interface from a given router. These are my interfaces, IP addresses, and subnet masks

  • R1:
    • Int s0/0; 172.16.32.5/30; 255.255.255.252
    • Int s0/1; 172.16.23.5/30; 255.255.255.252
    • Int s0/2; 192.168.10.5/30; 255.255.255.252
  • R2:
    • F0/0; 192.168.10.9/30; 255.255.255.252
    • Int s0/2; 192.168.10.6/30; 255.255.255.252
  • R3:
    • F0/0; 192.168.10.10/30; 255.255.255.252
    • Int s0/0; 172.16.23.10/30; 255.255.255.252
    • Int s0/1; 172.16.32.10/30; 255.255.255.252
  • R4:
    • Int s0/0; 172.16.32.6/30; 255.255.255.252
    • Int s0/1; 172.16.32.9/30; 255.255.255.252
  • R5:
    • Int s0/0; 172.16.23.9/30; 255.255.255.252
    • Int s0/1; 172.16.23.6/30; 255.255.255.252

Currently, int s0/0 and int s0/1 of R5 are status up and protocol down. The same for int s0/0 of R3 and int s0/1 of R1. I cannot ping any interface from R5. I cannot ping s0/0 or s0/1 of R5 from R1. I cannot ping s0/0 or s0/01 of R5 from R3. 

 

I am not sure how to change my protocol to up for these interfaces. Additionally, no routing information is listed under "Routing Information Sources" for R5 when do "show ip protocol". I did conf t, router ospf 1, network 172.16.23.4 0.0.0.3 area 0 and network 172.16.23.8 0.0.0.3 area 0 to establish the routing for networks for R5. 

  • R1
    • Routing for Networks:
      • 172.16.23.4 0.0.0.3 area 0
      • 172.16.32.4 0.0.0.3 area 0
      • 192.168.10.4 0.0.0.3 area 0
    • Routing Information Sources:
      • Gateway         Distance      Last Update
      • 129.168.10.9         110      00:00:08
      • 192.168.10.10        110      00:00:08
      • 172.16.32.9          110      00:00:08
    • R2
      • Routing for Networks:
      •     192.168.10.4 0.0.0.3 area 0
      •     192.168.10.8 0.0.0.3 area 0
      •   Routing Information Sources:
      •     Gateway         Distance      Last Update
      •     192.168.10.5         110      00:01:19
      •     192.168.10.10        110      00:01:19
      •     172.16.32.9          110      00:01:29
    • R3
      • Routing for Networks:
      •     172.16.23.8 0.0.0.3 area 0
      •     172.16.32.8 0.0.0.3 area 0
      •     192.168.10.8 0.0.0.3 area 0
      •   Routing Information Sources:
      •     Gateway         Distance      Last Update
      •     129.168.10.9         110      00:01:48
      •     192.168.10.5         110      00:01:58
      •     172.16.32.9          110      00:01:48
    • R4
      • Routing for Networks:
      •     172.16.32.4 0.0.0.3 area 0
      •     172.16.32.8 0.0.0.3 area 0
      •   Routing Information Sources:
      •     Gateway         Distance      Last Update
      •     192.168.10.5         110      00:02:15
      •     192.168.10.10        110      00:02:15
    • R5
      • Routing for Networks:
      •     172.16.23.4 0.0.0.3 area 0
      •     172.16.23.8 0.0.0.3 area 0

How would I be able to resolve this? I am very new OSPF and I am unsure of what I am overlooking. I have attached a picture of my topology. 

9 REPLIES 9
Georg Pauwen
VIP Expert

Hello,

 

it looks like you are doing this in GNS3 ? Either way, the OSPF part of the configuration looks ok. Make sure that on each serial connection, one end has 'clock rate 64000' configured. Without that command on one of the serial interfaces, the link won't come up.

For the R5 interfaces  (as well as my other interfaces on the other routers) have clock rate 64000. 

From the .cfg: 

```

interface Serial0/0
ip address 172.16.23.9 255.255.255.252
ip ospf message-digest-key 1 md5 
clock rate 64000
!

```
```

interface Serial0/1
ip address 172.16.23.6 255.255.255.252
ip ospf message-digest-key 1 md5 cit494
clock rate 64000
!

```

 

Hello,

 

you need the clock rate on one side only.

 

Post the full running configs of all 5 routers, otherwise this will just keep being guesswork. You are missing something fundamental...

Attached is a text file with configurations of all five routers. I removed the clock rate so that only one side now has the clock rate. I think I am still overlooking something because I cannot ping R5 s0/1 or s0/0 from R1 s0/1 or R5 s0/1 or s0/0 from R3 (and vice versa). 

 

Hello,

 

configs look good. My lab is identical to yours, minus the OSPF authentication, which I did not configure.

 

Can you remove the entire MD5 part ?

 

Also, can you send the actual GNS3 file ? Which images did you use ?

Torken
Beginner

Hello,

Please give us these informations :

R5#s ru | sec int
R5#s int s0/0
R5#s ip int

Can you ping s0/0 (R5) from s0/0 (R3)

As Georg Pauwen said it could be because clock rate (we will see if configuration is ok with sh run | sec int command)

Thanks

When I try running R5#s ru | sec int, it says "invalid input detected at '^' marker. 

 

R5#s int s0/0 outputs: 

```

R5#s int s0/0
Serial0/0 is up, line protocol is down
Hardware is GT96K Serial
Description: switch port connection to DNS server
Internet address is 172.16.23.9/30
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation HDLC, loopback not set
Keepalive set (10 sec)
Last input never, output 00:00:08, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/1/256 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
Available Bandwidth 1158 kilobits/sec
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
37 packets output, 2078 bytes, 0 underruns
0 output errors, 0 collisions, 15 interface resets
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
DCD=up DSR=up DTR=up RTS=up CTS=up

```

R5#s ip int outputs: 

```

R5#s ip int
FastEthernet0/0 is administratively down, line protocol is down
Internet protocol processing disabled
Serial0/0 is up, line protocol is down
Internet address is 172.16.23.9/30
Broadcast address is 255.255.255.255
Address determined by non-volatile memory
MTU is 1500 bytes
Helper address is not set
Directed broadcast forwarding is disabled
Multicast reserved groups joined: 224.0.0.5
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Local Proxy ARP is disabled
Security level is default
Split horizon is enabled
ICMP redirects are always sent
ICMP unreachables are always sent
ICMP mask replies are never sent
IP fast switching is enabled
IP fast switching on the same interface is enabled
IP Flow switching is disabled
IP CEF switching is enabled
IP CEF Fast switching turbo vector
IP multicast fast switching is enabled
IP multicast distributed fast switching is disabled
IP route-cache flags are Fast, CEF
Router Discovery is disabled
IP output packet accounting is disabled
IP access violation accounting is disabled
TCP/IP header compression is disabled
RTP/IP header compression is disabled
Policy routing is disabled
Network address translation is disabled
WCCP Redirect outbound is disabled
WCCP Redirect inbound is disabled
WCCP Redirect exclude is disabled
BGP Policy Mapping is disabled
FastEthernet0/1 is administratively down, line protocol is down
Internet protocol processing disabled
Serial0/1 is up, line protocol is down
Internet address is 172.16.23.6/30
Broadcast address is 255.255.255.255
Address determined by non-volatile memory
MTU is 1500 bytes
Helper address is not set
Directed broadcast forwarding is disabled
Multicast reserved groups joined: 224.0.0.5
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Local Proxy ARP is disabled
Security level is default
Split horizon is enabled
ICMP redirects are always sent
ICMP unreachables are always sent
ICMP mask replies are never sent
IP fast switching is enabled
IP fast switching on the same interface is enabled
IP Flow switching is disabled
IP CEF switching is enabled
IP CEF Fast switching turbo vector
IP multicast fast switching is enabled
IP multicast distributed fast switching is disabled
IP route-cache flags are Fast, CEF
Router Discovery is disabled
IP output packet accounting is disabled
IP access violation accounting is disabled
TCP/IP header compression is disabled
RTP/IP header compression is disabled
Policy routing is disabled
Network address translation is disabled
WCCP Redirect outbound is disabled
WCCP Redirect inbound is disabled
WCCP Redirect exclude is disabled
BGP Policy Mapping is disabled
Serial0/2 is administratively down, line protocol is down
Internet protocol processing disabled
Serial1/0 is administratively down, line protocol is down
Internet protocol processing disabled
Serial1/1 is administratively down, line protocol is down
Internet protocol processing disabled
Serial1/2 is administratively down, line protocol is down
Internet protocol processing disabled
Serial1/3 is administratively down, line protocol is down
Internet protocol processing disabled

```

try :

show run | section interface

 

Giuseppe Larosa
Hall of Fame Master

Hello @AshP83606 ,

you have issues at OSI layer 1 / layer 2 so when you see an interface with protocol up / down you need to wonder about interface configurations on both sides.

Being synchronous serial interfaces, one side has to provide a time reference called clock that is used by both devices on the link to create a working connection and that specifies the link speed in bps.

Ping and OSPF will come later when you fix issues at lower OSI layers.

 

Hope to help

Giuseppe