cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1436
Views
0
Helpful
6
Replies
Highlighted

OSPF neighbor not coming up "Drop packet, OSPF shut down on interface"

OSPF neighbor can't come up on a DMVPN spoke.

It all started with this message. Tun0 interface has always been up and connectivity has been verified.

*Apr 17 15:26:13.312: %OSPF-5-ADJCHG: Process 302, Nbr100.10.0.1 on Tunnel0 from FULL to DOWN, Neighbor Down: Interface down or detached

debug ip ospf packet

*Apr 17 15:38:23.938: OSPF-302 PAK   Tu0: Drop packet, OSPF shut down on interface

CE2#show ip ospf int tun0
Tunnel0 is up, line protocol is up
Internet Address 100.10.0.9/24, Area 51, Attached via Interface Enable
Process ID 302, Router 100.10.0.9, Network Type BROADCAST, Cost: 1000
Topology-MTID Cost Disabled Shutdown Topology Name
0 1000 no no Base
Enabled by interface config, including secondary ip addresses
Transmit Delay is 1 sec, State DOWN, Priority 0
No designated router on this network
No backup designated router on this network
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40

I am unable to find anything about "Drop packet, OSPF shut down on interface". Known bug?

6 REPLIES 6
Highlighted
VIP Mentor

Hi

Could you please share the config of both routers? Are you redistributing the source and destination into OSPF as well?




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<
Highlighted

DMVPN mGRE interface (no destination, source interface does not run OSPF), no redistribution

the ospf interface state is stuck in down

Highlighted

Thank you, 

Could you please share the config of the tunnels?




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<
Highlighted

Hi,

In a DMVPN phase 1, we need OSPF point-to-multipoint.  

In a DMVPN phase 2, we need OSPF broadcast.  The reason is because we need the broadcast network type to allow us to go spoke-to-spoke. 
In a DMVPN phase 3, we need OSPF point-to-multipoint because NHRP will override our next hop of the hub with the spoke. 
Hope it is useful
:-)



>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<
Highlighted
VIP Mentor

Hello,

in addition to the other posts, make sure that you do not advertise the tunnel sources into OSPF. Here is a generic sample config:

Hub

interface Tunnel1
description DMVPN Tunnnel Hub
bandwidth 1000
ip address 192.168.0.1 255.255.255.0
no ip redirects
ip mtu 1420
ip nhrp authentication dmvpn
ip nhrp map multicast dynamic
ip nhrp network-id 99
ip nhrp holdtime 300
no ip route-cache
ip ospf network broadcast
no ip mroute-cache
delay 1000
tunnel source FastEthernet0/0
tunnel mode gre multipoint
tunnel key 100000

interface FastEthernet0/0
ip address 10.22.118.1 255.255.0.0
duplex auto
speed auto

router ospf 1
log-adjacency-changes
network 192.168.0.0 0.0.0.255 area 0

Spoke

interface Tunnel1
description DMVPN Tunnel Spoke
bandwidth 1000
ip address 192.168.0.2 255.255.255.0
no ip redirects
ip mtu 1420
ip nhrp authentication dmvpn
ip nhrp map multicast dynamic
ip nhrp map 192.168.0.1 10.22.118.1
ip nhrp map multicast 10.22.118.1
ip nhrp network-id 99
ip nhrp holdtime 300
ip nhrp nhs 192.168.0.1
no ip route-cache
ip ospf network broadcast
no ip mroute-cache
delay 1000
tunnel FastEthernet0/0
tunnel mode gre multipoint
tunnel key 100000

router ospf 1
log-adjacency-changes
network 192.168.0.0 0.0.0.255 area 0

Highlighted

So a week later I revisited this issue, and found `shutdown` under the OSPF process. Removing `shutdown` solved the problem.

The error message is somewhat vague. I am surprised nobody has run into this issue before. Not sure why the process was shutdown, I don't think I did it manually.

Content for Community-Ad