cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2726
Views
0
Helpful
4
Replies

passing Layer 2 traffic between two Layer 3 ports ?

tedauction
Level 1
Level 1

Hello, I have a Cisco 1921 with two physical L3 interfaces. Both of these have sub-interfaces in the same VLAN connected to switches either side.

If I establish a sub-interface Gi0/0.2 and want that layer 2 traffic for VLAN 2 to pass through  to Gi0/1.2, how do I do it ?

Thank you kindly for any help.

So what I want is to transparently pass layer 2 traffic (same VLAN) between two L3 ports on the 1921 router.

Would a BVI interface do this ? (intergrated bridging and routing) 

1 Accepted Solution

Accepted Solutions

Let me provide you an example:

Router

interface Fa0/0
no ip address
!
interface Fa0/0.2
encapsulation dot1Q 2
bridge-group 2
!
interface Fa0/1
no ip address
!
interface Fa0/1.2
encapsulation dot1Q 2
bridge-group 2
!

!
interface BVI2
ip address 10.10.2.1 255.255.255.0
!

!

bridge irb
bridge 2 protocol ieee
bridge 2 route ip

Switch 1

Interface f1/0/1
switchport trunk encapsulation dot1q
switchport mode trunk

vlan 2

interface Vlan2
ip address 10.10.2.2 255.255.255.0
end

Switch#ping 10.10.2.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.2.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

Switch 2

Interface f1/0/1
switchport trunk encapsulation dot1q
switchport mode trunk

vlan 2

interface Vlan2
ip address 10.10.2.3 255.255.255.0
end

Switch2#ping
*Feb 13 13:06:47.111: %SYS-5-CONFIG_I: Configured from console by console
Switch2#ping 10.10.2.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
Switch2#ping 10.10.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 ms
Switch2#ping 10.10.2.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.2.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 5/5/5 ms
Switch2#




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

View solution in original post

4 Replies 4

Hi

You cannot have 2 ip addresses of the same subnet configured on the same router, it will overlap from each other. Are these vlan 2 configured on isolated switches or infrastructure?

Could you please provide more details?




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Yes, these two VLANs are configured on separate switches. I want to transparently bridge them through an L3 1921 router in the middle.

Is there any way to do this ?

I was thinking perhaps by using an interface BVI ?

Yeap, BVI could be

bridge irb

bridge 1 protocol ieee

bridge 1 route ip

But these 2- Vlan2 are using the same subnet?




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Let me provide you an example:

Router

interface Fa0/0
no ip address
!
interface Fa0/0.2
encapsulation dot1Q 2
bridge-group 2
!
interface Fa0/1
no ip address
!
interface Fa0/1.2
encapsulation dot1Q 2
bridge-group 2
!

!
interface BVI2
ip address 10.10.2.1 255.255.255.0
!

!

bridge irb
bridge 2 protocol ieee
bridge 2 route ip

Switch 1

Interface f1/0/1
switchport trunk encapsulation dot1q
switchport mode trunk

vlan 2

interface Vlan2
ip address 10.10.2.2 255.255.255.0
end

Switch#ping 10.10.2.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.2.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

Switch 2

Interface f1/0/1
switchport trunk encapsulation dot1q
switchport mode trunk

vlan 2

interface Vlan2
ip address 10.10.2.3 255.255.255.0
end

Switch2#ping
*Feb 13 13:06:47.111: %SYS-5-CONFIG_I: Configured from console by console
Switch2#ping 10.10.2.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
Switch2#ping 10.10.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 ms
Switch2#ping 10.10.2.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.2.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 5/5/5 ms
Switch2#




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<
Review Cisco Networking products for a $25 gift card