PC to switch connectivity fail vlan & spanning-tree
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
09-10-2020 09:47 AM
Hello all,
I've done everything I can think off and I just can't get this material. I cannot for the life of me ping pc to another pc using vlans.
If anyone can help me understand it better, it will be very much appreciated. I attached the packet tracer diagram and below are my 'show running-config'.
S1#show running-config
Building configuration...
Current configuration : 1818 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname S1
!
!
!
!
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
spanning-tree vlan 10,20,30 priority 24576
!
interface Port-channel1
switchport trunk native vlan 90
switchport mode trunk
!
interface Port-channel2
switchport trunk native vlan 90
switchport mode trunk
!
interface FastEthernet0/1
switchport trunk native vlan 90
switchport mode trunk
channel-group 2 mode passive
!
interface FastEthernet0/2
switchport trunk native vlan 90
switchport mode trunk
channel-group 2 mode passive
!
interface FastEthernet0/3
switchport trunk native vlan 90
switchport mode trunk
channel-group 1 mode auto
!
interface FastEthernet0/4
switchport trunk native vlan 90
switchport mode trunk
channel-group 1 mode auto
!
interface FastEthernet0/5
!
interface FastEthernet0/6
switchport access vlan 10
switchport mode access
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan90
mac-address 0000.0c84.9501
ip address 172.27.90.10 255.255.255.0
!
!
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
!
!
end
- Labels:
-
LAN Switching
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
09-10-2020 10:40 AM
You should have Layer3 interface in one of the switch to take care of Routing and available gateway for PC-A / B -C
Enable
ip routing
craete VLAN Interface ( one of the switch) make sure you allocated respective VLAN where PC connected
example : PC-A belong to VLAN 10
example : PC-B belong to VLAN 20
example : PC-C belong to VLAN 30
nterface FastEthernet0/6
switchport access vlan 10
switchport mode access
spanning-tree portfast
nterface FastEthernet0/7
switchport access vlan 20
switchport mode access
spanning-tree portfast
nterface FastEthernet0/8
switchport access vlan 30
switchport mode access
spanning-tree portfast
interface Vlan10
ip address 172.27.10.1 255.255.255.0
interface Vlan20
ip address 172.27.20.1 255.255.255.0
interface Vlan30
ip address 172.27.30.1 255.255.255.0
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
09-10-2020 10:58 AM
thank you for your reply. I added the gateway to the switches and still no connectivity?
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
09-10-2020 08:31 PM
You can attach PT file but it must be a zip format; so zip it, attach it, we can figure it out.
In the past, sometimes my PT got "Stuck". Save it, close it, re-open your PT file and then tested it
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
10-14-2020 06:28 PM
Hey sorry for the late reply, but I had to hold off on this project. Now I am back to square one and would appreciate the help.
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
10-14-2020 06:29 PM
Sorry but I don't see anywhere, where I can attach the PT file?
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
10-15-2020 01:02 AM
At the bottom of your 'Reply' post there is an option to drag and drop or browse files to attach. Make sure the Packet Tracer project (.pkt) file is zipped (.zip).
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
10-15-2020 09:58 AM - edited 10-15-2020 10:09 AM
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
09-10-2020 11:12 AM - edited 09-10-2020 11:13 AM
The VLAN interface configuration required only on 1 switch not on all switches ?
Post all the switches configuration after modify the config.
give information where the PC connected what port in each switch ?
Let us know below tests ;
From PC-A / PC- B / PC-C are you able to ping respected gateways ? Gateway IP that is .1 ? all VLAN ?
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
09-10-2020 11:29 AM
S1#show running-config
Building configuration...
Current configuration : 2073 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname S1
!
!
!
!
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
spanning-tree vlan 10,20,30 priority 24576
!
interface Port-channel1
switchport trunk native vlan 90
switchport mode trunk
!
interface Port-channel2
switchport trunk native vlan 90
switchport mode trunk
!
interface FastEthernet0/1
switchport trunk native vlan 90
switchport mode trunk
channel-group 2 mode passive
!
interface FastEthernet0/2
switchport trunk native vlan 90
switchport mode trunk
channel-group 2 mode passive
!
interface FastEthernet0/3
switchport trunk native vlan 90
switchport mode trunk
channel-group 1 mode auto
!
interface FastEthernet0/4
switchport trunk native vlan 90
switchport mode trunk
channel-group 1 mode auto
!
interface FastEthernet0/5
!
interface FastEthernet0/6
switchport access vlan 10
switchport mode access
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
mac-address 0000.0c84.9502
ip address 172.27.10.1 255.255.255.0
!
interface Vlan20
mac-address 0000.0c84.9503
ip address 172.27.20.1 255.255.255.0
!
interface Vlan30
mac-address 0000.0c84.9504
ip address 172.27.30.1 255.255.255.0
!
interface Vlan90
mac-address 0000.0c84.9501
ip address 172.27.90.10 255.255.255.0
!
!
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
!
!
end
S2#show running-config
Building configuration...
Current configuration : 1849 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname S2
!
!
!
!
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
spanning-tree vlan 90 priority 24576
spanning-tree vlan 10,20,30 priority 28672
!
interface Port-channel2
switchport trunk native vlan 90
switchport mode trunk
!
interface Port-channel3
switchport trunk native vlan 90
switchport mode trunk
!
interface FastEthernet0/1
switchport trunk native vlan 90
switchport mode trunk
channel-group 2 mode active
!
interface FastEthernet0/2
switchport trunk native vlan 90
switchport mode trunk
channel-group 2 mode active
!
interface FastEthernet0/3
switchport trunk native vlan 90
switchport mode trunk
channel-group 3 mode on
!
interface FastEthernet0/4
switchport trunk native vlan 90
switchport mode trunk
channel-group 3 mode on
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
switchport access vlan 20
switchport mode access
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan90
mac-address 00e0.a3b2.2501
ip address 172.27.90.11 255.255.255.0
!
!
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
!
!
end
S3#show running-config
Building configuration...
Current configuration : 1812 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname S3
!
!
!
!
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
spanning-tree vlan 90 priority 28672
!
interface Port-channel1
switchport trunk native vlan 90
switchport mode trunk
!
interface Port-channel3
switchport trunk native vlan 90
switchport mode trunk
!
interface FastEthernet0/1
switchport trunk native vlan 90
switchport mode trunk
channel-group 3 mode on
!
interface FastEthernet0/2
switchport trunk native vlan 90
switchport mode trunk
channel-group 3 mode on
!
interface FastEthernet0/3
switchport trunk native vlan 90
switchport mode trunk
channel-group 1 mode desirable
!
interface FastEthernet0/4
switchport trunk native vlan 90
switchport mode trunk
channel-group 1 mode desirable
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
switchport access vlan 30
switchport mode access
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan90
mac-address 0009.7cc0.de01
ip address 172.27.90.12 255.255.255.0
!
!
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
!
!
end
yes, there is connection between the their respected gateways.
no connection between other vlan gateways.
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
09-11-2020 08:59 AM
Hi,
Have you actually created the vlans on the switches
On a VTP server switch or on then all if in vtp transparent mode
something like
!
vlan 10
name PCs-Vlan10
!
vlan 20
!
name PCs-Vlan20
!
vlan 30
name PCs-Vlan30
!
!
vlan 90
name NATIVE-VLAN
!
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
09-11-2020 06:41 PM
Yes I have, and same results, no connectivity.
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
09-10-2020 11:37 AM - edited 09-10-2020 11:38 AM
as BB mentioned in his post; you need L3 switch; Although PT's 2960 (l2 switch) can handle routing, L3 switch like c3560 or c3650 can do better job and look better.
To communicate within same vlan (same subnet), you do not need routing enabled;
To communicate between vlans and different subents, you need either L3 switch using SVIs or Router-on-a-stick (ROAS) or plain router with several links to switch.
Regards, ML
**Please Rate All Helpful Responses **
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
09-11-2020 06:43 PM
Okay, I'm not too familiar with the switches, but are you implying that I delete those 2960 switches and replace them with the L3 switches?
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
09-12-2020 01:26 AM
Hello
What you show are just the access layer switches and the end hosts what you dont show is the L3 device that would be responsible for the inter-vlan routing, This device will have the L3 interfaces of the default-gateways that the hosts are using, the switches you show should be running as host switches meaning no ip routing enabled
Post the PT file or the running config of the L3 device in this network
Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.
Kind Regards
Paul
