cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2097
Views
0
Helpful
4
Replies
Highlighted
Beginner

Polycom getting DCHP address from wrong VLAN

Hello,

I have been tearing my hair out on this issue for 2 days, any help would be appreciated.

We have a normal network and a Cisco SGE2010P switch - a 48 port PoE switch

There are two VLANs, 1(data) & 50(VoIP).  When Polycoms are connected to the switch with VLAN 50 hard coded in the config they grab a DHCP address from VLAN 1, the PVID for the switch port.

The ports have membership in VLAN 1 as the PVID and VLAN 50 as tagged traffic.  I know the VoIP DHCP server is working because if I change a port to have a PVID of 50 any device gets the address from the VoIP DHCP server.

I have tried the ports as 'general' and 'trunk' with no success.

Any help would be greatly appreciated, I don't have much hair left!

--Thermal

4 REPLIES 4
Highlighted

Hello ,

have you tried :

interface x/y


switchport

switchport mode acc

switchport access vlan 50

[later edit]

Sorry it s a text-gui

The interface configuration should be with PVID 50.

Port vlan mode : access.

Dan

Highlighted

Dan,

Thank you for the response.

I had the PVID 1 one as there is a computer plugged into the phone.  The computer does need to be on VLAN 1.

The physical layout is:

switch <-> Phone <-> Computer

The phone does not alter the packets the the computer sends.

I would like the computer on VLAN 1, & the phone on VLAN 50.

None the less, I will try it in the morning...willing to try anything!

-Matt

Highlighted

switch config port :

Untagg vlan 1

tag vlan 50

DHCP server :  add option on dhcp server for vlan 1,  to set the voice vlan ( this is what is used for some nortel iphones - 191 )

Also read :

Assigning VLANs

http://knowledgebase.polycom.com/knowledgebase/End%20User/Tech%20Alerts/Audio/Using_SPIP_SSIP_Asterisk_TB43565.pdf

By default, the voice VLAN is unspecified. This means that voice and data traffic are untagged and transported in the native VLAN.

HTH

Dan

Highlighted

Dan,

Thanks for the link.

We have been setting the VLAN manually via the menu config.

I don't think we have the answer, I will keep looking.

-Matt

Content for Community-Ad