05-08-2013 02:50 AM - edited 03-07-2019 01:14 PM
hi all,
I am trying to configure port-channel from one switch to two switchs, and only one interface of each switchs make part of the portchannel
Cisco IOS Software, ME380x Software (ME380x-UNIVERSALK9-M), Version 12.2(52)EY4, RELEASE SOFTWARE (fc1)
baixo(config-if)
!
interface Port-channel12
port-type nni
switchport trunk allowed vlan 610,611
switchport mode trunk
end
!
interface GigabitEthernet0/3
port-type nni
switchport trunk allowed vlan 610,611
switchport mode trunk
channel-group 12 mode on
end
!
interface GigabitEthernet0/4
port-type nni
switchport trunk allowed vlan 610,611
switchport mode trunk
channel-group 12 mode on
end
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
Cisco IOS Software, C3560E Software (C3560E-UNIVERSALK9-M), Version 12.2(55)SE5, RELEASE SOFTWARE (fc1)
SWBAIXO(config)#
!
interface Port-channel12
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 610,611
switchport mode trunk
!
!
interface GigabitEthernet1/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 610,611
switchport mode trunk
channel-group 12 mode on
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
Cisco IOS Software, ME380x Software (ME380x-UNIVERSALK9-M), Version 15.3(1)S, RELEASE SOFTWARE (fc1)
cima(config-if)#
!
interface Port-channel12
switchport trunk allowed vlan 610,611
switchport mode trunk
!
!
interface GigabitEthernet0/1
switchport trunk allowed vlan 610,611
switchport mode trunk
channel-group 12 mode on
!
baixo(config)#int g0/3
baixo(config-if)#no shut
*May 7 14:37:41.534: %PM-4-ERR_DISABLE: channel-misconfig (STP) error detected on Gi0/3, putting Gi0/3 in err-disable state
*May 7 14:37:43.469: %LINK-3-UPDOWN: Interface GigabitEthernet0/3, changed state to down
baixo(config-if)#
baixo(config-if)#
baixo(config-if)#
baixo(config-if)#int g0/4
baixo(config-if)#no shut
baixo(config-if)#
*May 7 14:39:02.717: %PM-4-ERR_DISABLE: channel-misconfig (STP) error detected on Gi0/4, putting Gi0/4 in err-disable state
*May 7 14:39:04.660: %LINK-3-UPDOWN: Interface GigabitEthernet0/4, changed state to down
baixo(config-if)#
################ then I put 2 switchs connected (a normal portchannel each with 2 ports) but the same error happened###########
Cisco IOS Software, ME380x Software (ME380x-UNIVERSALK9-M), Version 15.3(1)S, RELEASE SOFTWARE (fc1)
*May 7 14:53:12.571: %PM-4-ERR_DISABLE: channel-misconfig (STP) error detected on Gi0/3, putting Gi0/3 in err-disable state
*May 7 14:53:12.571: %PM-4-ERR_DISABLE: channel-misconfig (STP) error detected on Gi0/4, putting Gi0/4 in err-disable state
*May 7 14:53:14.497: %LINK-3-UPDOWN: Interface GigabitEthernet0/3, changed state to down
*May 7 14:53:14.497: %LINK-3-UPDOWN: Interface GigabitEthernet0/4, changed state to down
Could you help me please?
05-08-2013 03:13 AM
You can't have a port channel between more than two switches (though this is supported on some platforms - http://www.cisco.com/en/US/docs/switches/datacenter/nexus1000/sw/4_0/interface/configuration/guide/if_5portchannel.html#wp1228139 )
The error you are seeing when you do the normal port channel looks like a config mismatch. Can you show the full interrface and port-channel configs from both sides?
05-08-2013 03:15 AM
Hi,
Could you try the following things:
1- Copy the configuration on notepad.
2- Remove the port-channel configuration and interfaces as well.
3- shut down the interfaces at one end.
4- Configure port-channel first at both the ends.
5- then apply the channel group command on the interfaces and configure the rest.
6- Also use one of the etherchannel protocol for the negotiation.
PAgP etherchannel (desirable|auto)
A port in the desirable mode can form an EtherChannel with another port that is in the desirable or auto mode.
A port in the auto mode can form an EtherChannel with another port in the desirable mode.
A port in the auto mode cannot form an EtherChannel with another port that is also in the auto mode because neither port starts PAgP negotiation.
_________________________
LACP etherchannel (passive|active)
A port in the active mode can form an EtherChannel with another port that is in the active or passive mode.
A port in the passive mode cannot form an EtherChannel with another port that is also in the passive mode because neither port starts LACP negotiation.
________________
Etherchannel without negotiation (on|on)
EtherChannel on mode can be used to manually configure an EtherChannel. The on mode forces a port to join an EtherChannel without negotiations. The on mode can be useful if the remote device does not support PAgP or LACP. In the on mode, a usable EtherChannel exists only when the switches at both ends of the link are configured in the on mode.
Ports that are configured in the on mode in the same channel group must have compatible port characteristics, such as speed and duplex. Ports that are not compatible are suspended, even though they are configured in the on mode.
HTH
Regards
Inayath
*Plz rate all usefull posts.
05-08-2013 03:16 AM
Hello
The physical interfaces need to be in the same channel-group for that particular aggregation link, they cannot span between two different switches for the same aggregation link
So on the switch with just one physical interface in each ehterchannel- try this:
baixo - towards swtich A
interface Port-channel12
port-type nni
switchport trunk allowed vlan 610,611
switchport mode trunk
end
interface GigabitEthernet0/3
port-type nni
switchport trunk allowed vlan 610,611
switchport mode trunk
channel-group 12 mode on
end
baixo - towards swtich B
interface Port-channel13
port-type nni
switchport trunk allowed vlan 610,611
switchport mode trunk
end
interface GigabitEthernet0/4
port-type nni
switchport trunk allowed vlan 610,611
switchport mode trunk
channel-group 13 mode on
L2 etherchannel
================
1)Config default physical interfaces involved
2)assign channel-group and channel-group number on the physical interfaces
on let port-channel be created automaticlly
3)create trunking encapsulation directly in port-channel interface config mode
4)reset physical interfaces "shut" "no shut"
res
Paul
Please don't forget to rate any posts that have been helpful.
Thanks.
05-08-2013 03:18 AM
Ahh,
I again overlooked the problem statement and can you clarify the following things:
1- R u trying to configure port-channel between the two devices? If yes then my above stated statements still hold the same.
2- If in case you are trying to port-channel from one device to 2 different switches then I am sorry to say this is not achievale with this device. This scenario is called as VPC and it would be done using the nexus/6500 etc...devices.
http://www.cisco.com/en/US/prod/collateral/switches/ps9441/ps9670/design_guide_c07-625857.pdf
HTH
Regards
Inayath
05-08-2013 03:40 AM
@ Inayath -
2- If in case you are trying to port-channel from one device to 2 different switches then I am sorry to say this is not achievale with this device. This scenario is called as VPC and it would be done using the nexus/6500 etc...devices.
I am on the understanding you can have multiple port-channels from one switch to multiple switches - as long as the physical interfaces in each port-channel are connecting to the same neighboring switch.
VPC - is the the physical interfaces in the same port-channel connecting to two different neighboring switches.
Please share your thoughts
res
Paul
Please don't forget to rate any posts that have been helpful.
Thanks.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide