cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3139
Views
0
Helpful
11
Replies

Port-Channel interface high utilization

jclj
Level 1
Level 1

Hello, i have a port channel with 3 links. The configuration is:

interface Port-channel2
 switchport
 switchport trunk encapsulation dot1q
 switchport mode trunk
end



!
interface GigabitEthernet2/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 logging event link-status
 logging event trunk-status
 channel-group 2 mode active
end

!
interface GigabitEthernet2/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 logging event link-status
 logging event trunk-status
 channel-group 2 mode active
end

!
interface GigabitEthernet2/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
 logging event link-status
 logging event trunk-status
 channel-group 2 mode active
end

A few times a week i am still seeing high utilization on one of the interfaces (random) and then it will drop. Since adding the 3rd link to the port-channel the channel itself doesn't drop, but when an interface goes down I have users saying their connected sessions (remote desktop/vnc/putty) drop and then reconnect. 

 

Would it be beneficial to configure load-balancing on the port-channel?

11 Replies 11

Hi @jclj

Which switch and IOS version do you have?

 

 

 

-If I helped you somehow, please, rate it as useful.-

jclj
Level 1
Level 1

3850 - CAT3K_CAA-UNIVERSALK9-M Version 3.58

4506 - cat4500-IPBASEK9-M, Version 12.2(31)SGA11

Serphentis
Level 1
Level 1

Hi jclj,

 

i had that issue with one of our own 3850 stacks, and it was down to the amount of links i had in the PO.

 

Load balancing is usualyl done autoamtecally over the EC links, and you can modify the method used, which could help you distribute the load.

 

however the load balncing algorithm used for EC is designed around usign equal amount of links, i.e. 2 , 4, 8, and this might help understand how this works:

 

Number of Ports in the EtherChannel Load Balancing
8 1:1:1:1:1:1:1:1
7 2:1:1:1:1:1:1
6 2:2:1:1:1:1
5 2:2:2:1:1
4 2:2:2:2
3 3:3:2
2 4:4

 

I fixed the issue on our side, by adding a 4th link to the EC, you can also try changing the LB method, depending of where that stack is located in your network, you can try sr-dst-ip or src-ip only or dst-ip only

 

 

jclj
Level 1
Level 1

Thanks, i can add another link to the channel and see if that helps. 

Can high utilization typically bring an interface down in a port-channel? I'm starting to think maybe it's something else, but not sure what to check.

The only reason an interface would go down is if you unplug it or goes in to err-disabled state.

High utilization would only lead to dropped packets, even if it runs at 100% it means that the the chances of output/input drops is very high, but it will not cause it to go down. User traffic going over that link would definitely notice being slow.

 

Do you see any errors on these interfaces show interface x what does it show ?

 

I am not sure what is behind that switch, but could be few things that i can think of that can cause high utilization, to name a few:

 

- Damaged cables on the links

- SNMP polling

- Backup Traffic

- Replication (SAN or the likes)

- A user machine with damaged NIC or Online Storage Uploads

- Broadcast storm

 

Do you have any monitoring software for that switch?  You can enable NetFlow depending on the Etherchannel type:

 

 

  • Flexible NetFlow is not supported on the L2 port-channel interface, but is supported on the L2 port-channel member ports.

     

  • Flexible NetFlow is not supported on the L3 port-channel member ports, but is supported on the L3 port-channel interface.

This can tell you which host (if any is causing the spike).

 

Lastly, how many VLANs traverse that link, you can prune those not needed?

 

 

 

I do see some overruns on the 4506 switch:

GigabitEthernet2/3 is up, line protocol is up (connected)
  Hardware is Gigabit Ethernet Port, address is 0018.73e2.0b62 (bia 0018.73e2.0b62)
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, link type is auto, media type is 10/100/1000-TX
  input flow-control is off, output flow-control is off
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:22, output never, output hang never
  Last clearing of "show interface" counters 3w6d
  Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 1367
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 804000 bits/sec, 152 packets/sec
  5 minute output rate 1379000 bits/sec, 367 packets/sec
     3170840628 packets input, 2503969654747 bytes, 0 no buffer
     Received 4906760 broadcasts (3465729 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 32895 overrun, 0 ignored
     0 input packets with dribble condition detected
     2491487039 packets output, 1632838824549 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

I see these overruns on all the interfaces of the 4506. I do not see them on the 3850 interfaces in the same port-channel.

This would indicate that the 3850 is sending too much frames and the 4506 is not capable of handling them correctly, this in turn would cause your interface on the 3850 to spike up, as it will fill the queues.

 

The most common reason would be that the Etherchannel is getting too much traffic, and if you add more links it should even out.

According to the output you have the flow-controls set to off, which can also help if you enable it, essentially it would allow the switch to inform the other side of the link that its receiving too much than it can process, so that the peer can either back of or switch to alternative link.

This needs to be enabled on both side, otherwise the Etherchannel wont form.

 Thanks, i'll add a 4th link. Is the flow control an interface configuration on both switches? Looks like i can just use:

 

Flowcontrol receive on

 

placed on all the 4506 interfaces in the portchannel or on the portchannel itself.

You should run that on the portchannel interface, if you run it on the individual interfaces, the line protocol would go down as it does not match the portchannel interface.

Apologies missed the first part, it is not necessary to be done on both switches, as long as the one that is having the overruns issue has it enabled it should do fine.
I have both flowcontrol receive and send on for all portchannels (both sides) in our environment as i find it very useful.

Hello


@jclj wrote:

Hello, i have a port channel with 3 links. The configuration is:


Would it be beneficial to configure load-balancing on the port-channel?


 

Absolutely - if you haven't done this then it would default based on hosts src-mac address - if this isn't applicable then recommend it is change to accommodate the correct traffic flow both ways

 

res
Paul

 

 

 


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: